6844759f70
using patch from https://github.com/antirez/redis/pull/3491 - data and configuration should not be publicly readable #1374700 - remove /var/run/redis with systemd #1374728 - provide redis-check-rdb as a symlink to redis-server #1374736 using patch from https://github.com/antirez/redis/pull/3494
23 lines
878 B
Diff
23 lines
878 B
Diff
From a34f7b1ac2cfb2879cc0889da0297aee96bcb076 Mon Sep 17 00:00:00 2001
|
|
From: Remi Collet <fedora@famillecollet.com>
|
|
Date: Fri, 9 Sep 2016 17:23:27 +0200
|
|
Subject: [PATCH] install redis-check-rdb as a symlink instead of duplicating
|
|
the binary
|
|
|
|
---
|
|
src/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/Makefile b/src/Makefile
|
|
index 6bd8d8d..4cc422e 100644
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -269,6 +269,6 @@ install: all
|
|
$(REDIS_INSTALL) $(REDIS_SERVER_NAME) $(INSTALL_BIN)
|
|
$(REDIS_INSTALL) $(REDIS_BENCHMARK_NAME) $(INSTALL_BIN)
|
|
$(REDIS_INSTALL) $(REDIS_CLI_NAME) $(INSTALL_BIN)
|
|
- $(REDIS_INSTALL) $(REDIS_CHECK_RDB_NAME) $(INSTALL_BIN)
|
|
$(REDIS_INSTALL) $(REDIS_CHECK_AOF_NAME) $(INSTALL_BIN)
|
|
@ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_SENTINEL_NAME)
|
|
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_RDB_NAME)
|