4d1e4c3aa9
Rebased patches
28 lines
794 B
Diff
28 lines
794 B
Diff
From d3cdf6aafbe700cd856440058e3b8a345838d326 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
|
Date: Mon, 8 Dec 2014 10:03:40 +0100
|
|
Subject: [PATCH 3/5] redis 2.8.18: use system jemalloc
|
|
|
|
---
|
|
src/Makefile | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/src/Makefile b/src/Makefile
|
|
index 8b3e959..af6a4fe 100644
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -90,8 +90,8 @@ endif
|
|
|
|
ifeq ($(MALLOC),jemalloc)
|
|
DEPENDENCY_TARGETS+= jemalloc
|
|
- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
|
|
- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
|
|
+ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
|
|
+ FINAL_LIBS+= -ljemalloc -ldl
|
|
endif
|
|
|
|
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
|
|
--
|
|
2.1.0
|
|
|