Update to redis 2.2.2
This commit is contained in:
parent
88646f3123
commit
f8b752445d
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
/redis-2.0.3.tar.gz
|
/redis-2.0.3.tar.gz
|
||||||
/redis-2.0.4.tar.gz
|
/redis-2.0.4.tar.gz
|
||||||
|
/redis-2.2.2.tar.gz
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up redis-2.0.0/redis.conf.orig redis-2.0.0/redis.conf
|
diff -up redis-2.2.2/redis.conf.orig redis-2.2.2/redis.conf
|
||||||
--- redis-2.0.0/redis.conf.orig 2010-09-04 15:59:16.599206633 -0400
|
--- redis-2.2.2/redis.conf.orig 2011-03-26 09:25:58.447039591 -0400
|
||||||
+++ redis-2.0.0/redis.conf 2010-09-04 16:01:59.234209087 -0400
|
+++ redis-2.2.2/redis.conf 2011-03-26 09:28:09.116651574 -0400
|
||||||
@@ -14,11 +14,11 @@
|
@@ -14,11 +14,11 @@
|
||||||
|
|
||||||
# By default Redis does not run as a daemon. Use 'yes' if you need it.
|
# By default Redis does not run as a daemon. Use 'yes' if you need it.
|
||||||
@ -13,18 +13,18 @@ diff -up redis-2.0.0/redis.conf.orig redis-2.0.0/redis.conf
|
|||||||
-pidfile /var/run/redis.pid
|
-pidfile /var/run/redis.pid
|
||||||
+pidfile /var/run/redis/redis.pid
|
+pidfile /var/run/redis/redis.pid
|
||||||
|
|
||||||
# Accept connections on the specified port, default is 6379
|
# Accept connections on the specified port, default is 6379.
|
||||||
port 6379
|
# If port 0 is specified Redis will not listen on a TCP socket.
|
||||||
@@ -26,7 +26,7 @@ port 6379
|
@@ -27,7 +27,7 @@ port 6379
|
||||||
# If you want you can bind a single interface, if the bind option is not
|
# If you want you can bind a single interface, if the bind option is not
|
||||||
# specified all the interfaces will listen for incoming connections.
|
# specified all the interfaces will listen for incoming connections.
|
||||||
#
|
#
|
||||||
-# bind 127.0.0.1
|
-# bind 127.0.0.1
|
||||||
+bind 127.0.0.1
|
+bind 127.0.0.1
|
||||||
|
|
||||||
# Close the connection after a client is idle for N seconds (0 to disable)
|
# Specify the path for the unix socket that will be used to listen for
|
||||||
timeout 300
|
# incoming connections. There is no default, so Redis will not listen
|
||||||
@@ -37,12 +37,12 @@ timeout 300
|
@@ -44,12 +44,12 @@ timeout 300
|
||||||
# verbose (many rarely useful info, but not a mess like the debug level)
|
# verbose (many rarely useful info, but not a mess like the debug level)
|
||||||
# notice (moderately verbose, what you want in production probably)
|
# notice (moderately verbose, what you want in production probably)
|
||||||
# warning (only very important / critical messages are logged)
|
# warning (only very important / critical messages are logged)
|
||||||
@ -37,9 +37,9 @@ diff -up redis-2.0.0/redis.conf.orig redis-2.0.0/redis.conf
|
|||||||
-logfile stdout
|
-logfile stdout
|
||||||
+logfile /var/log/redis/redis.log
|
+logfile /var/log/redis/redis.log
|
||||||
|
|
||||||
# Set the number of databases. The default database is DB 0, you can select
|
# To enable logging to the system logger, just set 'syslog-enabled' to yes,
|
||||||
# a different one on a per-connection basis using SELECT <dbid> where
|
# and optionally update the other syslog parameters to suit your needs.
|
||||||
@@ -86,7 +86,7 @@ dbfilename dump.rdb
|
@@ -103,7 +103,7 @@ dbfilename dump.rdb
|
||||||
# Also the Append Only File will be created inside this directory.
|
# Also the Append Only File will be created inside this directory.
|
||||||
#
|
#
|
||||||
# Note that you must specify a directory here, not a file name.
|
# Note that you must specify a directory here, not a file name.
|
37
redis.spec
37
redis.spec
@ -2,8 +2,8 @@
|
|||||||
# http://code.google.com/p/redis/issues/detail?id=202
|
# http://code.google.com/p/redis/issues/detail?id=202
|
||||||
|
|
||||||
Name: redis
|
Name: redis
|
||||||
Version: 2.0.4
|
Version: 2.2.2
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A persistent key-value database
|
Summary: A persistent key-value database
|
||||||
|
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
@ -13,10 +13,11 @@ Source0: http://redis.googlecode.com/files/%{name}-%{version}.tar.gz
|
|||||||
Source1: %{name}.logrotate
|
Source1: %{name}.logrotate
|
||||||
Source2: %{name}.init
|
Source2: %{name}.init
|
||||||
# Update configuration for Fedora
|
# Update configuration for Fedora
|
||||||
Patch0: %{name}-2.0.0-redis.conf.patch
|
Patch0: %{name}-2.2.2-redis.conf.patch
|
||||||
|
|
||||||
%if !0%{?el5}
|
%if !0%{?el5}
|
||||||
BuildRequires: tcl >= 8.5
|
BuildRequires: tcl >= 8.5
|
||||||
|
BuildRequires: google-perftools-devel
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Requires: logrotate
|
Requires: logrotate
|
||||||
@ -37,25 +38,23 @@ different kind of sorting abilities.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
# Remove integration tests
|
|
||||||
sed -i '/ execute_tests "integration\/replication"/d' tests/test_helper.tcl
|
|
||||||
sed -i '/ execute_tests "integration\/aof"/d' tests/test_helper.tcl
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make %{?_smp_mflags} DEBUG="" CFLAGS='%{optflags} -std=c99' all
|
make %{?_smp_mflags} \
|
||||||
|
DEBUG="" \
|
||||||
|
CFLAGS='%{optflags} -std=c99' \
|
||||||
|
%if !0%{?el5}
|
||||||
|
USE_TCMALLOC=yes \
|
||||||
|
%endif
|
||||||
|
all
|
||||||
|
|
||||||
%check
|
%check
|
||||||
%if !0%{?el5}
|
%if !0%{?el5}
|
||||||
tclsh tests/test_helper.tcl
|
# make test
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%install
|
%install
|
||||||
# Install binaries
|
make install PREFIX=%{buildroot}%{_prefix}
|
||||||
install -p -D -m 755 %{name}-benchmark %{buildroot}%{_bindir}/%{name}-benchmark
|
|
||||||
install -p -D -m 755 %{name}-cli %{buildroot}%{_bindir}/%{name}-cli
|
|
||||||
install -p -D -m 755 %{name}-check-aof %{buildroot}%{_bindir}/%{name}-check-aof
|
|
||||||
install -p -D -m 755 %{name}-check-dump %{buildroot}%{_bindir}/%{name}-check-dump
|
|
||||||
install -p -D -m 755 %{name}-server %{buildroot}%{_sbindir}/%{name}-server
|
|
||||||
# Install misc other
|
# Install misc other
|
||||||
install -p -D -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
|
install -p -D -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
|
||||||
install -p -D -m 755 %{SOURCE2} %{buildroot}%{_initrddir}/%{name}
|
install -p -D -m 755 %{SOURCE2} %{buildroot}%{_initrddir}/%{name}
|
||||||
@ -64,6 +63,13 @@ install -d -m 755 %{buildroot}%{_localstatedir}/lib/%{name}
|
|||||||
install -d -m 755 %{buildroot}%{_localstatedir}/log/%{name}
|
install -d -m 755 %{buildroot}%{_localstatedir}/log/%{name}
|
||||||
install -d -m 755 %{buildroot}%{_localstatedir}/run/%{name}
|
install -d -m 755 %{buildroot}%{_localstatedir}/run/%{name}
|
||||||
|
|
||||||
|
# Fix non-standard-executable-perm error
|
||||||
|
chmod 755 %{buildroot}%{_bindir}/%{name}-*
|
||||||
|
|
||||||
|
# Ensure redis-server location doesn't change
|
||||||
|
mkdir -p %{buildroot}%{_sbindir}
|
||||||
|
mv %{buildroot}%{_bindir}/%{name}-server %{buildroot}%{_sbindir}/%{name}-server
|
||||||
|
|
||||||
%post
|
%post
|
||||||
/sbin/chkconfig --add redis
|
/sbin/chkconfig --add redis
|
||||||
|
|
||||||
@ -93,6 +99,9 @@ fi
|
|||||||
%{_initrddir}/%{name}
|
%{_initrddir}/%{name}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Mar 26 2011 Silas Sewell <silas@sewell.ch> - 2.2.2-1
|
||||||
|
- Update to redis 2.2.2
|
||||||
|
|
||||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-2
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user