Add a patch to fix SDS_NOINIT extern definition.
Resolves Red Hat BZ #1799969
This commit is contained in:
parent
4efe1163c9
commit
c84f0b33e4
@ -1,7 +1,7 @@
|
|||||||
From ae2235dab50c86480ee37f50119af6668f312ba3 Mon Sep 17 00:00:00 2001
|
From d68953c34d4d6987883ddf6158c3c69e7500667f Mon Sep 17 00:00:00 2001
|
||||||
From: Remi Collet <fedora@famillecollet.com>
|
From: Remi Collet <fedora@famillecollet.com>
|
||||||
Date: Thu, 8 Sep 2016 14:51:15 +0200
|
Date: Thu, 8 Sep 2016 14:51:15 +0200
|
||||||
Subject: [PATCH 1/2] 1st man pageis for - redis-cli - redis-benchmark -
|
Subject: [PATCH 1/3] 1st man pageis for - redis-cli - redis-benchmark -
|
||||||
redis-check-aof - redis-check-rdb - redis-server - redis.conf
|
redis-check-aof - redis-check-rdb - redis-server - redis.conf
|
||||||
|
|
||||||
as redis-sentinel is a symlink to redis-server, same page can be used (also symlinked)
|
as redis-sentinel is a symlink to redis-server, same page can be used (also symlinked)
|
||||||
@ -648,5 +648,5 @@ index 0000000..1e0c9c9
|
|||||||
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
||||||
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
--
|
--
|
||||||
2.20.1
|
2.24.1
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
From 85d847361b519dca524178e3197dbb0ed24e0cb5 Mon Sep 17 00:00:00 2001
|
From 79ed52edf84676786e5817cddb8914c5925144c7 Mon Sep 17 00:00:00 2001
|
||||||
From: Remi Collet <fedora@famillecollet.com>
|
From: Remi Collet <fedora@famillecollet.com>
|
||||||
Date: Fri, 9 Sep 2016 17:23:27 +0200
|
Date: Fri, 9 Sep 2016 17:23:27 +0200
|
||||||
Subject: [PATCH 2/2] install redis-check-rdb as a symlink instead of
|
Subject: [PATCH 2/3] install redis-check-rdb as a symlink instead of
|
||||||
duplicating the binary
|
duplicating the binary
|
||||||
|
|
||||||
---
|
---
|
||||||
@ -25,5 +25,5 @@ index 2a68649..585c95b 100644
|
|||||||
uninstall:
|
uninstall:
|
||||||
rm -f $(INSTALL_BIN)/{$(REDIS_SERVER_NAME),$(REDIS_BENCHMARK_NAME),$(REDIS_CLI_NAME),$(REDIS_CHECK_RDB_NAME),$(REDIS_CHECK_AOF_NAME),$(REDIS_SENTINEL_NAME)}
|
rm -f $(INSTALL_BIN)/{$(REDIS_SERVER_NAME),$(REDIS_BENCHMARK_NAME),$(REDIS_CLI_NAME),$(REDIS_CHECK_RDB_NAME),$(REDIS_CHECK_AOF_NAME),$(REDIS_SENTINEL_NAME)}
|
||||||
--
|
--
|
||||||
2.20.1
|
2.24.1
|
||||||
|
|
||||||
|
29
0003-Mark-extern-definition-of-SDS_NOINIT-in-sds.h.patch
Normal file
29
0003-Mark-extern-definition-of-SDS_NOINIT-in-sds.h.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From df079a0b34f922b75ad388b16f8f7eace52a09b0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Khem Raj <raj.khem@gmail.com>
|
||||||
|
Date: Wed, 12 Feb 2020 16:16:41 +1100
|
||||||
|
Subject: [PATCH 3/3] Mark extern definition of SDS_NOINIT in sds.h
|
||||||
|
|
||||||
|
This helps avoiding multiple definition of this variable, its also
|
||||||
|
defined globally in sds.c
|
||||||
|
|
||||||
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||||
|
---
|
||||||
|
src/sds.h | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/sds.h b/src/sds.h
|
||||||
|
index 1bdb60d..adcc12c 100644
|
||||||
|
--- a/src/sds.h
|
||||||
|
+++ b/src/sds.h
|
||||||
|
@@ -34,7 +34,7 @@
|
||||||
|
#define __SDS_H
|
||||||
|
|
||||||
|
#define SDS_MAX_PREALLOC (1024*1024)
|
||||||
|
-const char *SDS_NOINIT;
|
||||||
|
+extern const char *SDS_NOINIT;
|
||||||
|
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <stdarg.h>
|
||||||
|
--
|
||||||
|
2.24.1
|
||||||
|
|
10
redis.spec
10
redis.spec
@ -20,7 +20,7 @@
|
|||||||
|
|
||||||
Name: redis
|
Name: redis
|
||||||
Version: 5.0.7
|
Version: 5.0.7
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: A persistent key-value database
|
Summary: A persistent key-value database
|
||||||
# redis, linenoise, lzf, hiredis are BSD
|
# redis, linenoise, lzf, hiredis are BSD
|
||||||
# lua is MIT
|
# lua is MIT
|
||||||
@ -48,6 +48,8 @@ Source10: https://github.com/antirez/%{name}-doc/archive/%{doc_commit}/
|
|||||||
Patch0001: 0001-1st-man-pageis-for-redis-cli-redis-benchmark-redis-c.patch
|
Patch0001: 0001-1st-man-pageis-for-redis-cli-redis-benchmark-redis-c.patch
|
||||||
# https://github.com/antirez/redis/pull/3494 - symlink
|
# https://github.com/antirez/redis/pull/3494 - symlink
|
||||||
Patch0002: 0002-install-redis-check-rdb-as-a-symlink-instead-of-dupl.patch
|
Patch0002: 0002-install-redis-check-rdb-as-a-symlink-instead-of-dupl.patch
|
||||||
|
# https://github.com/antirez/redis/pull/6691 - gcc v10
|
||||||
|
Patch0003: 0003-Mark-extern-definition-of-SDS_NOINIT-in-sds.h.patch
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
%if 0%{?with_tests}
|
%if 0%{?with_tests}
|
||||||
BuildRequires: procps-ng
|
BuildRequires: procps-ng
|
||||||
@ -55,7 +57,7 @@ BuildRequires: tcl
|
|||||||
%endif
|
%endif
|
||||||
BuildRequires: systemd
|
BuildRequires: systemd
|
||||||
# redis-trib functionality migrated to redis-cli
|
# redis-trib functionality migrated to redis-cli
|
||||||
Obsoletes: redis-trib
|
Obsoletes: redis-trib < 5
|
||||||
# Required for redis-shutdown
|
# Required for redis-shutdown
|
||||||
Requires: /bin/awk
|
Requires: /bin/awk
|
||||||
Requires: logrotate
|
Requires: logrotate
|
||||||
@ -125,6 +127,7 @@ administration and development.
|
|||||||
mv ../%{name}-doc-%{doc_commit} doc
|
mv ../%{name}-doc-%{doc_commit} doc
|
||||||
%patch0001 -p1
|
%patch0001 -p1
|
||||||
%patch0002 -p1
|
%patch0002 -p1
|
||||||
|
%patch0003 -p1
|
||||||
|
|
||||||
mv deps/lua/COPYRIGHT COPYRIGHT-lua
|
mv deps/lua/COPYRIGHT COPYRIGHT-lua
|
||||||
mv deps/hiredis/COPYING COPYING-hiredis
|
mv deps/hiredis/COPYING COPYING-hiredis
|
||||||
@ -272,6 +275,9 @@ exit 0
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 12 2020 Nathan Scott <nathans@redhat.com> - 5.0.7-3
|
||||||
|
- Patch extern SDS_NOINIT definition for gcc 10 (RHBZ #1799969)
|
||||||
|
|
||||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.7-2
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.7-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user