Update to latest community sources
This commit is contained in:
parent
5b0571d432
commit
bea1cbef61
2
.gitignore
vendored
2
.gitignore
vendored
@ -56,3 +56,5 @@ clog
|
|||||||
/redis-doc-a59c016.tar.gz
|
/redis-doc-a59c016.tar.gz
|
||||||
/redis-5.0.3.tar.gz
|
/redis-5.0.3.tar.gz
|
||||||
/redis-doc-a1e79fc.tar.gz
|
/redis-doc-a1e79fc.tar.gz
|
||||||
|
/redis-5.0.4.tar.gz
|
||||||
|
/redis-doc-8c32249.tar.gz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From c7958ad1c0d615b81276ec2d4dbc1bf6a67dcc4d Mon Sep 17 00:00:00 2001
|
From ae2235dab50c86480ee37f50119af6668f312ba3 Mon Sep 17 00:00:00 2001
|
||||||
From: Remi Collet <fedora@famillecollet.com>
|
From: Remi Collet <fedora@famillecollet.com>
|
||||||
Date: Thu, 8 Sep 2016 14:51:15 +0200
|
Date: Thu, 8 Sep 2016 14:51:15 +0200
|
||||||
Subject: [PATCH 1/2] 1st man pageis for - redis-cli - redis-benchmark -
|
Subject: [PATCH 1/2] 1st man pageis for - redis-cli - redis-benchmark -
|
||||||
@ -7,12 +7,12 @@ Subject: [PATCH 1/2] 1st man pageis for - redis-cli - redis-benchmark -
|
|||||||
as redis-sentinel is a symlink to redis-server, same page can be used (also symlinked)
|
as redis-sentinel is a symlink to redis-server, same page can be used (also symlinked)
|
||||||
redis.conf can also be used for sentinel.conf
|
redis.conf can also be used for sentinel.conf
|
||||||
---
|
---
|
||||||
man/man1/redis-benchmark.1 | 132 ++++++++++++++++++++++++++++++++++
|
man/man1/redis-benchmark.1 | 132 ++++++++++++++++++++++++++++
|
||||||
man/man1/redis-check-aof.1 | 60 ++++++++++++++++
|
man/man1/redis-check-aof.1 | 60 +++++++++++++
|
||||||
man/man1/redis-check-rdb.1 | 53 ++++++++++++++
|
man/man1/redis-check-rdb.1 | 53 ++++++++++++
|
||||||
man/man1/redis-cli.1 | 171 +++++++++++++++++++++++++++++++++++++++++++++
|
man/man1/redis-cli.1 | 171 +++++++++++++++++++++++++++++++++++++
|
||||||
man/man1/redis-server.1 | 117 +++++++++++++++++++++++++++++++
|
man/man1/redis-server.1 | 117 +++++++++++++++++++++++++
|
||||||
man/man5/redis.conf.5 | 57 +++++++++++++++
|
man/man5/redis.conf.5 | 57 +++++++++++++
|
||||||
6 files changed, 590 insertions(+)
|
6 files changed, 590 insertions(+)
|
||||||
create mode 100644 man/man1/redis-benchmark.1
|
create mode 100644 man/man1/redis-benchmark.1
|
||||||
create mode 100644 man/man1/redis-check-aof.1
|
create mode 100644 man/man1/redis-check-aof.1
|
||||||
@ -648,5 +648,5 @@ index 0000000..1e0c9c9
|
|||||||
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
||||||
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
--
|
--
|
||||||
2.13.5
|
2.20.1
|
||||||
|
|
||||||
|
@ -1,18 +1,18 @@
|
|||||||
From 992c773e70462a6fbe1536e18e673c9ab55d5901 Mon Sep 17 00:00:00 2001
|
From 85d847361b519dca524178e3197dbb0ed24e0cb5 Mon Sep 17 00:00:00 2001
|
||||||
From: Remi Collet <fedora@famillecollet.com>
|
From: Remi Collet <fedora@famillecollet.com>
|
||||||
Date: Fri, 9 Sep 2016 17:23:27 +0200
|
Date: Fri, 9 Sep 2016 17:23:27 +0200
|
||||||
Subject: [PATCH 2/2] install redis-check-rdb as a symlink instead of duplicating
|
Subject: [PATCH 2/2] install redis-check-rdb as a symlink instead of
|
||||||
the binary
|
duplicating the binary
|
||||||
|
|
||||||
---
|
---
|
||||||
src/Makefile | 4 ++--
|
src/Makefile | 4 ++--
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/Makefile b/src/Makefile
|
diff --git a/src/Makefile b/src/Makefile
|
||||||
index fdbe36a..c3083f8 100644
|
index 2a68649..585c95b 100644
|
||||||
--- a/src/Makefile
|
--- a/src/Makefile
|
||||||
+++ b/src/Makefile
|
+++ b/src/Makefile
|
||||||
@@ -287,6 +287,6 @@ install: all
|
@@ -307,9 +307,9 @@ install: all
|
||||||
$(REDIS_INSTALL) $(REDIS_SERVER_NAME) $(INSTALL_BIN)
|
$(REDIS_INSTALL) $(REDIS_SERVER_NAME) $(INSTALL_BIN)
|
||||||
$(REDIS_INSTALL) $(REDIS_BENCHMARK_NAME) $(INSTALL_BIN)
|
$(REDIS_INSTALL) $(REDIS_BENCHMARK_NAME) $(INSTALL_BIN)
|
||||||
$(REDIS_INSTALL) $(REDIS_CLI_NAME) $(INSTALL_BIN)
|
$(REDIS_INSTALL) $(REDIS_CLI_NAME) $(INSTALL_BIN)
|
||||||
@ -21,6 +21,9 @@ index fdbe36a..c3083f8 100644
|
|||||||
@ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_SENTINEL_NAME)
|
@ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_SENTINEL_NAME)
|
||||||
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_RDB_NAME)
|
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_RDB_NAME)
|
||||||
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_AOF_NAME)
|
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_AOF_NAME)
|
||||||
--
|
|
||||||
2.13.5
|
uninstall:
|
||||||
|
rm -f $(INSTALL_BIN)/{$(REDIS_SERVER_NAME),$(REDIS_BENCHMARK_NAME),$(REDIS_CLI_NAME),$(REDIS_CHECK_RDB_NAME),$(REDIS_CHECK_AOF_NAME),$(REDIS_SENTINEL_NAME)}
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
||||||
|
10
redis.spec
10
redis.spec
@ -24,15 +24,15 @@
|
|||||||
|
|
||||||
# Commit IDs for the (unversioned) redis-doc repository
|
# Commit IDs for the (unversioned) redis-doc repository
|
||||||
# https://fedoraproject.org/wiki/Packaging:SourceURL "Commit Revision"
|
# https://fedoraproject.org/wiki/Packaging:SourceURL "Commit Revision"
|
||||||
%global doc_commit a1e79fc9b2f42f04a8ab59c05c3228931adcd0a6
|
%global doc_commit 8c322492b0ad14067bd4cebce20f3509d989370d
|
||||||
%global short_doc_commit %(c=%{doc_commit}; echo ${c:0:7})
|
%global short_doc_commit %(c=%{doc_commit}; echo ${c:0:7})
|
||||||
|
|
||||||
# %%{rpmmacrodir} not usable on EL-6
|
# %%{rpmmacrodir} not usable on EL-6
|
||||||
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
||||||
|
|
||||||
Name: redis
|
Name: redis
|
||||||
Version: 5.0.3
|
Version: 5.0.4
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A persistent key-value database
|
Summary: A persistent key-value database
|
||||||
# redis, linenoise, lzf, hiredis are BSD
|
# redis, linenoise, lzf, hiredis are BSD
|
||||||
# lua is MIT
|
# lua is MIT
|
||||||
@ -358,6 +358,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 19 2019 Nathan Scott <nathans@redhat.com> - 5.0.4-1
|
||||||
|
- Upstream 5.0.4 release and redis-doc updates.
|
||||||
|
- Fix sentinel.conf logfile line addition.
|
||||||
|
|
||||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.3-2
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.3-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (redis-5.0.3.tar.gz) = 5915b14502438bf7c3f56e38640dda54b095bd87501aefa6e386c9cef48e8d1e625e980643d128d91b8cab26dd51d5d99ca66fa638dc04e5ba315fe43f11f58b
|
SHA512 (redis-5.0.4.tar.gz) = 336929c81a476e2a23a64f867823d70c3aab66fb0098eef2e61630be6522ff2f6af680169ffcae35d559758b2c6b56f88c5a953a538291fea886449cba33b8ad
|
||||||
SHA512 (redis-doc-a1e79fc.tar.gz) = c135d450e073d5383072d94506b49a209d92fa03b7ad404693d19c236fa162ef51a78bbc202eb75af811665b3a768f523bce906967d6f084d2aca7b2c0f6625f
|
SHA512 (redis-doc-8c32249.tar.gz) = bfdcb7824bb4e240c93e8fceb85d566831a0696d90848a99c2e870168074ea16f4b0a72f0545bcf5d6dc4d7d03d0426b453b81e10e3b176feec5ff6b14fc9acb
|
||||||
|
Loading…
Reference in New Issue
Block a user