Upstream 3.2.7 (important security fix)
This commit is contained in:
parent
93650f449c
commit
8cbea8c9c3
@ -1,4 +1,4 @@
|
|||||||
From 2c3b48cf7fb494e21aa47c03c1de9ce2ee9ccd37 Mon Sep 17 00:00:00 2001
|
From cbd4460b0c1a8614644171904e3522ffbe001b48 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||||
Date: Fri, 5 Dec 2014 14:11:15 +0100
|
Date: Fri, 5 Dec 2014 14:11:15 +0100
|
||||||
Subject: [PATCH 1/7] redis 3.2.3: redis conf
|
Subject: [PATCH 1/7] redis 3.2.3: redis conf
|
||||||
@ -30,5 +30,5 @@ index 22e00bc..2bcddb8 100644
|
|||||||
################################# REPLICATION #################################
|
################################# REPLICATION #################################
|
||||||
|
|
||||||
--
|
--
|
||||||
2.9.0
|
2.9.3
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 0305001c78ce0304ade54e3f28396bc43763074a Mon Sep 17 00:00:00 2001
|
From efdb3b41171d335511af511b0a0cdf43cde2144a Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||||
Date: Mon, 8 Dec 2014 10:02:54 +0100
|
Date: Mon, 8 Dec 2014 10:02:54 +0100
|
||||||
Subject: [PATCH 2/7] redis 3.2.3: deps library fPIC performance tuning
|
Subject: [PATCH 2/7] redis 3.2.3: deps library fPIC performance tuning
|
||||||
@ -49,5 +49,5 @@ index 1dd894b..712f2a6 100644
|
|||||||
DEBUG= -g
|
DEBUG= -g
|
||||||
|
|
||||||
--
|
--
|
||||||
2.9.0
|
2.9.3
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 5c26d1b71675c91ebbcc43c0a9a6c9359e92fd60 Mon Sep 17 00:00:00 2001
|
From 028b374759921656cb8a1e46198c8abbb62a4f0d Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||||
Date: Mon, 8 Dec 2014 10:03:40 +0100
|
Date: Mon, 8 Dec 2014 10:03:40 +0100
|
||||||
Subject: [PATCH 3/7] redis 2.8.18: use system jemalloc
|
Subject: [PATCH 3/7] redis 2.8.18: use system jemalloc
|
||||||
@ -8,20 +8,20 @@ Subject: [PATCH 3/7] redis 2.8.18: use system jemalloc
|
|||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/Makefile b/src/Makefile
|
diff --git a/src/Makefile b/src/Makefile
|
||||||
index 648127a..d513859 100644
|
index fdbe36a..6c27dd9 100644
|
||||||
--- a/src/Makefile
|
--- a/src/Makefile
|
||||||
+++ b/src/Makefile
|
+++ b/src/Makefile
|
||||||
@@ -94,8 +94,8 @@ endif
|
@@ -104,8 +104,8 @@ endif
|
||||||
|
|
||||||
ifeq ($(MALLOC),jemalloc)
|
ifeq ($(MALLOC),jemalloc)
|
||||||
DEPENDENCY_TARGETS+= jemalloc
|
DEPENDENCY_TARGETS+= jemalloc
|
||||||
- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
|
- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
|
||||||
- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
|
- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a
|
||||||
+ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
|
+ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
|
||||||
+ FINAL_LIBS+= -ljemalloc -ldl
|
+ FINAL_LIBS+= -ljemalloc -ldl
|
||||||
endif
|
endif
|
||||||
|
|
||||||
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
|
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
|
||||||
--
|
--
|
||||||
2.9.0
|
2.9.3
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 8658b92caa8da108a3cdaae7a5d69da43fb4e22e Mon Sep 17 00:00:00 2001
|
From a39e81c428eac6745a1aa7d87ca64d78e335b2c3 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||||
Date: Mon, 8 Dec 2014 10:04:18 +0100
|
Date: Mon, 8 Dec 2014 10:04:18 +0100
|
||||||
Subject: [PATCH 4/7] redis 2.8.18: disable test failed on slow machine
|
Subject: [PATCH 4/7] redis 2.8.18: disable test failed on slow machine
|
||||||
@ -20,5 +20,5 @@ index 9a6e673..0891619 100644
|
|||||||
integration/rdb
|
integration/rdb
|
||||||
integration/convert-zipmap-hash-on-load
|
integration/convert-zipmap-hash-on-load
|
||||||
--
|
--
|
||||||
2.9.0
|
2.9.3
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 833926e852de5bfc46021178c3edb90312c7db41 Mon Sep 17 00:00:00 2001
|
From 8aa7a039b6b23f7e9fdb9a459e975f216dd8fdba Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||||
Date: Sat, 13 Sep 2014 14:03:04 +0200
|
Date: Sat, 13 Sep 2014 14:03:04 +0200
|
||||||
Subject: [PATCH 5/7] redis 2.8.18: sentinel configuration file fix
|
Subject: [PATCH 5/7] redis 2.8.18: sentinel configuration file fix
|
||||||
@ -25,5 +25,5 @@ index 0e1b266..428e7b6 100644
|
|||||||
#
|
#
|
||||||
# sentinel notification-script and sentinel reconfig-script are used in order
|
# sentinel notification-script and sentinel reconfig-script are used in order
|
||||||
--
|
--
|
||||||
2.9.0
|
2.9.3
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 81a1b8a6e37a83e0dc99c770d5c734c13a0fcb27 Mon Sep 17 00:00:00 2001
|
From e1ded77b1f80a5241f2f9b5088b9063ecbeb72c9 Mon Sep 17 00:00:00 2001
|
||||||
From: Remi Collet <fedora@famillecollet.com>
|
From: Remi Collet <fedora@famillecollet.com>
|
||||||
Date: Thu, 8 Sep 2016 14:51:15 +0200
|
Date: Thu, 8 Sep 2016 14:51:15 +0200
|
||||||
Subject: [PATCH 6/7] 1st man pageis for - redis-cli - redis-benchmark -
|
Subject: [PATCH 6/7] 1st man pageis for - redis-cli - redis-benchmark -
|
||||||
@ -648,5 +648,5 @@ index 0000000..1e0c9c9
|
|||||||
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
||||||
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
--
|
--
|
||||||
2.9.0
|
2.9.3
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 4bdb4b591f61566caf65fbdb8e72da672fe1b737 Mon Sep 17 00:00:00 2001
|
From bcd509def0d4a75f56d9d6a53eea280127803eb4 Mon Sep 17 00:00:00 2001
|
||||||
From: Remi Collet <fedora@famillecollet.com>
|
From: Remi Collet <fedora@famillecollet.com>
|
||||||
Date: Fri, 9 Sep 2016 17:23:27 +0200
|
Date: Fri, 9 Sep 2016 17:23:27 +0200
|
||||||
Subject: [PATCH 7/7] install redis-check-rdb as a symlink instead of
|
Subject: [PATCH 7/7] install redis-check-rdb as a symlink instead of
|
||||||
@ -9,10 +9,10 @@ Subject: [PATCH 7/7] install redis-check-rdb as a symlink instead of
|
|||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/src/Makefile b/src/Makefile
|
diff --git a/src/Makefile b/src/Makefile
|
||||||
index d513859..ffc926b 100644
|
index 6c27dd9..2de5e3f 100644
|
||||||
--- a/src/Makefile
|
--- a/src/Makefile
|
||||||
+++ b/src/Makefile
|
+++ b/src/Makefile
|
||||||
@@ -257,6 +257,6 @@ install: all
|
@@ -267,6 +267,6 @@ install: all
|
||||||
$(REDIS_INSTALL) $(REDIS_SERVER_NAME) $(INSTALL_BIN)
|
$(REDIS_INSTALL) $(REDIS_SERVER_NAME) $(INSTALL_BIN)
|
||||||
$(REDIS_INSTALL) $(REDIS_BENCHMARK_NAME) $(INSTALL_BIN)
|
$(REDIS_INSTALL) $(REDIS_BENCHMARK_NAME) $(INSTALL_BIN)
|
||||||
$(REDIS_INSTALL) $(REDIS_CLI_NAME) $(INSTALL_BIN)
|
$(REDIS_INSTALL) $(REDIS_CLI_NAME) $(INSTALL_BIN)
|
||||||
@ -21,5 +21,5 @@ index d513859..ffc926b 100644
|
|||||||
@ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_SENTINEL_NAME)
|
@ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_SENTINEL_NAME)
|
||||||
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_RDB_NAME)
|
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_RDB_NAME)
|
||||||
--
|
--
|
||||||
2.9.0
|
2.9.3
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@
|
|||||||
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
|
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
|
||||||
|
|
||||||
Name: redis
|
Name: redis
|
||||||
Version: 3.2.4
|
Version: 3.2.7
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A persistent key-value database
|
Summary: A persistent key-value database
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -252,6 +252,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Feb 4 2017 Haïkel Guémar <hguemar@fedoraproject.org> - 3.2.7-1
|
||||||
|
- Upstream 3.2.7 (important security fix)
|
||||||
|
|
||||||
* Mon Sep 26 2016 Haïkel Guémar <hguemar@fedoraproject.org> - 3.2.4-1
|
* Mon Sep 26 2016 Haïkel Guémar <hguemar@fedoraproject.org> - 3.2.4-1
|
||||||
- Upstream 3.2.4
|
- Upstream 3.2.4
|
||||||
- Fix buffer overlow (TALOS-2016-0206)
|
- Fix buffer overlow (TALOS-2016-0206)
|
||||||
|
Loading…
Reference in New Issue
Block a user