Upstream 6.0.6 release.
drop patch merged upstream open https://github.com/redis/redis/pull/7543 fix deprecated tail syntax
This commit is contained in:
parent
df1fc55f35
commit
8b33f75e64
2
.gitignore
vendored
2
.gitignore
vendored
@ -72,3 +72,5 @@ clog
|
|||||||
/redis-6.0.4.tar.gz
|
/redis-6.0.4.tar.gz
|
||||||
/redis-doc-f092dd3.tar.gz
|
/redis-doc-f092dd3.tar.gz
|
||||||
/redis-6.0.5.tar.gz
|
/redis-6.0.5.tar.gz
|
||||||
|
/redis-6.0.6.tar.gz
|
||||||
|
/redis-doc-02423fd.tar.gz
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
diff --git a/0003-Notify-systemd-on-sentinel-startup.patch b/0003-Notify-systemd-on-sentinel-startup.patch
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..ee58b56
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/0003-Notify-systemd-on-sentinel-startup.patch
|
|
||||||
@@ -0,0 +1,24 @@
|
|
||||||
+From 16dbe5168224b9f8a2b193f014f3dbf7e9604516 Mon Sep 17 00:00:00 2001
|
|
||||||
+From: Daniel Murnane <dmurnane@eitccorp.com>
|
|
||||||
+Date: Fri, 1 May 2020 08:19:28 -0400
|
|
||||||
+Subject: [PATCH] Notify systemd on sentinel startup
|
|
||||||
+
|
|
||||||
+---
|
|
||||||
+ src/server.c | 4 ++++
|
|
||||||
+ 1 file changed, 4 insertions(+)
|
|
||||||
+
|
|
||||||
+diff --git a/src/server.c b/src/server.c
|
|
||||||
+index 659604ef363..7ab7c39fd0a 100644
|
|
||||||
+--- a/src/server.c
|
|
||||||
++++ b/src/server.c
|
|
||||||
+@@ -5111,6 +5111,10 @@ int main(int argc, char **argv) {
|
|
||||||
+ } else {
|
|
||||||
+ InitServerLast();
|
|
||||||
+ sentinelIsRunning();
|
|
||||||
++ if (server.supervised_mode == SUPERVISED_SYSTEMD) {
|
|
||||||
++ redisCommunicateSystemd("STATUS=Ready to accept connections\n");
|
|
||||||
++ redisCommunicateSystemd("READY=1\n");
|
|
||||||
++ }
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ /* Warning the user about suspicious maxmemory setting. */
|
|
22
0003-fix-deprecated-tail-syntax.patch
Normal file
22
0003-fix-deprecated-tail-syntax.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
From b5fc5d0a1bc4d959995688c8b363daa859c44036 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Remi Collet <remi@remirepo.net>
|
||||||
|
Date: Tue, 21 Jul 2020 07:33:12 +0200
|
||||||
|
Subject: [PATCH] Fix deprecated syntax
|
||||||
|
|
||||||
|
---
|
||||||
|
tests/support/util.tcl | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/tests/support/util.tcl b/tests/support/util.tcl
|
||||||
|
index fce3ffd1858..69ea675dca5 100644
|
||||||
|
--- a/tests/support/util.tcl
|
||||||
|
+++ b/tests/support/util.tcl
|
||||||
|
@@ -119,7 +119,7 @@ proc wait_for_log_message {srv_idx pattern from_line maxtries delay} {
|
||||||
|
set retry $maxtries
|
||||||
|
set stdout [srv $srv_idx stdout]
|
||||||
|
while {$retry} {
|
||||||
|
- set result [exec tail +$from_line < $stdout]
|
||||||
|
+ set result [exec tail -n +$from_line < $stdout]
|
||||||
|
set result [split $result "\n"]
|
||||||
|
foreach line $result {
|
||||||
|
if {[string match $pattern $line]} {
|
20
redis.spec
20
redis.spec
@ -8,18 +8,18 @@
|
|||||||
#
|
#
|
||||||
|
|
||||||
# Tests fail in mock, not in local build.
|
# Tests fail in mock, not in local build.
|
||||||
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
|
%bcond_with tests
|
||||||
|
|
||||||
# Commit IDs for the (unversioned) redis-doc repository
|
# Commit IDs for the (unversioned) redis-doc repository
|
||||||
# https://fedoraproject.org/wiki/Packaging:SourceURL "Commit Revision"
|
# https://fedoraproject.org/wiki/Packaging:SourceURL "Commit Revision"
|
||||||
%global doc_commit f092dd3227cc74978853e379c0a7731bdaa324af
|
%global doc_commit 02423fd2f5603ae300654613a51eaee13bc5cb80
|
||||||
%global short_doc_commit %(c=%{doc_commit}; echo ${c:0:7})
|
%global short_doc_commit %(c=%{doc_commit}; echo ${c:0:7})
|
||||||
|
|
||||||
# %%{rpmmacrodir} not usable on EL-6
|
# %%{rpmmacrodir} not usable on EL-6
|
||||||
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
||||||
|
|
||||||
Name: redis
|
Name: redis
|
||||||
Version: 6.0.5
|
Version: 6.0.6
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A persistent key-value database
|
Summary: A persistent key-value database
|
||||||
# redis, linenoise, lzf, hiredis are BSD
|
# redis, linenoise, lzf, hiredis are BSD
|
||||||
@ -48,10 +48,11 @@ Source10: https://github.com/antirez/%{name}-doc/archive/%{doc_commit}/
|
|||||||
Patch0001: 0001-1st-man-pageis-for-redis-cli-redis-benchmark-redis-c.patch
|
Patch0001: 0001-1st-man-pageis-for-redis-cli-redis-benchmark-redis-c.patch
|
||||||
# https://github.com/antirez/redis/pull/3494 - symlink
|
# https://github.com/antirez/redis/pull/3494 - symlink
|
||||||
Patch0002: 0002-install-redis-check-rdb-as-a-symlink-instead-of-dupl.patch
|
Patch0002: 0002-install-redis-check-rdb-as-a-symlink-instead-of-dupl.patch
|
||||||
# https://github.com/antirez/redis/pull/7168 - notify systemd
|
# https://github.com/redis/redis/pull/7543 - tail syntax
|
||||||
Patch0003: 0003-Notify-systemd-on-sentinel-startup.patch
|
Patch0003: 0003-fix-deprecated-tail-syntax.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
%if 0%{?with_tests}
|
%if %{with tests}
|
||||||
BuildRequires: procps-ng
|
BuildRequires: procps-ng
|
||||||
BuildRequires: tcl
|
BuildRequires: tcl
|
||||||
%endif
|
%endif
|
||||||
@ -209,7 +210,7 @@ mkdir -p %{buildroot}%{macrosdir}
|
|||||||
install -pDm644 %{S:9} %{buildroot}%{macrosdir}/macros.%{name}
|
install -pDm644 %{S:9} %{buildroot}%{macrosdir}/macros.%{name}
|
||||||
|
|
||||||
%check
|
%check
|
||||||
%if 0%{?with_tests}
|
%if %{with tests}
|
||||||
# ERR Active defragmentation cannot be enabled: it requires a Redis server compiled
|
# ERR Active defragmentation cannot be enabled: it requires a Redis server compiled
|
||||||
# with a modified Jemalloc like the one shipped by default with the Redis source distribution
|
# with a modified Jemalloc like the one shipped by default with the Redis source distribution
|
||||||
sed -e '/memefficiency/d' -i tests/test_helper.tcl
|
sed -e '/memefficiency/d' -i tests/test_helper.tcl
|
||||||
@ -277,6 +278,11 @@ exit 0
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 21 2020 Remi Collet <rcollet@redhat.com> - 6.0.6-1
|
||||||
|
- Upstream 6.0.6 release.
|
||||||
|
- drop patch merged upstream
|
||||||
|
- open https://github.com/redis/redis/pull/7543 fix deprecated tail syntax
|
||||||
|
|
||||||
* Wed Jun 10 2020 Nathan Scott <nathans@redhat.com> - 6.0.5-1
|
* Wed Jun 10 2020 Nathan Scott <nathans@redhat.com> - 6.0.5-1
|
||||||
- Upstream 6.0.5 release.
|
- Upstream 6.0.5 release.
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (redis-6.0.5.tar.gz) = 62ce42bb5ac9443e0736f5dfeffa7609542cef5b3c6c7d689ad8427cf788f3daf321531fdaa0329942e746e2eee47461be9d8771b89ae25adcc5badc225ebf26
|
SHA512 (redis-6.0.6.tar.gz) = bb60aff6e495b201fed814eb134e6ce2825429ef6bd52215c7369eec941318ba460d60ad7b0cef3684b3f992823d465869177dc1d0eb16886bfed598dff74f65
|
||||||
SHA512 (redis-doc-f092dd3.tar.gz) = 72305a13dc09e535e49015689078b4cef48466e38ce7815322dfffe8f22ad49be91a89752a2214c3788fff4e1c4e8c9f6de4846c659d8e1621db47199544e1f5
|
SHA512 (redis-doc-02423fd.tar.gz) = 4be8fdd0c5671b1edf814897b9033c59366159513e1ad428a2101df353682d7b74cd88ac5dba4278917d6c796d4ccb76c8da6cc3043b8d9013c2971ce3a8f69e
|
||||||
|
Loading…
Reference in New Issue
Block a user