Rebase to 6.0.4 and add some updates from Remi.
This commit is contained in:
parent
780d984317
commit
875ac2f90c
2
.gitignore
vendored
2
.gitignore
vendored
@ -69,3 +69,5 @@ clog
|
||||
/redis-doc-ee32a19.tar.gz
|
||||
/redis-6.0.1.tar.gz
|
||||
/redis-6.0.3.tar.gz
|
||||
/redis-6.0.4.tar.gz
|
||||
/redis-doc-f092dd3.tar.gz
|
||||
|
30
0003-Notify-systemd-on-sentinel-startup.patch
Normal file
30
0003-Notify-systemd-on-sentinel-startup.patch
Normal file
@ -0,0 +1,30 @@
|
||||
diff --git a/0003-Notify-systemd-on-sentinel-startup.patch b/0003-Notify-systemd-on-sentinel-startup.patch
|
||||
new file mode 100644
|
||||
index 0000000..ee58b56
|
||||
--- /dev/null
|
||||
+++ b/0003-Notify-systemd-on-sentinel-startup.patch
|
||||
@@ -0,0 +1,24 @@
|
||||
+From 16dbe5168224b9f8a2b193f014f3dbf7e9604516 Mon Sep 17 00:00:00 2001
|
||||
+From: Daniel Murnane <dmurnane@eitccorp.com>
|
||||
+Date: Fri, 1 May 2020 08:19:28 -0400
|
||||
+Subject: [PATCH] Notify systemd on sentinel startup
|
||||
+
|
||||
+---
|
||||
+ src/server.c | 4 ++++
|
||||
+ 1 file changed, 4 insertions(+)
|
||||
+
|
||||
+diff --git a/src/server.c b/src/server.c
|
||||
+index 659604ef363..7ab7c39fd0a 100644
|
||||
+--- a/src/server.c
|
||||
++++ b/src/server.c
|
||||
+@@ -5111,6 +5111,10 @@ int main(int argc, char **argv) {
|
||||
+ } else {
|
||||
+ InitServerLast();
|
||||
+ sentinelIsRunning();
|
||||
++ if (server.supervised_mode == SUPERVISED_SYSTEMD) {
|
||||
++ redisCommunicateSystemd("STATUS=Ready to accept connections\n");
|
||||
++ redisCommunicateSystemd("READY=1\n");
|
||||
++ }
|
||||
+ }
|
||||
+
|
||||
+ /* Warning the user about suspicious maxmemory setting. */
|
@ -1,7 +1,14 @@
|
||||
# If you need to change max open file limit
|
||||
# for example, when you change maxclient in configuration
|
||||
# you can change the LimitNOFILE value below
|
||||
# see "man systemd.exec" for information
|
||||
# you can change the LimitNOFILE value below.
|
||||
# See "man systemd.exec" for more information.
|
||||
|
||||
# Slave nodes on large system may take lot of time to start.
|
||||
# You may need to uncomment TimeoutStartSec and TimeoutStopSec
|
||||
# directives below and raise their value.
|
||||
# See "man systemd.service" for more information.
|
||||
|
||||
[Service]
|
||||
LimitNOFILE=10240
|
||||
#TimeoutStartSec=90s
|
||||
#TimeoutStopSec=90s
|
||||
|
11
redis.spec
11
redis.spec
@ -19,7 +19,7 @@
|
||||
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
||||
|
||||
Name: redis
|
||||
Version: 6.0.3
|
||||
Version: 6.0.4
|
||||
Release: 1%{?dist}
|
||||
Summary: A persistent key-value database
|
||||
# redis, linenoise, lzf, hiredis are BSD
|
||||
@ -48,6 +48,8 @@ Source10: https://github.com/antirez/%{name}-doc/archive/%{doc_commit}/
|
||||
Patch0001: 0001-1st-man-pageis-for-redis-cli-redis-benchmark-redis-c.patch
|
||||
# https://github.com/antirez/redis/pull/3494 - symlink
|
||||
Patch0002: 0002-install-redis-check-rdb-as-a-symlink-instead-of-dupl.patch
|
||||
# https://github.com/antirez/redis/pull/7168 - notify systemd
|
||||
Patch0003: 0003-Notify-systemd-on-sentinel-startup.patch
|
||||
BuildRequires: gcc
|
||||
%if 0%{?with_tests}
|
||||
BuildRequires: procps-ng
|
||||
@ -127,6 +129,7 @@ administration and development.
|
||||
mv ../%{name}-doc-%{doc_commit} doc
|
||||
%patch0001 -p1
|
||||
%patch0002 -p1
|
||||
%patch0003 -p1
|
||||
|
||||
mv deps/lua/COPYRIGHT COPYRIGHT-lua
|
||||
mv deps/hiredis/COPYING COPYING-hiredis
|
||||
@ -274,6 +277,12 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 28 2020 Remi Collet <remi@remirepo.net> - 6.0.3-3
|
||||
- Add comment for TimeoutStartSec and TimeoutStopSec in limit.conf
|
||||
- Fix missing notification to systemd for sentinel
|
||||
patch from https://github.com/antirez/redis/pull/7168
|
||||
- Upstream 6.0.4 release.
|
||||
|
||||
* Mon May 18 2020 Nathan Scott <nathans@redhat.com> - 6.0.3-1
|
||||
- Upstream 6.0.3 release.
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (redis-6.0.3.tar.gz) = 88978285db62cb8aa6e27fcd2075bbdb13f2606eaa702491047080bd6396d79d59336f0310d049d88a57e8e7b7096d716f9408b41cc658788a3902627770a807
|
||||
SHA512 (redis-doc-ee32a19.tar.gz) = 7158a24d35fdb811fcc398c7caca489912675784cdbc0b26cbb8f4c428814d36c32b986b3df3048d186ddae92290a70706b671d382f1afa04374d966e7e40ceb
|
||||
SHA512 (redis-6.0.4.tar.gz) = 8b0922fd7a9d03d4c21d4822da2c7b16a79c65151d3084b03bbacb35dfc2213a0847115c36ffbe8cc1e7b8664ed142e1e05e9f3f262a5e8a043849b398c7547d
|
||||
SHA512 (redis-doc-f092dd3.tar.gz) = 72305a13dc09e535e49015689078b4cef48466e38ce7815322dfffe8f22ad49be91a89752a2214c3788fff4e1c4e8c9f6de4846c659d8e1621db47199544e1f5
|
||||
|
Loading…
Reference in New Issue
Block a user