Redis package builds for the 4.0 series
Upstream redis-4.0.1 release packages, including a devel header-only package for module support.
This commit is contained in:
parent
c374de3637
commit
74836e8db5
@ -1,4 +1,4 @@
|
|||||||
From e1ded77b1f80a5241f2f9b5088b9063ecbeb72c9 Mon Sep 17 00:00:00 2001
|
From ed77684a7eb20635e7f8f8f3ead277c3c48182fe Mon Sep 17 00:00:00 2001
|
||||||
From: Remi Collet <fedora@famillecollet.com>
|
From: Remi Collet <fedora@famillecollet.com>
|
||||||
Date: Thu, 8 Sep 2016 14:51:15 +0200
|
Date: Thu, 8 Sep 2016 14:51:15 +0200
|
||||||
Subject: [PATCH 1/2] 1st man pageis for - redis-cli - redis-benchmark -
|
Subject: [PATCH 1/2] 1st man pageis for - redis-cli - redis-benchmark -
|
||||||
|
@ -1,25 +1,26 @@
|
|||||||
From bcd509def0d4a75f56d9d6a53eea280127803eb4 Mon Sep 17 00:00:00 2001
|
From a7e5d1dab11be34fafe80180f58411f02cd98026 Mon Sep 17 00:00:00 2001
|
||||||
From: Remi Collet <fedora@famillecollet.com>
|
From: Remi Collet <fedora@famillecollet.com>
|
||||||
Date: Fri, 9 Sep 2016 17:23:27 +0200
|
Date: Fri, 9 Sep 2016 17:23:27 +0200
|
||||||
Subject: [PATCH 2/2] install redis-check-rdb as a symlink instead of
|
Subject: [PATCH 2/2] install redis-check-rdb as a symlink instead of duplicating
|
||||||
duplicating the binary
|
the binary
|
||||||
|
|
||||||
---
|
---
|
||||||
src/Makefile | 2 +-
|
src/Makefile | 4 ++--
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/Makefile b/src/Makefile
|
diff --git a/src/Makefile b/src/Makefile
|
||||||
index 6c27dd9..2de5e3f 100644
|
index 4a8a326..a1bbfe9 100644
|
||||||
--- a/src/Makefile
|
--- a/src/Makefile
|
||||||
+++ b/src/Makefile
|
+++ b/src/Makefile
|
||||||
@@ -267,6 +267,6 @@ install: all
|
@@ -287,6 +287,6 @@ install: all
|
||||||
$(REDIS_INSTALL) $(REDIS_SERVER_NAME) $(INSTALL_BIN)
|
$(REDIS_INSTALL) $(REDIS_SERVER_NAME) $(INSTALL_BIN)
|
||||||
$(REDIS_INSTALL) $(REDIS_BENCHMARK_NAME) $(INSTALL_BIN)
|
$(REDIS_INSTALL) $(REDIS_BENCHMARK_NAME) $(INSTALL_BIN)
|
||||||
$(REDIS_INSTALL) $(REDIS_CLI_NAME) $(INSTALL_BIN)
|
$(REDIS_INSTALL) $(REDIS_CLI_NAME) $(INSTALL_BIN)
|
||||||
- $(REDIS_INSTALL) $(REDIS_CHECK_RDB_NAME) $(INSTALL_BIN)
|
- $(REDIS_INSTALL) $(REDIS_CHECK_RDB_NAME) $(INSTALL_BIN)
|
||||||
$(REDIS_INSTALL) $(REDIS_CHECK_AOF_NAME) $(INSTALL_BIN)
|
- $(REDIS_INSTALL) $(REDIS_CHECK_AOF_NAME) $(INSTALL_BIN)
|
||||||
@ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_SENTINEL_NAME)
|
@ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_SENTINEL_NAME)
|
||||||
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_RDB_NAME)
|
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_RDB_NAME)
|
||||||
|
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_AOF_NAME)
|
||||||
--
|
--
|
||||||
2.9.3
|
2.9.3
|
||||||
|
|
||||||
|
30
redis.spec
30
redis.spec
@ -17,8 +17,8 @@
|
|||||||
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
|
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
|
||||||
|
|
||||||
Name: redis
|
Name: redis
|
||||||
Version: 3.2.10
|
Version: 4.0.1
|
||||||
Release: 3%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: A persistent key-value database
|
Summary: A persistent key-value database
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://redis.io
|
URL: http://redis.io
|
||||||
@ -98,6 +98,15 @@ a cache.
|
|||||||
|
|
||||||
You can use Redis from most programming languages also.
|
You can use Redis from most programming languages also.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development header for Redis module development
|
||||||
|
# Header-Only Library (https://fedoraproject.org/wiki/Packaging:Guidelines)
|
||||||
|
Provides: %{name}-static = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Header file required for building loadable Redis modules. Detailed API
|
||||||
|
documentation available at [http://redis-module-redoc.readthedocs.io/]
|
||||||
|
|
||||||
%if 0%{?with_redistrib}
|
%if 0%{?with_redistrib}
|
||||||
%package trib
|
%package trib
|
||||||
Summary: Cluster management script for Redis
|
Summary: Cluster management script for Redis
|
||||||
@ -151,6 +160,7 @@ make %{?_smp_mflags} \
|
|||||||
%else
|
%else
|
||||||
MALLOC=jemalloc \
|
MALLOC=jemalloc \
|
||||||
%endif
|
%endif
|
||||||
|
INSTALL="install -p" PREFIX=%{buildroot}%{_prefix} \
|
||||||
all
|
all
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -189,6 +199,9 @@ chmod 755 %{buildroot}%{_bindir}/%{name}-*
|
|||||||
# Install redis-shutdown
|
# Install redis-shutdown
|
||||||
install -pDm755 %{S:6} %{buildroot}%{_libexecdir}/%{name}-shutdown
|
install -pDm755 %{S:6} %{buildroot}%{_libexecdir}/%{name}-shutdown
|
||||||
|
|
||||||
|
# Install redis module header
|
||||||
|
install -pDm644 src/%{name}module.h %{buildroot}%{_includedir}/%{name}module.h
|
||||||
|
|
||||||
%if 0%{?with_redistrib}
|
%if 0%{?with_redistrib}
|
||||||
# Install redis-trib
|
# Install redis-trib
|
||||||
install -pDm755 src/%{name}-trib.rb %{buildroot}%{_bindir}/%{name}-trib
|
install -pDm755 src/%{name}-trib.rb %{buildroot}%{_bindir}/%{name}-trib
|
||||||
@ -263,6 +276,7 @@ fi
|
|||||||
%if 0%{?with_redistrib}
|
%if 0%{?with_redistrib}
|
||||||
%exclude %{_bindir}/%{name}-trib
|
%exclude %{_bindir}/%{name}-trib
|
||||||
%endif
|
%endif
|
||||||
|
%exclude %{_includedir}/%{name}module.h
|
||||||
%{_bindir}/%{name}-*
|
%{_bindir}/%{name}-*
|
||||||
%{_libexecdir}/%{name}-*
|
%{_libexecdir}/%{name}-*
|
||||||
%{_mandir}/man1/%{name}*
|
%{_mandir}/man1/%{name}*
|
||||||
@ -280,6 +294,10 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/security/limits.d/95-%{name}.conf
|
%config(noreplace) %{_sysconfdir}/security/limits.d/95-%{name}.conf
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license COPYING
|
||||||
|
%{_includedir}/%{name}module.h
|
||||||
|
|
||||||
%if 0%{?with_redistrib}
|
%if 0%{?with_redistrib}
|
||||||
%files trib
|
%files trib
|
||||||
%license COPYING
|
%license COPYING
|
||||||
@ -288,10 +306,16 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Sep 06 2017 Nathan Scott <nathans@redhat.com> - 3.2.10-3
|
|
||||||
|
* Wed Sep 06 2017 Nathan Scott <nathans@redhat.com> - 4.0.1-2
|
||||||
- Switch to using Type=notify for Redis systemd services (RHBZ #1172841)
|
- Switch to using Type=notify for Redis systemd services (RHBZ #1172841)
|
||||||
- Add Provides:bundled hiredis, linenoise, lua-libs clauses (RHBZ #788500)
|
- Add Provides:bundled hiredis, linenoise, lua-libs clauses (RHBZ #788500)
|
||||||
|
|
||||||
|
* Mon Aug 14 2017 Nathan Scott <nathans@redhat.com> - 4.0.1-1
|
||||||
|
- Upstream 4.0.1 release. (RHBZ #1389592)
|
||||||
|
- Add redis-devel for loadable module development.
|
||||||
|
- Provide redis-check-aof as a symlink to redis-server also now.
|
||||||
|
|
||||||
* Mon Aug 14 2017 Nathan Scott <nathans@redhat.com> - 3.2.10-2
|
* Mon Aug 14 2017 Nathan Scott <nathans@redhat.com> - 3.2.10-2
|
||||||
- Add redis-trib based on patch from Sebastian Saletnik. (RHBZ #1215654)
|
- Add redis-trib based on patch from Sebastian Saletnik. (RHBZ #1215654)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (redis-3.2.10.tar.gz) = 32fd27fac8ba559ea38e3a1006b90c4117c74a8ca15399ade19834c4221521e7e3669e4e1f24d214a53bb7cde896839438dd4a273d6be6def587841dd9954aa1
|
SHA512 (redis-4.0.1.tar.gz) = 62dec537aebd12340b9642f5f8b07fd98757c9e648dcd539a0411f207db3495923c5a6a9941036c56b2d574ee38b46d08558668111e322345ef549f93fada26f
|
||||||
|
Loading…
Reference in New Issue
Block a user