Upstream 2.8.18
Rebased patches
This commit is contained in:
parent
3b49225c57
commit
4d1e4c3aa9
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@
|
||||
/redis-2.8.14.tar.gz
|
||||
/redis-2.8.15.tar.gz
|
||||
/redis-2.8.17.tar.gz
|
||||
/redis-2.8.18.tar.gz
|
||||
|
@ -1,14 +1,14 @@
|
||||
From 81f2f0a7341a5d56202506dd68440710188615cd Mon Sep 17 00:00:00 2001
|
||||
From 99c028fdf6723f5a32c3fa5e308f9339f95f66ca Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||
Date: Thu, 11 Sep 2014 13:40:31 +0200
|
||||
Subject: [PATCH 1/5] redis 2.8.11: redis conf
|
||||
Date: Fri, 5 Dec 2014 14:11:15 +0100
|
||||
Subject: [PATCH 1/5] redis 2.8.18: redis conf
|
||||
|
||||
---
|
||||
redis.conf | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/redis.conf b/redis.conf
|
||||
index 24c1b7a..186121a 100644
|
||||
index 6c76569..dd0ef34 100644
|
||||
--- a/redis.conf
|
||||
+++ b/redis.conf
|
||||
@@ -38,7 +38,7 @@ daemonize no
|
||||
@ -48,5 +48,5 @@ index 24c1b7a..186121a 100644
|
||||
################################# REPLICATION #################################
|
||||
|
||||
--
|
||||
1.9.3
|
||||
2.1.0
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 9083bd267135c4d3404c2f1f4a90e900cc13c097 Mon Sep 17 00:00:00 2001
|
||||
From 4325ecb8fadeb36c7d09b994360110fa9c7b63a8 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||
Date: Thu, 11 Sep 2014 13:40:54 +0200
|
||||
Subject: [PATCH 2/5] redis 2.8.11: deps library fPIC performance tuning
|
||||
Date: Mon, 8 Dec 2014 10:02:54 +0100
|
||||
Subject: [PATCH 2/5] redis 2.8.18: deps library fPIC performance tuning
|
||||
|
||||
---
|
||||
deps/Makefile | 2 +-
|
||||
@ -9,15 +9,15 @@ Subject: [PATCH 2/5] redis 2.8.11: deps library fPIC performance tuning
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/deps/Makefile b/deps/Makefile
|
||||
index e183ede..9dcb6b1 100644
|
||||
index 1f623ea..4c2df41 100644
|
||||
--- a/deps/Makefile
|
||||
+++ b/deps/Makefile
|
||||
@@ -58,7 +58,7 @@ ifeq ($(uname_S),SunOS)
|
||||
LUA_CFLAGS= -D__C99FEATURES__=1
|
||||
endif
|
||||
|
||||
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
|
||||
+LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS) -fPIC
|
||||
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL $(CFLAGS)
|
||||
+LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL $(CFLAGS) -fPIC
|
||||
LUA_LDFLAGS+= $(LDFLAGS)
|
||||
# lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
|
||||
# challenging to cross-compile lua (and redis). These defines make it easier
|
||||
@ -35,5 +35,5 @@ index 1dd894b..712f2a6 100644
|
||||
DEBUG= -g
|
||||
|
||||
--
|
||||
1.9.3
|
||||
2.1.0
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 50a409c4f9f753c97c49fd10a44fd7c5f737aea6 Mon Sep 17 00:00:00 2001
|
||||
From d3cdf6aafbe700cd856440058e3b8a345838d326 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||
Date: Thu, 11 Sep 2014 13:41:17 +0200
|
||||
Subject: [PATCH 3/5] redis 2.8.11: use system jemalloc
|
||||
Date: Mon, 8 Dec 2014 10:03:40 +0100
|
||||
Subject: [PATCH 3/5] redis 2.8.18: use system jemalloc
|
||||
|
||||
---
|
||||
src/Makefile | 4 ++--
|
||||
@ -23,5 +23,5 @@ index 8b3e959..af6a4fe 100644
|
||||
|
||||
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
|
||||
--
|
||||
1.9.3
|
||||
2.1.0
|
||||
|
@ -1,14 +1,14 @@
|
||||
From 8b0e3e46bc63975d6fc10a65292d1c1400ce38c4 Mon Sep 17 00:00:00 2001
|
||||
From 2d056b8da3fb3ee4480b7849eefae6637e9ed22c Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||
Date: Thu, 11 Sep 2014 13:42:01 +0200
|
||||
Subject: [PATCH 4/5] redis 2.8.11: disable test failed on slow machine
|
||||
Date: Mon, 8 Dec 2014 10:04:18 +0100
|
||||
Subject: [PATCH 4/5] redis 2.8.18: disable test failed on slow machine
|
||||
|
||||
---
|
||||
tests/test_helper.tcl | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/tests/test_helper.tcl b/tests/test_helper.tcl
|
||||
index 5f958e5..bcd258a 100644
|
||||
index d1ebde1..369ebc2 100644
|
||||
--- a/tests/test_helper.tcl
|
||||
+++ b/tests/test_helper.tcl
|
||||
@@ -33,7 +33,6 @@ set ::all_tests {
|
||||
@ -20,5 +20,5 @@ index 5f958e5..bcd258a 100644
|
||||
integration/rdb
|
||||
integration/convert-zipmap-hash-on-load
|
||||
--
|
||||
1.9.3
|
||||
2.1.0
|
||||
|
@ -1,14 +1,14 @@
|
||||
From 39027199f73e7164fb5f64307f491ebc165a2f5f Mon Sep 17 00:00:00 2001
|
||||
From 35e87543975c05e3f4d07de7c1dba2f7b88add59 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||
Date: Sat, 13 Sep 2014 14:03:04 +0200
|
||||
Subject: [PATCH 5/5] redis 2.8.15: sentinel configuration file fix
|
||||
Subject: [PATCH 5/5] redis 2.8.18: sentinel configuration file fix
|
||||
|
||||
---
|
||||
sentinel.conf | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/sentinel.conf b/sentinel.conf
|
||||
index 4b3b792..1e6a11b 100644
|
||||
index 39d1044..543d40d 100644
|
||||
--- a/sentinel.conf
|
||||
+++ b/sentinel.conf
|
||||
@@ -177,5 +177,10 @@ sentinel failover-timeout mymaster 180000
|
||||
@ -23,5 +23,5 @@ index 4b3b792..1e6a11b 100644
|
||||
|
||||
|
||||
--
|
||||
1.9.3
|
||||
2.1.0
|
||||
|
18
redis.spec
18
redis.spec
@ -18,7 +18,7 @@
|
||||
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
|
||||
|
||||
Name: redis
|
||||
Version: 2.8.17
|
||||
Version: 2.8.18
|
||||
Release: 1%{?dist}
|
||||
Summary: A persistent key-value database
|
||||
License: BSD
|
||||
@ -37,13 +37,13 @@ Source7: %{name}-shutdown
|
||||
# Then refresh your patches
|
||||
# git format-patch HEAD~<number of expected patches>
|
||||
# Update configuration for Fedora
|
||||
Patch0001: 0001-redis-2.8.11-redis-conf.patch
|
||||
Patch0002: 0002-redis-2.8.11-deps-library-fPIC-performance-tuning.patch
|
||||
Patch0003: 0003-redis-2.8.11-use-system-jemalloc.patch
|
||||
Patch0001: 0001-redis-2.8.18-redis-conf.patch
|
||||
Patch0002: 0002-redis-2.8.18-deps-library-fPIC-performance-tuning.patch
|
||||
Patch0003: 0003-redis-2.8.18-use-system-jemalloc.patch
|
||||
# tests/integration/replication-psync.tcl failed on slow machines(GITHUB #1417)
|
||||
Patch0004: 0004-redis-2.8.11-disable-test-failed-on-slow-machine.patch
|
||||
Patch0004: 0004-redis-2.8.18-disable-test-failed-on-slow-machine.patch
|
||||
# Fix sentinel configuration to use a different log file than redis
|
||||
Patch0005: 0005-redis-2.8.15-sentinel-configuration-file-fix.patch
|
||||
Patch0005: 0005-redis-2.8.18-sentinel-configuration-file-fix.patch
|
||||
%if 0%{?with_perftools}
|
||||
BuildRequires: gperftools-devel
|
||||
%else
|
||||
@ -264,7 +264,11 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Sep 20 2014 Remi Collet <remi@fedoraproject.org> - 2.8.17-1
|
||||
* Fri Dec 05 2014 Haïkel Guémar <hguemar@fedoraproject.org> - 2.8.18-1
|
||||
- Upstream 2.8.18
|
||||
- Rebased patches
|
||||
|
||||
* Sat Sep 20 2014 Remi Collet <remi@fedoraproject.org> - 2.8.17-1
|
||||
- Upstream 2.8.17
|
||||
- fix redis-sentinel service unit file for systemd
|
||||
- fix redis-shutdown for sentinel
|
||||
|
Loading…
Reference in New Issue
Block a user