Port makefile to C99 mode
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
This commit is contained in:
parent
c2f6adf473
commit
45aabba7d6
33
0002-deps-jemalloc-Do-not-force-building-in-gnu99-mode.patch
Normal file
33
0002-deps-jemalloc-Do-not-force-building-in-gnu99-mode.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
From bbace21828d7e82f1c481f0e1caece31b661cbd9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Florian Weimer <fweimer@redhat.com>
|
||||||
|
Date: Mon, 5 Dec 2022 11:10:37 +0100
|
||||||
|
Subject: [PATCH 2/2] deps/jemalloc: Do not force building in gnu99 mode
|
||||||
|
Content-type: text/plain
|
||||||
|
|
||||||
|
The jemalloc configure logic switches to gnu11 mode if available,
|
||||||
|
and this explicit flags injection prevents that. The main difference
|
||||||
|
seems to be that in gnu99 mode, <stdatomic.h> is presumed to be
|
||||||
|
unavailable and is not used.
|
||||||
|
|
||||||
|
Submitted upstream: <https://github.com/redis/redis/pull/11583>
|
||||||
|
|
||||||
|
---
|
||||||
|
deps/Makefile | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/deps/Makefile b/deps/Makefile
|
||||||
|
index 8592e17..d6cb06e 100644
|
||||||
|
--- a/deps/Makefile
|
||||||
|
+++ b/deps/Makefile
|
||||||
|
@@ -90,7 +90,7 @@ lua: .make-prerequisites
|
||||||
|
|
||||||
|
.PHONY: lua
|
||||||
|
|
||||||
|
-JEMALLOC_CFLAGS= -std=gnu99 -Wall -pipe -g3 -O3 -funroll-loops $(CFLAGS)
|
||||||
|
+JEMALLOC_CFLAGS= -Wall -pipe -g3 -O3 -funroll-loops $(CFLAGS)
|
||||||
|
JEMALLOC_LDFLAGS= $(LDFLAGS)
|
||||||
|
|
||||||
|
ifneq ($(DEB_HOST_GNU_TYPE),)
|
||||||
|
--
|
||||||
|
2.38.1
|
||||||
|
|
@ -23,7 +23,7 @@
|
|||||||
|
|
||||||
Name: redis
|
Name: redis
|
||||||
Version: 7.0.5
|
Version: 7.0.5
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: A persistent key-value database
|
Summary: A persistent key-value database
|
||||||
# redis, jemalloc, linenoise, lzf, hiredis are BSD
|
# redis, jemalloc, linenoise, lzf, hiredis are BSD
|
||||||
# lua is MIT
|
# lua is MIT
|
||||||
@ -46,6 +46,7 @@ Source10: https://github.com/%{name}/%{name}-doc/archive/%{doc_commit}/
|
|||||||
# Update configuration for Fedora
|
# Update configuration for Fedora
|
||||||
# https://github.com/redis/redis/pull/3491 - man pages
|
# https://github.com/redis/redis/pull/3491 - man pages
|
||||||
Patch0001: 0001-1st-man-pageis-for-redis-cli-redis-benchmark-redis-c.patch
|
Patch0001: 0001-1st-man-pageis-for-redis-cli-redis-benchmark-redis-c.patch
|
||||||
|
Patch0002: 0002-deps-jemalloc-Do-not-force-building-in-gnu99-mode.patch
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -134,6 +135,7 @@ administration and development.
|
|||||||
%setup -q
|
%setup -q
|
||||||
mv ../%{name}-doc-%{doc_commit} doc
|
mv ../%{name}-doc-%{doc_commit} doc
|
||||||
%patch0001 -p1
|
%patch0001 -p1
|
||||||
|
%patch0002 -p1
|
||||||
|
|
||||||
mv deps/lua/COPYRIGHT COPYRIGHT-lua
|
mv deps/lua/COPYRIGHT COPYRIGHT-lua
|
||||||
mv deps/jemalloc/COPYING COPYING-jemalloc
|
mv deps/jemalloc/COPYING COPYING-jemalloc
|
||||||
@ -306,6 +308,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 5 2022 Florian Weimer <fweimer@redhat.com> - 7.0.5-2
|
||||||
|
- Port makefile to C99 mode
|
||||||
|
|
||||||
* Thu Sep 22 2022 Remi Collet <remi@remirepo.net> - 7.0.5-1
|
* Thu Sep 22 2022 Remi Collet <remi@remirepo.net> - 7.0.5-1
|
||||||
- Upstream 7.0.5 security release.
|
- Upstream 7.0.5 security release.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user