Update to redis-2.6.13 and PIC build flag

Signed-off-by: Fabian Deutsch <fabiand@fedoraproject.org>
This commit is contained in:
Fabian Deutsch 2013-06-07 08:32:47 +02:00
parent 53668999cf
commit 12623859e3
5 changed files with 45 additions and 17 deletions

1
.gitignore vendored
View File

@ -10,3 +10,4 @@
/redis-2.4.13.tar.gz /redis-2.4.13.tar.gz
/redis-2.4.15.tar.gz /redis-2.4.15.tar.gz
/redis-2.6.7.tar.gz /redis-2.6.7.tar.gz
/redis-2.6.13.tar.gz

View File

@ -1,6 +1,5 @@
diff -up redis-2.6.7/redis.conf.orig redis-2.6.7/redis.conf --- a/redis.conf 2013-04-30 15:15:56.000000000 +0200
--- redis-2.6.7/redis.conf.orig 2012-12-27 07:54:11.772560595 -0500 +++ b/redis.conf 2013-06-07 08:32:04.571127785 +0200
+++ redis-2.6.7/redis.conf 2012-12-27 07:56:12.818571232 -0500
@@ -18,7 +18,7 @@ daemonize no @@ -18,7 +18,7 @@ daemonize no
# When running daemonized, Redis writes a pid file in /var/run/redis.pid by # When running daemonized, Redis writes a pid file in /var/run/redis.pid by
@ -19,7 +18,7 @@ diff -up redis-2.6.7/redis.conf.orig redis-2.6.7/redis.conf
# Specify the path for the unix socket that will be used to listen for # Specify the path for the unix socket that will be used to listen for
# incoming connections. There is no default, so Redis will not listen # incoming connections. There is no default, so Redis will not listen
@@ -50,7 +50,7 @@ loglevel notice @@ -66,7 +66,7 @@ loglevel notice
# Specify the log file name. Also 'stdout' can be used to force # Specify the log file name. Also 'stdout' can be used to force
# Redis to log on the standard output. Note that if you use standard # Redis to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null # output for logging but daemonize, logs will be sent to /dev/null
@ -28,8 +27,8 @@ diff -up redis-2.6.7/redis.conf.orig redis-2.6.7/redis.conf
# To enable logging to the system logger, just set 'syslog-enabled' to yes, # To enable logging to the system logger, just set 'syslog-enabled' to yes,
# and optionally update the other syslog parameters to suit your needs. # and optionally update the other syslog parameters to suit your needs.
@@ -134,7 +134,7 @@ dbfilename dump.rdb @@ -150,7 +150,7 @@ dbfilename dump.rdb
# Also the Append Only File will be created inside this directory. # The Append Only File will also be created inside this directory.
# #
# Note that you must specify a directory here, not a file name. # Note that you must specify a directory here, not a file name.
-dir ./ -dir ./

23
redis-deps-PIC.patch Normal file
View File

@ -0,0 +1,23 @@
--- a/deps/Makefile
+++ a/deps/Makefile
@@ -58,7 +58,7 @@ ifeq ($(uname_S),SunOS)
LUA_CFLAGS= -D__C99FEATURES__=1
endif
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
+LUA_CFLAGS+= -O2 -Wall -fPIC -DLUA_ANSI $(CFLAGS)
LUA_LDFLAGS+= $(LDFLAGS)
lua: .make-prerequisites
--- a/deps/linenoise/Makefile
+++ a/deps/linenoise/Makefile
@@ -2,7 +2,7 @@ STD=
WARN= -Wall
OPT= -Os
-R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
+R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) -fPIC
R_LDFLAGS= $(LDFLAGS)
DEBUG= -g

View File

@ -1,14 +1,16 @@
# Check for status of man pages # Check for status of man pages
# http://code.google.com/p/redis/issues/detail?id=202 # http://code.google.com/p/redis/issues/detail?id=202
%global _hardened_build 1
%ifarch %{ix86} x86_64 ppc %ifarch %{ix86} x86_64 ppc
# available only on selected architectures # available only on selected architectures
%global with_perftools 1 %global with_perftools 1
%endif %endif
Name: redis Name: redis
Version: 2.6.7 Version: 2.6.13
Release: 2%{?dist} Release: 1%{?dist}
Summary: A persistent key-value database Summary: A persistent key-value database
Group: Applications/Databases Group: Applications/Databases
@ -19,7 +21,8 @@ Source1: %{name}.logrotate
Source2: %{name}.init Source2: %{name}.init
Source3: %{name}.service Source3: %{name}.service
# Update configuration for Fedora # Update configuration for Fedora
Patch0: %{name}-2.6.7-redis.conf.patch Patch0: %{name}-2.6.13-redis.conf.patch
Patch1: %{name}-deps-PIC.patch
BuildRequires: systemd-units BuildRequires: systemd-units
%if !0%{?el5} %if !0%{?el5}
@ -47,11 +50,15 @@ different kind of sorting abilities.
%prep %prep
%setup -q %setup -q
%patch0 -p1 %patch0 -p1
%patch1 -p1
%build %build
export CFLAGS="$RPM_OPT_FLAGS"
make %{?_smp_mflags} \ make %{?_smp_mflags} \
DEBUG="" \ DEBUG="" \
CFLAGS='%{optflags}' \ LDFLAGS="%{?__global_ldflags}" \
CFLAGS="$RPM_OPT_FLAGS -fPIC" \
LUA_CFLAGS="-fPIC" \
%if !0%{?el5} %if !0%{?el5}
%if 0%{?with_perftools} %if 0%{?with_perftools}
USE_TCMALLOC=yes \ USE_TCMALLOC=yes \
@ -114,6 +121,10 @@ fi
%{_unitdir}/%{name}.service %{_unitdir}/%{name}.service
%changelog %changelog
* Fri Jun 07 2013 Fabian Deutsch <fabiand@fedoraproject.org> - 2.6.13-1
- Add compile PIE flag (rhbz#955459)
- Update to redis 2.6.13 (rhbz#820919)
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.7-2 * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

View File

@ -1,7 +1 @@
41d394074bcde762872ecb5506f35aee redis-2.4.6.tar.gz c4be422013905c64af18b1ef140de21f redis-2.6.13.tar.gz
6afffb6120724183e40f1cac324ac71c redis-2.4.7.tar.gz
ac776d25f238b142d3d526cfcdc621ab redis-2.4.8.tar.gz
71938de99cbb4fdefd74d7571831fa28 redis-2.4.10.tar.gz
f8a160f8a6fe7d7e8ebb4c23ff583d71 redis-2.4.13.tar.gz
ef273152151c3f905d284cbdbbdb234c redis-2.4.15.tar.gz
9c3db210faff9fea3c17f2b71c2760f4 redis-2.6.7.tar.gz