Fix FTBFS if "-Werror=format-security" flag is used (#1037305).
This commit is contained in:
parent
1c92514681
commit
e3c13f6a4e
12
recode-format-security.patch
Normal file
12
recode-format-security.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up recode-3.6/src/names.c.printf recode-3.6/src/names.c
|
||||||
|
--- recode-3.6/src/names.c.printf 2000-12-06 20:41:29.000000000 +0100
|
||||||
|
+++ recode-3.6/src/names.c 2013-12-18 12:48:42.578052395 +0100
|
||||||
|
@@ -892,7 +892,7 @@ list_concise_charset (RECODE_OUTER outer
|
||||||
|
if (ucs2 >= 0)
|
||||||
|
printf (format, code);
|
||||||
|
else if (mnemonic || counter2 != 112)
|
||||||
|
- printf (blanks);
|
||||||
|
+ printf ("%s", blanks);
|
||||||
|
|
||||||
|
if (mnemonic)
|
||||||
|
printf (counter2 == 112 ? " %s\n" : " %-3s", mnemonic);
|
23
recode.spec
23
recode.spec
@ -1,17 +1,17 @@
|
|||||||
Summary: Conversion between character sets and surfaces
|
Summary: Conversion between character sets and surfaces
|
||||||
Name: recode
|
Name: recode
|
||||||
Version: 3.6
|
Version: 3.6
|
||||||
Release: 37%{?dist}
|
Release: 38%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/File
|
Group: Applications/File
|
||||||
|
Url: http://recode.progiciels-bpi.ca/
|
||||||
Source: http://recode.progiciels-bpi.ca/archives/recode-%{version}.tar.gz
|
Source: http://recode.progiciels-bpi.ca/archives/recode-%{version}.tar.gz
|
||||||
Patch0: recode.patch
|
Patch0: recode.patch
|
||||||
Patch1: recode-3.6-getcwd.patch
|
Patch1: recode-3.6-getcwd.patch
|
||||||
Patch2: recode-bool-bitfield.patch
|
Patch2: recode-bool-bitfield.patch
|
||||||
Patch3: recode-flex-m4.patch
|
Patch3: recode-flex-m4.patch
|
||||||
Patch4: recode-automake.patch
|
Patch4: recode-automake.patch
|
||||||
Url: http://recode.progiciels-bpi.ca/
|
Patch5: recode-format-security.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
||||||
|
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
Requires(post): /sbin/ldconfig
|
Requires(post): /sbin/ldconfig
|
||||||
@ -24,7 +24,7 @@ BuildRequires: texinfo
|
|||||||
|
|
||||||
%description
|
%description
|
||||||
The `recode' converts files between character sets and usages.
|
The `recode' converts files between character sets and usages.
|
||||||
It recognises or produces nearly 150 different character sets
|
It recognizes or produces nearly 150 different character sets
|
||||||
and is able to transliterate files between almost any pair. When exact
|
and is able to transliterate files between almost any pair. When exact
|
||||||
transliteration are not possible, it may get rid of the offending
|
transliteration are not possible, it may get rid of the offending
|
||||||
characters or fall back on approximations. Most RFC 1345 character sets
|
characters or fall back on approximations. Most RFC 1345 character sets
|
||||||
@ -33,11 +33,11 @@ are supported.
|
|||||||
%package devel
|
%package devel
|
||||||
Summary: Header files for development using recode
|
Summary: Header files for development using recode
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
The `recode' library converts files between character sets and usages.
|
The `recode' library converts files between character sets and usages.
|
||||||
The library recognises or produces nearly 150 different character sets
|
The library recognizes or produces nearly 150 different character sets
|
||||||
and is able to transliterate files between almost any pair. When exact
|
and is able to transliterate files between almost any pair. When exact
|
||||||
transliteration are not possible, it may get rid of the offending
|
transliteration are not possible, it may get rid of the offending
|
||||||
characters or fall back on approximations. Most RFC 1345 character sets
|
characters or fall back on approximations. Most RFC 1345 character sets
|
||||||
@ -50,6 +50,7 @@ are supported.
|
|||||||
%patch2 -p0
|
%patch2 -p0
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
|
%patch5 -p1
|
||||||
rm m4/libtool.m4
|
rm m4/libtool.m4
|
||||||
rm acinclude.m4
|
rm acinclude.m4
|
||||||
|
|
||||||
@ -62,8 +63,6 @@ make %{?_smp_mflags}
|
|||||||
make check
|
make check
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
%makeinstall
|
%makeinstall
|
||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
@ -85,11 +84,7 @@ fi
|
|||||||
|
|
||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%clean
|
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
|
||||||
%doc AUTHORS COPYING* ChangeLog NEWS README THANKS TODO
|
%doc AUTHORS COPYING* ChangeLog NEWS README THANKS TODO
|
||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
%{_infodir}/recode.info*
|
%{_infodir}/recode.info*
|
||||||
@ -97,11 +92,13 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/*.so.0*
|
%{_libdir}/*.so.0*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_libdir}/*.so
|
%{_libdir}/*.so
|
||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 18 2013 Jiri Popelka <jpopelka@redhat.com> - 3.6-38
|
||||||
|
- Fix FTBFS if "-Werror=format-security" flag is used (#1037305).
|
||||||
|
|
||||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6-37
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6-37
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user