3.7.13 bump
Resolves: rhbz#2158811
This commit is contained in:
parent
4da501507f
commit
bdd84d8b5b
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@ recode-3.6.tar.gz
|
|||||||
/recode-3.7.9.tar.gz
|
/recode-3.7.9.tar.gz
|
||||||
/recode-3.7.11.tar.gz
|
/recode-3.7.11.tar.gz
|
||||||
/recode-3.7.12.tar.gz
|
/recode-3.7.12.tar.gz
|
||||||
|
/recode-3.7.13.tar.gz
|
||||||
|
58
0001-src-Makefile.am-allow-build-without-help2man.patch
Normal file
58
0001-src-Makefile.am-allow-build-without-help2man.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
From dcdd5d26c0c2c49f8113b63186449d6a1e3a509e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Reuben Thomas <rrt@sc3d.org>
|
||||||
|
Date: Fri, 6 Jan 2023 20:11:03 +0100
|
||||||
|
Subject: [PATCH 02/18] src/Makefile.am: allow build without help2man
|
||||||
|
|
||||||
|
---
|
||||||
|
src/Makefile.am | 8 +++-----
|
||||||
|
tests/Makefile.am | 2 +-
|
||||||
|
2 files changed, 4 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||||
|
index fa6740e..0342057 100644
|
||||||
|
--- a/src/Makefile.am
|
||||||
|
+++ b/src/Makefile.am
|
||||||
|
@@ -19,7 +19,7 @@ AUTOMAKE_OPTIONS = gnits
|
||||||
|
bin_PROGRAMS = recode
|
||||||
|
lib_LTLIBRARIES = librecode.la
|
||||||
|
noinst_LTLIBRARIES = libmerged.la
|
||||||
|
-man_MANS = recode.1
|
||||||
|
+dist_man_MANS = recode.1
|
||||||
|
include_HEADERS = recode.h recodext.h
|
||||||
|
|
||||||
|
H_STEPS = common.h decsteps.h inisteps.h tersteps.h \
|
||||||
|
@@ -100,12 +100,12 @@ merged.c: mergelex.py $(L_STEPS)
|
||||||
|
# Depend on recode$(EXEEXT) rather than explicitly make-ing it, as otherwise
|
||||||
|
# we break parallel builds, as libmerged.la can be built twice in parallel,
|
||||||
|
# which can fail.
|
||||||
|
-recode.1: main.c $(top_srcdir)/configure.ac recode$(EXEEXT)
|
||||||
|
+recode.1: main.c $(top_srcdir)/configure.ac
|
||||||
|
## Exit gracefully if recode.1 is not writeable, such as during distcheck!
|
||||||
|
$(AM_V_GEN)if ( touch $@.w && rm -f $@.w; ) >/dev/null 2>&1; then \
|
||||||
|
$(top_srcdir)/build-aux/missing --run $(HELP2MAN) --locale=en_US.UTF-8 \
|
||||||
|
--name="converts files between character sets" \
|
||||||
|
- --output=$@ ./recode; \
|
||||||
|
+ --output=$@ ./recode$(EXEEXT); \
|
||||||
|
fi
|
||||||
|
|
||||||
|
main.o: main.c ../config.status
|
||||||
|
@@ -169,5 +169,3 @@ strip-pool.c strip-data.c: stamp-strip
|
||||||
|
stamp-strip: ../tables.py $(MNEMONICS_DS) $(CHARSETS_DEF)
|
||||||
|
$(TABLES_PY) -C $(srcdir) -p $(MNEMONICS_DS) $(CHARSETS_DEF)
|
||||||
|
@echo timestamp > $(srcdir)/$@
|
||||||
|
-
|
||||||
|
-DISTCLEANFILES = recode.1
|
||||||
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
||||||
|
index 3ab84cd..a26d43e 100644
|
||||||
|
--- a/tests/Makefile.am
|
||||||
|
+++ b/tests/Makefile.am
|
||||||
|
@@ -1,5 +1,5 @@
|
||||||
|
# Makefile for Recode regression tests.
|
||||||
|
-# Copyright © 1996-2022 Free Software Foundation, Inc.
|
||||||
|
+# Copyright © 1996-2023 Free Software Foundation, Inc.
|
||||||
|
# François Pinard <pinard@iro.umontreal.ca>, 1988.
|
||||||
|
|
||||||
|
# This program is free software; you can redistribute it and/or modify
|
||||||
|
--
|
||||||
|
2.38.1
|
||||||
|
|
@ -1,40 +0,0 @@
|
|||||||
From 170857800f2a84b4cdb8fefe9a698efe5509837a Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
|
||||||
Date: Fri, 16 Aug 2019 09:29:54 +0200
|
|
||||||
Subject: [PATCH] Rename coliding hash functions
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Ported from Fedora recode patch:
|
|
||||||
|
|
||||||
commit 5cd1d43a39e4679ed265efcdf4bdc3da517e3de5 (tag: recode-3_6-16)
|
|
||||||
Author: Bill Nottingham <notting@fedoraproject.org>
|
|
||||||
Date: Fri May 27 02:52:25 2005 +0000
|
|
||||||
|
|
||||||
auto-import recode-3.6-16 on branch devel from recode-3.6-16.src.rpm
|
|
||||||
|
|
||||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
|
||||||
---
|
|
||||||
lib/hash.h | 5 +++++
|
|
||||||
1 file changed, 5 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/lib/hash.h b/lib/hash.h
|
|
||||||
index 562f5e6..65d967e 100644
|
|
||||||
--- a/lib/hash.h
|
|
||||||
+++ b/lib/hash.h
|
|
||||||
@@ -24,6 +24,11 @@
|
|
||||||
#ifndef HASH_H_
|
|
||||||
# define HASH_H_
|
|
||||||
|
|
||||||
+#define hash_lookup recode_hash_lookup
|
|
||||||
+#define hash_delete recode_hash_delete
|
|
||||||
+#define hash_free recode_hash_free
|
|
||||||
+#define hash_insert recode_hash_insert
|
|
||||||
+
|
|
||||||
# include <stdio.h>
|
|
||||||
# include <stdbool.h>
|
|
||||||
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
15
recode-3.7.13-Rename-coliding-hash-functions.patch
Normal file
15
recode-3.7.13-Rename-coliding-hash-functions.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff -ur a/lib/hash.h b/lib/hash.h
|
||||||
|
--- a/lib/hash.h 2023-01-04 23:06:45.000000000 +0100
|
||||||
|
+++ b/lib/hash.h 2023-01-17 13:04:05.200398680 +0100
|
||||||
|
@@ -24,6 +24,11 @@
|
||||||
|
#ifndef HASH_H_
|
||||||
|
# define HASH_H_
|
||||||
|
|
||||||
|
+#define hash_lookup recode_hash_lookup
|
||||||
|
+#define hash_delete recode_hash_delete
|
||||||
|
+#define hash_free recode_hash_free
|
||||||
|
+#define hash_insert recode_hash_insert
|
||||||
|
+
|
||||||
|
# include <stdio.h>
|
||||||
|
|
||||||
|
# ifdef __cplusplus
|
16
recode.spec
16
recode.spec
@ -1,6 +1,6 @@
|
|||||||
Name: recode
|
Name: recode
|
||||||
Version: 3.7.12
|
Version: 3.7.13
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Conversion between character sets and surfaces
|
Summary: Conversion between character sets and surfaces
|
||||||
# COPYING: GPLv3 text
|
# COPYING: GPLv3 text
|
||||||
# COPYING-LIB: LGPLv3 text
|
# COPYING-LIB: LGPLv3 text
|
||||||
@ -53,8 +53,9 @@ Summary: Conversion between character sets and surfaces
|
|||||||
License: GPLv3+ and LGPLv3+ and BSD and OFSFDL
|
License: GPLv3+ and LGPLv3+ and BSD and OFSFDL
|
||||||
URL: https://github.com/rrthomas/recode
|
URL: https://github.com/rrthomas/recode
|
||||||
Source: %{url}/releases/download/v%{version}/recode-%{version}.tar.gz
|
Source: %{url}/releases/download/v%{version}/recode-%{version}.tar.gz
|
||||||
# Make internal hash function identifiers unique
|
Patch: recode-3.7.13-Rename-coliding-hash-functions.patch
|
||||||
Patch0: recode-3.7.1-Rename-coliding-hash-functions.patch
|
Patch: 0001-src-Makefile.am-allow-build-without-help2man.patch
|
||||||
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
BuildRequires: coreutils
|
BuildRequires: coreutils
|
||||||
@ -88,8 +89,7 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
|
|||||||
This package provides the header files for a recode library.
|
This package provides the header files for a recode library.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup -p1 -n %{name}-%{version}
|
||||||
%patch0 -p1
|
|
||||||
autoreconf -fi
|
autoreconf -fi
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -132,6 +132,10 @@ rm $RPM_BUILD_ROOT%{_libdir}/*.la
|
|||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 17 2023 Ondrej Pohorelsky <opohorel@redhat.com> - 3.7.13-1
|
||||||
|
- 3.7.13 bump
|
||||||
|
- Resolves: rhbz#2158811
|
||||||
|
|
||||||
* Thu Oct 27 2022 Ondrej Pohorelsky <opohorel@redhat.com> - 3.7.12-3
|
* Thu Oct 27 2022 Ondrej Pohorelsky <opohorel@redhat.com> - 3.7.12-3
|
||||||
- Adds BuildRequire for Python 3.12
|
- Adds BuildRequire for Python 3.12
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (recode-3.7.12.tar.gz) = 365602bf7b20e5362d13d1ab5269419f7f0838fb81dc01c466ea99c38eb1b979f8d707d24ca3dabbd3a0c65cde97704b570007ac60689d88bbafd33351d37d95
|
SHA512 (recode-3.7.13.tar.gz) = af86754ed2ed1dc414f1dd7ab3564d606abb309766fb02bf085e56241527a74ac7141617956d01b0797e8e426cfb39ec597bd221d8ad58d9246e96b228e65b00
|
||||||
|
Loading…
Reference in New Issue
Block a user