6c63e96637
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/realtime-tests.git#df761eddf517e50ed859d90947c84a57a9b7540b
58 lines
1.7 KiB
Diff
58 lines
1.7 KiB
Diff
From a6114da09c475c0083fe3a681e79ba2c05d08848 Mon Sep 17 00:00:00 2001
|
|
From: John Kacur <jkacur@redhat.com>
|
|
Date: Tue, 8 Dec 2020 13:25:53 -0500
|
|
Subject: [PATCH 2/3] rt-tests: queuelat: Remove get_cpuinfo_mhz.sh and old
|
|
Makefile
|
|
|
|
The functionality in get_cpuinfo_mhz.sh has been incorporated into
|
|
determine_maximum_mpps.sh, so it can safely be removed.
|
|
|
|
The queuelat is built from the rt-tests suite Makefile, and the old
|
|
Makefile in the queuelat directory can be removed.
|
|
|
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 3b38d21afb3a..d5b14991032d 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -209,7 +209,6 @@ rebuild:
|
|
install: all install_manpages install_hwlatdetect install_get_cyclictest_snapshot
|
|
mkdir -p "$(DESTDIR)$(bindir)"
|
|
cp $(TARGETS) "$(DESTDIR)$(bindir)"
|
|
- install src/queuelat/get_cpuinfo_mhz.sh "$(DESTDIR)$(bindir)"
|
|
install src/queuelat/determine_maximum_mpps.sh "${DESTDIR}${bindir}"
|
|
|
|
.PHONY: install_hwlatdetect
|
|
diff --git a/src/queuelat/Makefile b/src/queuelat/Makefile
|
|
deleted file mode 100644
|
|
index b4d327829b17..000000000000
|
|
--- a/src/queuelat/Makefile
|
|
+++ /dev/null
|
|
@@ -1,9 +0,0 @@
|
|
-queuelat: queuelat.o
|
|
- cc -o queuelat queuelat.o
|
|
-
|
|
-queuelat.o: queuelat.c
|
|
- cc -c -Wall queuelat.c
|
|
-
|
|
-clean:
|
|
- rm queuelat queuelat.o
|
|
-
|
|
diff --git a/src/queuelat/get_cpuinfo_mhz.sh b/src/queuelat/get_cpuinfo_mhz.sh
|
|
deleted file mode 100755
|
|
index 14a2c12c478f..000000000000
|
|
--- a/src/queuelat/get_cpuinfo_mhz.sh
|
|
+++ /dev/null
|
|
@@ -1,7 +0,0 @@
|
|
-#!/bin/bash
|
|
-
|
|
-# SPDX-License-Identifier: GPL-2.0-or-later
|
|
-# Copyright (C) 2018 Marcelo Tosatti <mtosatti@redhat.com>
|
|
-
|
|
-mhz=$(grep "cpu MHz" /proc/cpuinfo | cut -f 3 -d " " | sort -rn | head -n1)
|
|
-echo "$mhz"
|
|
--
|
|
2.26.2
|
|
|