readline/readline-5.2-shlib.patch
Miroslav Lichvar c6de18b184 - fix cursor position when prompt has one invisible character (#358231)
- merge review fixes (#226361)
- fix source URL
2007-11-05 18:26:52 +00:00

39 lines
1.5 KiB
Diff

--- readline-5.2/support/shlib-install.shlib 2006-01-03 20:06:27.000000000 +0100
+++ readline-5.2/support/shlib-install 2006-11-13 13:51:02.000000000 +0100
@@ -71,7 +71,7 @@
case "$host_os" in
hpux*|darwin*|macosx*|linux*)
if [ -z "$uninstall" ]; then
- chmod 555 ${INSTALLDIR}/${LIBNAME}
+ chmod 755 ${INSTALLDIR}/${LIBNAME}
fi ;;
cygwin*)
IMPLIBNAME=`echo ${LIBNAME} \
--- readline-5.2/support/shobj-conf.shlib 2006-04-11 15:15:43.000000000 +0200
+++ readline-5.2/support/shobj-conf 2007-03-15 14:11:36.000000000 +0100
@@ -108,10 +108,11 @@
linux*-*|gnu*-*|k*bsd*-gnu-*)
SHOBJ_CFLAGS=-fPIC
SHOBJ_LD='${CC}'
- SHOBJ_LDFLAGS='-shared -Wl,-soname,$@'
+ SHOBJ_LDFLAGS='$(CFLAGS) -shared -Wl,-soname,$@'
- SHLIB_XLDFLAGS='-Wl,-rpath,$(libdir) -Wl,-soname,`basename $@ $(SHLIB_MINOR)`'
+ SHLIB_XLDFLAGS='-Wl,-soname,`basename $@ $(SHLIB_MINOR)`'
SHLIB_LIBVERSION='$(SHLIB_LIBSUFF).$(SHLIB_MAJOR)$(SHLIB_MINOR)'
+ SHLIB_LIBS='-ltinfo'
;;
freebsd2* | netbsd*)
--- readline-5.2/shlib/Makefile.in.shlib 2005-08-12 05:56:10.000000000 +0200
+++ readline-5.2/shlib/Makefile.in 2007-11-05 18:59:14.000000000 +0100
@@ -168,7 +168,7 @@ $(SHARED_READLINE): $(SHARED_OBJ)
$(SHARED_HISTORY): $(SHARED_HISTOBJ) xmalloc.so
$(RM) $@
- $(SHOBJ_LD) ${SHOBJ_LDFLAGS} ${SHLIB_XLDFLAGS} -o $@ $(SHARED_HISTOBJ) xmalloc.so $(SHLIB_LIBS)
+ $(SHOBJ_LD) ${SHOBJ_LDFLAGS} ${SHLIB_XLDFLAGS} -o $@ $(SHARED_HISTOBJ) xmalloc.so
# Since tilde.c is shared between readline and bash, make sure we compile
# it with the right flags when it's built as part of readline