445e35117f
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/readline#e8b028767c4a56aa08a060ab44ef334fbb19887b
32 lines
1.2 KiB
Diff
32 lines
1.2 KiB
Diff
diff --git a/shlib/Makefile.in b/shlib/Makefile.in
|
|
index f2ec3e4..5c8994c 100644
|
|
--- a/shlib/Makefile.in
|
|
+++ b/shlib/Makefile.in
|
|
@@ -178,7 +178,7 @@ $(SHARED_READLINE): $(SHARED_OBJ)
|
|
|
|
$(SHARED_HISTORY): $(SHARED_HISTOBJ) xmalloc.so xfree.so
|
|
$(RM) $@
|
|
- $(SHOBJ_LD) ${SHOBJ_LDFLAGS} ${SHLIB_XLDFLAGS} -o $@ $(SHARED_HISTOBJ) xmalloc.so xfree.so $(SHLIB_LIBS)
|
|
+ $(SHOBJ_LD) ${SHOBJ_LDFLAGS} ${SHLIB_XLDFLAGS} -o $@ $(SHARED_HISTOBJ) xmalloc.so xfree.so
|
|
|
|
# Since tilde.c is shared between readline and bash, make sure we compile
|
|
# it with the right flags when it's built as part of readline
|
|
diff --git a/support/shobj-conf b/support/shobj-conf
|
|
index 7920f1b..e7520cb 100644
|
|
--- a/support/shobj-conf
|
|
+++ b/support/shobj-conf
|
|
@@ -126,10 +126,11 @@ sunos5*|solaris2*)
|
|
linux*-*|gnu*-*|k*bsd*-gnu-*|freebsd*-gentoo)
|
|
SHOBJ_CFLAGS=-fPIC
|
|
SHOBJ_LD='${CC}'
|
|
- SHOBJ_LDFLAGS='-shared -Wl,-soname,$@'
|
|
+ SHOBJ_LDFLAGS='$(CFLAGS) -shared -Wl,-soname,$@'
|
|
|
|
- SHLIB_XLDFLAGS='-Wl,-rpath,$(libdir) -Wl,-soname,`basename $@ $(SHLIB_MINOR)`'
|
|
+ SHLIB_XLDFLAGS='-Wl,-soname,`basename $@ $(SHLIB_MINOR)`'
|
|
SHLIB_LIBVERSION='$(SHLIB_LIBSUFF).$(SHLIB_MAJOR)$(SHLIB_MINOR)'
|
|
+ SHLIB_LIBS='-ltinfo'
|
|
;;
|
|
|
|
freebsd2*)
|