parent
1368db5270
commit
e4db95e0f7
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
||||
/readline-7.0.tar.gz
|
||||
/readline-8.0.tar.gz
|
||||
/readline-8.1.tar.gz
|
||||
/readline-8.2.tar.gz
|
||||
|
@ -1,117 +0,0 @@
|
||||
From 5ad621bce2ec28f97706e58979b328f98367fd3f Mon Sep 17 00:00:00 2001
|
||||
From: Siteshwar Vashisht <svashisht@redhat.com>
|
||||
Date: Mon, 17 Jan 2022 21:27:26 +0100
|
||||
Subject: [PATCH] Add pkg-config configurations for libhistory
|
||||
|
||||
---
|
||||
MANIFEST | 1 +
|
||||
Makefile.in | 8 ++++++--
|
||||
configure | 3 ++-
|
||||
configure.ac | 2 +-
|
||||
history.pc.in | 12 ++++++++++++
|
||||
5 files changed, 22 insertions(+), 4 deletions(-)
|
||||
create mode 100644 history.pc.in
|
||||
|
||||
diff --git a/MANIFEST b/MANIFEST
|
||||
index ad49d66..5da0afa 100644
|
||||
--- a/MANIFEST
|
||||
+++ b/MANIFEST
|
||||
@@ -21,6 +21,7 @@ configure f
|
||||
configure.ac f
|
||||
Makefile.in f
|
||||
readline.pc.in f
|
||||
+history.pc.in f
|
||||
ansi_stdlib.h f
|
||||
chardefs.h f
|
||||
colors.h f
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index c57db60..2120daa 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -149,7 +149,7 @@ DOCUMENTATION = $(DOCSOURCE) $(DOCOBJECT) $(DOCSUPPORT)
|
||||
|
||||
CREATED_MAKEFILES = Makefile doc/Makefile examples/Makefile shlib/Makefile
|
||||
CREATED_CONFIGURE = config.status config.h config.cache config.log \
|
||||
- stamp-config stamp-h readline.pc
|
||||
+ stamp-config stamp-h readline.pc history.pc
|
||||
CREATED_TAGS = TAGS tags
|
||||
|
||||
INSTALLED_HEADERS = readline.h chardefs.h keymaps.h history.h tilde.h \
|
||||
@@ -243,10 +243,11 @@ maybe-uninstall-headers: uninstall-headers
|
||||
|
||||
install-pc: installdirs
|
||||
-$(INSTALL_DATA) $(BUILD_DIR)/readline.pc $(DESTDIR)$(pkgconfigdir)/readline.pc
|
||||
+ -$(INSTALL_DATA) $(BUILD_DIR)/history.pc $(DESTDIR)$(pkgconfigdir)/history.pc
|
||||
|
||||
uninstall-pc:
|
||||
-test -n "$(pkgconfigdir)" && cd $(DESTDIR)$(pkgconfigdir) && \
|
||||
- ${RM} readline.pc
|
||||
+ ${RM} readline.pc history.pc
|
||||
|
||||
maybe-uninstall-pc: uninstall-pc
|
||||
|
||||
@@ -324,6 +325,9 @@ distclean maintainer-clean: clean
|
||||
readline.pc: config.status $(srcdir)/readline.pc.in
|
||||
$(SHELL) config.status
|
||||
|
||||
+history.pc: config.status $(srcdir)/history.pc.in
|
||||
+ $(SHELL) config.status
|
||||
+
|
||||
info dvi html pdf ps:
|
||||
-( cd doc && $(MAKE) $(MFLAGS) $@ )
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 5a0bf2f..fe5d4b4 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -6941,7 +6941,7 @@ CFLAGS="$CFLAGS $STYLE_CFLAGS"
|
||||
|
||||
|
||||
|
||||
-ac_config_files="$ac_config_files Makefile doc/Makefile examples/Makefile shlib/Makefile readline.pc"
|
||||
+ac_config_files="$ac_config_files Makefile doc/Makefile examples/Makefile shlib/Makefile readline.pc history.pc"
|
||||
|
||||
ac_config_commands="$ac_config_commands default"
|
||||
|
||||
@@ -7645,6 +7645,7 @@ do
|
||||
"examples/Makefile") CONFIG_FILES="$CONFIG_FILES examples/Makefile" ;;
|
||||
"shlib/Makefile") CONFIG_FILES="$CONFIG_FILES shlib/Makefile" ;;
|
||||
"readline.pc") CONFIG_FILES="$CONFIG_FILES readline.pc" ;;
|
||||
+ "history.pc") CONFIG_FILES="$CONFIG_FILES history.pc" ;;
|
||||
"default") CONFIG_COMMANDS="$CONFIG_COMMANDS default" ;;
|
||||
|
||||
*) as_fn_error $? "invalid argument: \`$ac_config_target'" "$LINENO" 5;;
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 147bae5..070c891 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -328,7 +328,7 @@ AC_SUBST(LIBVERSION)
|
||||
AC_SUBST(TERMCAP_LIB)
|
||||
AC_SUBST(TERMCAP_PKG_CONFIG_LIB)
|
||||
|
||||
-AC_OUTPUT([Makefile doc/Makefile examples/Makefile shlib/Makefile readline.pc],
|
||||
+AC_OUTPUT([Makefile doc/Makefile examples/Makefile shlib/Makefile readline.pc history.pc],
|
||||
[
|
||||
# Makefile uses this timestamp file to record whether config.h is up to date.
|
||||
echo > stamp-h
|
||||
diff --git a/history.pc.in b/history.pc.in
|
||||
new file mode 100644
|
||||
index 0000000..aa4a0c9
|
||||
--- /dev/null
|
||||
+++ b/history.pc.in
|
||||
@@ -0,0 +1,12 @@
|
||||
+prefix=@prefix@
|
||||
+exec_prefix=@exec_prefix@
|
||||
+libdir=@libdir@
|
||||
+includedir=@includedir@
|
||||
+
|
||||
+Name: History
|
||||
+Description: Gnu History library for managing the text of previously typed lines
|
||||
+URL: http://tiswww.cwru.edu/php/chet/readline/rltop.html
|
||||
+Version: @LIBVERSION@
|
||||
+Requires.private: @TERMCAP_PKG_CONFIG_LIB@
|
||||
+Libs: -L${libdir} -lhistory
|
||||
+Cflags: -I${includedir}
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,5 +1,4 @@
|
||||
diff --git a/shlib/Makefile.in b/shlib/Makefile.in
|
||||
index d138524..b68b0cc 100644
|
||||
--- a/shlib/Makefile.in
|
||||
+++ b/shlib/Makefile.in
|
||||
@@ -178,7 +178,7 @@ $(SHARED_READLINE): $(SHARED_OBJ)
|
||||
@ -12,11 +11,10 @@ index d138524..b68b0cc 100644
|
||||
# Since tilde.c is shared between readline and bash, make sure we compile
|
||||
# it with the right flags when it's built as part of readline
|
||||
diff --git a/support/shobj-conf b/support/shobj-conf
|
||||
index 5a3f977..0668a33 100644
|
||||
--- a/support/shobj-conf
|
||||
+++ b/support/shobj-conf
|
||||
@@ -126,10 +126,11 @@ sunos5*|solaris2*)
|
||||
linux*-*|gnu*-*|k*bsd*-gnu-*|freebsd*|dragonfly*)
|
||||
linux*-*|gnu*-*|k*bsd*-gnu-*|midnightbsd*|freebsd*|dragonfly*)
|
||||
SHOBJ_CFLAGS=-fPIC
|
||||
SHOBJ_LD='${CC}'
|
||||
- SHOBJ_LDFLAGS='-shared -Wl,-soname,$@'
|
||||
|
@ -1,68 +0,0 @@
|
||||
From 9ba3434aa5434e509300a3722b0479fd30480b44 Mon Sep 17 00:00:00 2001
|
||||
From: Chet Ramey <chet.ramey@case.edu>
|
||||
Date: Tue, 4 May 2021 14:26:34 -0400
|
||||
Subject: [PATCH] Readline-8.1 patch 1: fix version comparisons in startup
|
||||
files
|
||||
|
||||
---
|
||||
bind.c | 15 ++++++++-------
|
||||
patchlevel | 2 +-
|
||||
2 files changed, 9 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/bind.c b/bind.c
|
||||
index 87596dc..7610378 100644
|
||||
--- a/bind.c
|
||||
+++ b/bind.c
|
||||
@@ -1234,7 +1234,7 @@ parser_if (char *args)
|
||||
#endif /* VI_MODE */
|
||||
else if (_rl_strnicmp (args, "version", 7) == 0)
|
||||
{
|
||||
- int rlversion, versionarg, op, previ, major, minor;
|
||||
+ int rlversion, versionarg, op, previ, major, minor, opresult;
|
||||
|
||||
_rl_parsing_conditionalized_out = 1;
|
||||
rlversion = RL_VERSION_MAJOR*10 + RL_VERSION_MINOR;
|
||||
@@ -1294,24 +1294,25 @@ parser_if (char *args)
|
||||
switch (op)
|
||||
{
|
||||
case OP_EQ:
|
||||
- _rl_parsing_conditionalized_out = rlversion == versionarg;
|
||||
+ opresult = rlversion == versionarg;
|
||||
break;
|
||||
case OP_NE:
|
||||
- _rl_parsing_conditionalized_out = rlversion != versionarg;
|
||||
+ opresult = rlversion != versionarg;
|
||||
break;
|
||||
case OP_GT:
|
||||
- _rl_parsing_conditionalized_out = rlversion > versionarg;
|
||||
+ opresult = rlversion > versionarg;
|
||||
break;
|
||||
case OP_GE:
|
||||
- _rl_parsing_conditionalized_out = rlversion >= versionarg;
|
||||
+ opresult = rlversion >= versionarg;
|
||||
break;
|
||||
case OP_LT:
|
||||
- _rl_parsing_conditionalized_out = rlversion < versionarg;
|
||||
+ opresult = rlversion < versionarg;
|
||||
break;
|
||||
case OP_LE:
|
||||
- _rl_parsing_conditionalized_out = rlversion <= versionarg;
|
||||
+ opresult = rlversion <= versionarg;
|
||||
break;
|
||||
}
|
||||
+ _rl_parsing_conditionalized_out = 1 - opresult;
|
||||
}
|
||||
/* Check to see if the first word in ARGS is the same as the
|
||||
value stored in rl_readline_name. */
|
||||
diff --git a/patchlevel b/patchlevel
|
||||
index d8c9df7..fdf4740 100644
|
||||
--- a/patchlevel
|
||||
+++ b/patchlevel
|
||||
@@ -1,3 +1,3 @@
|
||||
# Do not edit -- exists only for use by patch
|
||||
|
||||
-0
|
||||
+1
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,36 +0,0 @@
|
||||
From 5263c0d88064fda96292335d12eec1733f91cdc9 Mon Sep 17 00:00:00 2001
|
||||
From: Chet Ramey <chet.ramey@case.edu>
|
||||
Date: Wed, 5 Jan 2022 11:09:58 -0500
|
||||
Subject: [PATCH] Readline-8.1 patch 2: fix redisplay of some characters > 128
|
||||
in certain single-byte encodings
|
||||
|
||||
---
|
||||
display.c | 2 +-
|
||||
patchlevel | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/display.c b/display.c
|
||||
index 38b3d0e..f5d3294 100644
|
||||
--- a/display.c
|
||||
+++ b/display.c
|
||||
@@ -1598,7 +1598,7 @@ puts_face (const char *str, const char *face, int n)
|
||||
char cur_face;
|
||||
|
||||
for (cur_face = FACE_NORMAL, i = 0; i < n; i++)
|
||||
- putc_face (str[i], face[i], &cur_face);
|
||||
+ putc_face ((unsigned char) str[i], face[i], &cur_face);
|
||||
putc_face (EOF, FACE_NORMAL, &cur_face);
|
||||
}
|
||||
|
||||
diff --git a/patchlevel b/patchlevel
|
||||
index fdf4740..7cbda82 100644
|
||||
--- a/patchlevel
|
||||
+++ b/patchlevel
|
||||
@@ -1,3 +1,3 @@
|
||||
# Do not edit -- exists only for use by patch
|
||||
|
||||
-1
|
||||
+2
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,22 +1,17 @@
|
||||
Summary: A library for editing typed command lines
|
||||
Name: readline
|
||||
Version: 8.1
|
||||
Release: 7%{?dist}
|
||||
Version: 8.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
URL: https://tiswww.case.edu/php/chet/readline/rltop.html
|
||||
Source: ftp://ftp.gnu.org/gnu/readline/readline-%{version}.tar.gz
|
||||
|
||||
# Official upstream patches
|
||||
# Patches are converted to apply with '-p1'
|
||||
Patch1: readline-8.1-patch-1.patch
|
||||
Patch2: readline-8.1-patch-2.patch
|
||||
|
||||
# Other patches
|
||||
# Remove RPATH, use CFLAGS
|
||||
Patch101: readline-8.0-shlib.patch
|
||||
# Remove this patch during next rebase
|
||||
# https://git.savannah.gnu.org/cgit/readline.git/commit/?h=devel&id=d5d497730cf7708b6dcb85479f8bdfc748d23ff8
|
||||
Patch102: 0001-Add-pkg-config-configurations-for-libhistory.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
@ -87,6 +82,10 @@ rm -vf %{buildroot}%{_infodir}/dir*
|
||||
%{_libdir}/libhistory.a
|
||||
|
||||
%changelog
|
||||
* Wed Oct 05 2022 Siteshwar Vashisht <svashisht@redhat.com> - 8.2-1
|
||||
- Update to readline-8.2
|
||||
Resolves: #2129926
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 8.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (readline-8.1.tar.gz) = 27790d0461da3093a7fee6e89a51dcab5dc61928ec42e9228ab36493b17220641d5e481ea3d8fee5ee0044c70bf960f55c7d3f1a704cf6b9c42e5c269b797e00
|
||||
SHA512 (readline-8.2.tar.gz) = 0a451d459146bfdeecc9cdd94bda6a6416d3e93abd80885a40b334312f16eb890f8618a27ca26868cebbddf1224983e631b1cbc002c1a4d1cd0d65fba9fea49a
|
||||
|
Loading…
Reference in New Issue
Block a user