- update to 6.1

This commit is contained in:
Miroslav Lichvar 2010-01-12 14:55:52 +00:00
parent 1ee0fa6967
commit 617e85be5b
8 changed files with 20 additions and 269 deletions

View File

@ -1 +1 @@
readline-6.0.tar.gz
readline-6.1.tar.gz

View File

@ -1,7 +1,7 @@
diff -up readline-6.0/shlib/Makefile.in.shlib readline-6.0/shlib/Makefile.in
--- readline-6.0/shlib/Makefile.in.shlib 2009-01-06 18:03:22.000000000 +0100
+++ readline-6.0/shlib/Makefile.in 2009-07-02 14:36:15.000000000 +0200
@@ -169,7 +169,7 @@ $(SHARED_READLINE): $(SHARED_OBJ)
diff -up readline-6.1/shlib/Makefile.in.shlib readline-6.1/shlib/Makefile.in
--- readline-6.1/shlib/Makefile.in.shlib 2009-03-05 16:51:23.000000000 +0100
+++ readline-6.1/shlib/Makefile.in 2010-01-12 15:05:32.000000000 +0100
@@ -170,7 +170,7 @@ $(SHARED_READLINE): $(SHARED_OBJ)
$(SHARED_HISTORY): $(SHARED_HISTOBJ) xmalloc.so
$(RM) $@
@ -10,10 +10,10 @@ diff -up readline-6.0/shlib/Makefile.in.shlib readline-6.0/shlib/Makefile.in
# Since tilde.c is shared between readline and bash, make sure we compile
# it with the right flags when it's built as part of readline
diff -up readline-6.0/support/shlib-install.shlib readline-6.0/support/shlib-install
--- readline-6.0/support/shlib-install.shlib 2008-07-20 01:16:05.000000000 +0200
+++ readline-6.0/support/shlib-install 2009-07-02 14:37:59.000000000 +0200
@@ -71,7 +71,7 @@ fi
diff -up readline-6.1/support/shlib-install.shlib readline-6.1/support/shlib-install
--- readline-6.1/support/shlib-install.shlib 2009-10-28 14:30:18.000000000 +0100
+++ readline-6.1/support/shlib-install 2010-01-12 15:05:32.000000000 +0100
@@ -72,7 +72,7 @@ fi
case "$host_os" in
hpux*|darwin*|macosx*|linux*)
if [ -z "$uninstall" ]; then
@ -22,11 +22,11 @@ diff -up readline-6.0/support/shlib-install.shlib readline-6.0/support/shlib-ins
fi ;;
cygwin*|mingw*)
IMPLIBNAME=`echo ${LIBNAME} \
diff -up readline-6.0/support/shobj-conf.shlib readline-6.0/support/shobj-conf
--- readline-6.0/support/shobj-conf.shlib 2009-01-04 20:32:42.000000000 +0100
+++ readline-6.0/support/shobj-conf 2009-07-02 14:40:06.000000000 +0200
diff -up readline-6.1/support/shobj-conf.shlib readline-6.1/support/shobj-conf
--- readline-6.1/support/shobj-conf.shlib 2009-10-28 14:20:21.000000000 +0100
+++ readline-6.1/support/shobj-conf 2010-01-12 15:07:27.000000000 +0100
@@ -112,10 +112,11 @@ sunos5*|solaris2*)
linux*-*|gnu*-*|k*bsd*-gnu-*)
linux*-*|gnu*-*|k*bsd*-gnu-*|freebsd*-gentoo)
SHOBJ_CFLAGS=-fPIC
SHOBJ_LD='${CC}'
- SHOBJ_LDFLAGS='-shared -Wl,-soname,$@'

View File

@ -1,17 +1,13 @@
Summary: A library for editing typed command lines
Name: readline
Version: 6.0
Release: 3%{?dist}
Version: 6.1
Release: 1%{?dist}
License: GPLv3+
Group: System Environment/Libraries
URL: http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
Source: ftp://ftp.gnu.org/gnu/readline/readline-%{version}.tar.gz
Patch1: ftp://ftp.gnu.org/gnu/readline/readline-6.0-patches/readline60-001
Patch2: ftp://ftp.gnu.org/gnu/readline/readline-6.0-patches/readline60-002
Patch3: ftp://ftp.gnu.org/gnu/readline/readline-6.0-patches/readline60-003
Patch4: ftp://ftp.gnu.org/gnu/readline/readline-6.0-patches/readline60-004
# fix file permissions, remove RPATH, use CFLAGS
Patch20: readline-6.0-shlib.patch
Patch20: readline-6.1-shlib.patch
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
BuildRequires: ncurses-devel
@ -50,10 +46,6 @@ library.
%prep
%setup -q
%patch1 -p0 -b .001
%patch2 -p0 -b .002
%patch3 -p0 -b .003
%patch4 -p0 -b .004
%patch20 -p1 -b .shlib
pushd examples
@ -132,6 +124,9 @@ fi
%{_libdir}/lib*.a
%changelog
* Tue Jan 12 2010 Miroslav Lichvar <mlichvar@redhat.com> 6.1-1
- update to 6.1
* Tue Aug 25 2009 Miroslav Lichvar <mlichvar@redhat.com> 6.0-3
- include patch 004
- suppress install-info errors (#515910)

View File

@ -1,79 +0,0 @@
READLINE PATCH REPORT
=====================
Readline-Release: 6.0
Patch-ID: readline60-001
Bug-Reported-by: Nicolai Lissner <nlissne@linux01.org>
Bug-Reference-ID: <20090412020510.GA29658@lilith>
Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2009-04/msg00104.html
Bug-Description:
If a SIGWINCH arrives while bash is performing redisplay, multi-line prompts
are displayed incorrectly due to the display code being called recursively.
Patch:
*** ../readline-6.0/readline.h 2009-01-04 14:32:33.000000000 -0500
--- readline.h 2009-04-13 08:47:00.000000000 -0400
***************
*** 815,820 ****
#define RL_STATE_MULTIKEY 0x200000 /* reading multiple-key command */
#define RL_STATE_VICMDONCE 0x400000 /* entered vi command mode at least once */
! #define RL_STATE_DONE 0x800000 /* done; accepted line */
#define RL_SETSTATE(x) (rl_readline_state |= (x))
--- 815,821 ----
#define RL_STATE_MULTIKEY 0x200000 /* reading multiple-key command */
#define RL_STATE_VICMDONCE 0x400000 /* entered vi command mode at least once */
+ #define RL_STATE_REDISPLAYING 0x800000 /* updating terminal display */
! #define RL_STATE_DONE 0x1000000 /* done; accepted line */
#define RL_SETSTATE(x) (rl_readline_state |= (x))
*** ../readline-6.0/display.c 2009-01-04 14:32:32.000000000 -0500
--- display.c 2009-04-13 08:29:54.000000000 -0400
***************
*** 513,516 ****
--- 513,517 ----
data structures. */
_rl_block_sigint ();
+ RL_SETSTATE (RL_STATE_REDISPLAYING);
if (!rl_display_prompt)
***************
*** 1237,1240 ****
--- 1238,1242 ----
}
+ RL_UNSETSTATE (RL_STATE_REDISPLAYING);
_rl_release_sigint ();
}
*** ../readline-6.0/terminal.c 2009-01-04 14:32:34.000000000 -0500
--- terminal.c 2009-04-13 08:43:00.000000000 -0400
***************
*** 356,360 ****
if (CUSTOM_REDISPLAY_FUNC ())
rl_forced_update_display ();
! else
_rl_redisplay_after_sigwinch ();
}
--- 356,360 ----
if (CUSTOM_REDISPLAY_FUNC ())
rl_forced_update_display ();
! else if (RL_ISSTATE(RL_STATE_REDISPLAYING) == 0)
_rl_redisplay_after_sigwinch ();
}
*** ../readline-6.0/patchlevel 2008-11-18 11:01:14.000000000 -0500
--- patchlevel 2009-05-09 12:01:06.000000000 -0400
***************
*** 1,3 ****
# Do not edit -- exists only for use by patch
! 0
--- 1,3 ----
# Do not edit -- exists only for use by patch
! 1

View File

@ -1,44 +0,0 @@
READLINE PATCH REPORT
=====================
Readline-Release: 6.0
Patch-ID: readline60-002
Bug-Reported-by: Matt Zyzik <matt.zyzik@nyu.edu>
Bug-Reference-ID: <20090319015542.696F62B8E8@ice.filescope.com>
Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2009-03/msg00149.html
Bug-Description:
When not in a locale supporting multibyte characters, readline will occasionally
not erase characters between the cursor position and the end of the line
when killing text backwards.
Patch:
*** ../readline-6.0/display.c 2009-01-04 14:32:32.000000000 -0500
--- display.c 2009-04-14 14:00:18.000000000 -0400
***************
*** 1775,1779 ****
adjust col_lendiff based on the difference between _rl_last_c_pos
and _rl_screenwidth */
! if (col_lendiff && (_rl_last_c_pos < _rl_screenwidth))
#endif
{
--- 1775,1779 ----
adjust col_lendiff based on the difference between _rl_last_c_pos
and _rl_screenwidth */
! if (col_lendiff && ((MB_CUR_MAX == 1 || rl_byte_oriented) || (_rl_last_c_pos < _rl_screenwidth)))
#endif
{
*** ../readline-6.0/patchlevel 2008-11-18 11:01:14.000000000 -0500
--- patchlevel 2009-05-09 12:01:06.000000000 -0400
***************
*** 1,3 ****
# Do not edit -- exists only for use by patch
! 1
--- 1,3 ----
# Do not edit -- exists only for use by patch
! 2

View File

@ -1,58 +0,0 @@
READLINE PATCH REPORT
=====================
Readline-Release: 6.0
Patch-ID: readline60-003
Bug-Reported-by: Andreas Schwab <schwab@linux-m68k.org>
Bug-Reference-ID: <m21vrhhx08.fsf@igel.home>
Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2009-04/msg00160.html
Bug-Description:
If the prompt length exactly matches the screen width, and the prompt ends
with invisible characters, readline positions the cursor incorrectly.
Patch:
*** ../readline-6.0/display.c 2009-01-04 14:32:32.000000000 -0500
--- display.c 2009-04-25 21:42:18.000000000 -0400
***************
*** 1895,1898 ****
--- 1897,1904 ----
woff = WRAP_OFFSET (_rl_last_v_pos, wrap_offset);
cpos = _rl_last_c_pos;
+
+ if (cpos == 0 && cpos == new)
+ return;
+
#if defined (HANDLE_MULTIBYTE)
/* If we have multibyte characters, NEW is indexed by the buffer point in
***************
*** 1908,1914 ****
desired display position. */
if ((new > prompt_last_invisible) || /* XXX - don't use woff here */
! (prompt_physical_chars > _rl_screenwidth &&
_rl_last_v_pos == prompt_last_screen_line &&
! wrap_offset >= woff &&
new > (prompt_last_invisible-(_rl_screenwidth*_rl_last_v_pos)-wrap_offset)))
/* XXX last comparison might need to be >= */
--- 1914,1920 ----
desired display position. */
if ((new > prompt_last_invisible) || /* XXX - don't use woff here */
! (prompt_physical_chars >= _rl_screenwidth &&
_rl_last_v_pos == prompt_last_screen_line &&
! wrap_offset >= woff && dpos >= woff &&
new > (prompt_last_invisible-(_rl_screenwidth*_rl_last_v_pos)-wrap_offset)))
/* XXX last comparison might need to be >= */
*** ../readline-6.0/patchlevel 2008-11-18 11:01:14.000000000 -0500
--- patchlevel 2009-05-09 12:01:06.000000000 -0400
***************
*** 1,3 ****
# Do not edit -- exists only for use by patch
! 2
--- 1,3 ----
# Do not edit -- exists only for use by patch
! 3

View File

@ -1,63 +0,0 @@
READLINE PATCH REPORT
=====================
Readline-Release: 6.0
Patch-ID: readline60-004
Bug-Reported-by: jim@jim.sh
Bug-Reference-ID: <200905262140.n4QLeO4X030664@psychosis.jim.sh>
Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2009-05/msg00074.html
Bug-Description:
There are occasional cursor positioning errors when using readline's
horizontal scroll mode.
Patch:
*** ../readline-6.0-patched/display.c 2009-05-22 12:32:25.000000000 -0400
--- display.c 2009-05-29 23:32:20.000000000 -0400
***************
*** 1190,1196 ****
line[t - 1] = '>';
! if (!rl_display_fixed || forced_display || lmargin != last_lmargin)
{
forced_display = 0;
update_line (&visible_line[last_lmargin],
&invisible_line[lmargin],
--- 1192,1200 ----
line[t - 1] = '>';
! if (rl_display_fixed == 0 || forced_display || lmargin != last_lmargin)
{
forced_display = 0;
+ o_cpos = _rl_last_c_pos;
+ cpos_adjusted = 0;
update_line (&visible_line[last_lmargin],
&invisible_line[lmargin],
***************
*** 1200,1203 ****
--- 1204,1214 ----
0);
+ if ((MB_CUR_MAX > 1 && rl_byte_oriented == 0) &&
+ cpos_adjusted == 0 &&
+ _rl_last_c_pos != o_cpos &&
+ _rl_last_c_pos > wrap_offset &&
+ o_cpos < prompt_last_invisible)
+ _rl_last_c_pos -= prompt_invis_chars_first_line; /* XXX - was wrap_offset */
+
/* If the visible new line is shorter than the old, but the number
of invisible characters is greater, and we are at the end of
*** ../readline-6.0/patchlevel 2008-11-18 11:01:14.000000000 -0500
--- patchlevel 2009-05-09 12:01:06.000000000 -0400
***************
*** 1,3 ****
# Do not edit -- exists only for use by patch
! 3
--- 1,3 ----
# Do not edit -- exists only for use by patch
! 4

View File

@ -1 +1 @@
b7f65a48add447693be6e86f04a63019 readline-6.0.tar.gz
fc2f7e714fe792db1ce6ddc4c9fb4ef3 readline-6.1.tar.gz