Rebase to readline-8.0

- Remove patches for readline-7.0
- Tweak shlib patch to apply with readline-8.0
- Add pkgconfig file for readline-8.0
This commit is contained in:
Siteshwar Vashisht 2019-02-15 14:41:19 +01:00
parent f07976f8b5
commit 256945080d
9 changed files with 12 additions and 277 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/readline-6.3.tar.gz
/readline-7.0.tar.gz
/readline-8.0.tar.gz

View File

@ -1,46 +0,0 @@
From acf3951d483e7b3478db4d731f4a8af99d27327d Mon Sep 17 00:00:00 2001
From: Chet Ramey <chet.ramey@case.edu>
Date: Wed, 16 Nov 2016 12:57:31 -0500
Subject: [PATCH] Readline-7.0 patch 1
---
history.c | 6 +++++-
patchlevel | 2 +-
2 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/history.c b/history.c
index 3b8dbc5..9ff25a7 100644
--- a/history.c
+++ b/history.c
@@ -57,6 +57,8 @@ extern int errno;
/* How big to make the_history when we first allocate it. */
#define DEFAULT_HISTORY_INITIAL_SIZE 502
+#define MAX_HISTORY_INITIAL_SIZE 8192
+
/* The number of slots to increase the_history by. */
#define DEFAULT_HISTORY_GROW_SIZE 50
@@ -307,7 +309,9 @@ add_history (string)
if (history_size == 0)
{
if (history_stifled && history_max_entries > 0)
- history_size = history_max_entries + 2;
+ history_size = (history_max_entries > MAX_HISTORY_INITIAL_SIZE)
+ ? MAX_HISTORY_INITIAL_SIZE
+ : history_max_entries + 2;
else
history_size = DEFAULT_HISTORY_INITIAL_SIZE;
the_history = (HIST_ENTRY **)xmalloc (history_size * sizeof (HIST_ENTRY *));
diff --git a/patchlevel b/patchlevel
index d8c9df7..fdf4740 100644
--- a/patchlevel
+++ b/patchlevel
@@ -1,3 +1,3 @@
# Do not edit -- exists only for use by patch
-0
+1
--
2.9.3

View File

@ -1,77 +0,0 @@
From e3f5a97bfa54db0d4e4fe67e406e64f1a58508ea Mon Sep 17 00:00:00 2001
From: Chet Ramey <chet.ramey@case.edu>
Date: Sun, 29 Jan 2017 13:55:34 -0500
Subject: [PATCH] Readline-7.0 patch 2
---
history.c | 16 +++++++---------
patchlevel | 2 +-
2 files changed, 8 insertions(+), 10 deletions(-)
diff --git a/history.c b/history.c
index 9ff25a7..129c57a 100644
--- a/history.c
+++ b/history.c
@@ -279,6 +279,7 @@ add_history (string)
const char *string;
{
HIST_ENTRY *temp;
+ int new_length;
if (history_stifled && (history_length == history_max_entries))
{
@@ -295,13 +296,9 @@ add_history (string)
/* Copy the rest of the entries, moving down one slot. Copy includes
trailing NULL. */
-#if 0
- for (i = 0; i < history_length; i++)
- the_history[i] = the_history[i + 1];
-#else
memmove (the_history, the_history + 1, history_length * sizeof (HIST_ENTRY *));
-#endif
+ new_length = history_length;
history_base++;
}
else
@@ -315,7 +312,7 @@ add_history (string)
else
history_size = DEFAULT_HISTORY_INITIAL_SIZE;
the_history = (HIST_ENTRY **)xmalloc (history_size * sizeof (HIST_ENTRY *));
- history_length = 1;
+ new_length = 1;
}
else
{
@@ -325,14 +322,15 @@ add_history (string)
the_history = (HIST_ENTRY **)
xrealloc (the_history, history_size * sizeof (HIST_ENTRY *));
}
- history_length++;
+ new_length = history_length + 1;
}
}
temp = alloc_history_entry ((char *)string, hist_inittime ());
- the_history[history_length] = (HIST_ENTRY *)NULL;
- the_history[history_length - 1] = temp;
+ the_history[new_length] = (HIST_ENTRY *)NULL;
+ the_history[new_length - 1] = temp;
+ history_length = new_length;
}
/* Change the time stamp of the most recent history entry to STRING. */
diff --git a/patchlevel b/patchlevel
index fdf4740..7cbda82 100644
--- a/patchlevel
+++ b/patchlevel
@@ -1,3 +1,3 @@
# Do not edit -- exists only for use by patch
-1
+2
--
2.13.6

View File

@ -1,34 +0,0 @@
From 6c32f81cd66bbe86218469063690c84205661a5e Mon Sep 17 00:00:00 2001
From: Chet Ramey <chet.ramey@case.edu>
Date: Sun, 29 Jan 2017 13:55:51 -0500
Subject: [PATCH] Readline-7.0 patch 3
---
input.c | 1 +
patchlevel | 2 +-
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/input.c b/input.c
index 286897d..24126ea 100644
--- a/input.c
+++ b/input.c
@@ -513,6 +513,7 @@ rl_getc (stream)
result = 0;
#if defined (HAVE_PSELECT)
sigemptyset (&empty_set);
+ sigprocmask (SIG_BLOCK, (sigset_t *)NULL, &empty_set);
FD_ZERO (&readfds);
FD_SET (fileno (stream), &readfds);
result = pselect (fileno (stream) + 1, &readfds, NULL, NULL, NULL, &empty_set);
diff --git a/patchlevel b/patchlevel
index 7cbda82..ce3e355 100644
--- a/patchlevel
+++ b/patchlevel
@@ -1,3 +1,3 @@
# Do not edit -- exists only for use by patch
-2
+3
--
2.13.6

View File

@ -1,37 +0,0 @@
From 457e4fbeb977ffe065dc2ba05a0ebc4000b32065 Mon Sep 17 00:00:00 2001
From: Chet Ramey <chet.ramey@case.edu>
Date: Fri, 1 Jun 2018 10:17:06 -0400
Subject: [PATCH] readline-7.0 patch 4
---
display.c | 4 +++-
patchlevel | 2 +-
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/display.c b/display.c
index 41fb053..2d2e768 100644
--- a/display.c
+++ b/display.c
@@ -771,7 +771,9 @@ rl_redisplay ()
appear in the first and last lines of the prompt */
wadjust = (newlines == 0)
? prompt_invis_chars_first_line
- : ((newlines == prompt_lines_estimate) ? wrap_offset : prompt_invis_chars_first_line);
+ : ((newlines == prompt_lines_estimate)
+ ? (wrap_offset - prompt_invis_chars_first_line)
+ : 0);
/* fix from Darin Johnson <darin@acuson.com> for prompt string with
invisible characters that is longer than the screen width. The
diff --git a/patchlevel b/patchlevel
index ce3e355..626a945 100644
--- a/patchlevel
+++ b/patchlevel
@@ -1,3 +1,3 @@
# Do not edit -- exists only for use by patch
-3
+4
--
2.14.4

View File

@ -1,44 +0,0 @@
From 57ea39840aebbb34571df1586acc66783b3368d0 Mon Sep 17 00:00:00 2001
From: Chet Ramey <chet.ramey@case.edu>
Date: Fri, 1 Jun 2018 10:17:53 -0400
Subject: [PATCH] readline-7.0 patch 5
---
patchlevel | 2 +-
readline.c | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/patchlevel b/patchlevel
index 626a945..e0ba09d 100644
--- a/patchlevel
+++ b/patchlevel
@@ -1,3 +1,3 @@
# Do not edit -- exists only for use by patch
-4
+5
diff --git a/readline.c b/readline.c
index e51df4f..a05b35e 100644
--- a/readline.c
+++ b/readline.c
@@ -1057,7 +1057,7 @@ _rl_subseq_result (r, map, key, got_subseq)
/* We probably shadowed a keymap, so keep going. */
r = _rl_dispatch (ANYOTHERKEY, m);
}
- else if (r && map[ANYOTHERKEY].function)
+ else if (r < 0 && map[ANYOTHERKEY].function)
{
/* We didn't match (r is probably -1), so return something to
tell the caller that it should try ANYOTHERKEY for an
@@ -1069,7 +1069,7 @@ _rl_subseq_result (r, map, key, got_subseq)
_rl_dispatching_keymap = map;
return -2;
}
- else if (r && got_subseq)
+ else if (r < 0 && got_subseq) /* XXX */
{
/* OK, back up the chain. */
if (RL_ISSTATE (RL_STATE_MACROINPUT))
--
2.14.4

View File

@ -1,16 +1,5 @@
From 5f7f73a57b16ef58769004fe2f4111baf1c81690 Mon Sep 17 00:00:00 2001
From: Jan Chaloupka <jchaloup@redhat.com>
Date: Mon, 21 Jul 2014 13:50:01 +0200
Subject: [PATCH] shlib
---
shlib/Makefile.in | 2 +-
support/shlib-install | 2 +-
support/shobj-conf | 5 +++--
3 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/shlib/Makefile.in b/shlib/Makefile.in
index eb16211..3a34840 100644
index f2ec3e4..5c8994c 100644
--- a/shlib/Makefile.in
+++ b/shlib/Makefile.in
@@ -178,7 +178,7 @@ $(SHARED_READLINE): $(SHARED_OBJ)
@ -22,21 +11,8 @@ index eb16211..3a34840 100644
# Since tilde.c is shared between readline and bash, make sure we compile
# it with the right flags when it's built as part of readline
diff --git a/support/shlib-install b/support/shlib-install
index cfec3bd..f4eea27 100755
--- a/support/shlib-install
+++ b/support/shlib-install
@@ -73,7 +73,7 @@ fi
case "$host_os" in
hpux*|darwin*|macosx*|linux*|solaris2*)
if [ -z "$uninstall" ]; then
- chmod 555 ${INSTALLDIR}/${LIBNAME}
+ chmod 755 ${INSTALLDIR}/${LIBNAME}
fi ;;
cygwin*|mingw*)
IMPLIBNAME=`echo ${LIBNAME} \
diff --git a/support/shobj-conf b/support/shobj-conf
index 1f64433..40827a4 100644
index 7920f1b..e7520cb 100644
--- a/support/shobj-conf
+++ b/support/shobj-conf
@@ -126,10 +126,11 @@ sunos5*|solaris2*)
@ -53,6 +29,3 @@ index 1f64433..40827a4 100644
;;
freebsd2*)
--
1.9.3

View File

@ -1,22 +1,17 @@
Summary: A library for editing typed command lines
Name: readline
Version: 7.0
Release: 13%{?dist}
Version: 8.0
Release: 1%{?dist}
License: GPLv3+
URL: http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
Source: ftp://ftp.gnu.org/gnu/readline/readline-%{version}.tar.gz
# Official upstream patches
# Patches are converted to apply with '-p1'
Patch1: Readline-7.0-patch-1.patch
Patch2: Readline-7.0-patch-2.patch
Patch3: Readline-7.0-patch-3.patch
Patch4: Readline-7.0-patch-4.patch
Patch5: Readline-7.0-patch-5.patch
# Other patches
# fix file permissions, remove RPATH, use CFLAGS
Patch101: readline-7.0-shlib.patch
# Remove RPATH, use CFLAGS
Patch101: readline-8.0-shlib.patch
BuildRequires: gcc
BuildRequires: ncurses-devel
@ -79,6 +74,7 @@ rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
%{_includedir}/readline/
%{_libdir}/libreadline.so
%{_libdir}/libhistory.so
%{_libdir}/pkgconfig/%{name}.pc
%{_mandir}/man3/readline.3*
%{_mandir}/man3/history.3*
%{_infodir}/readline.info*
@ -88,6 +84,9 @@ rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
%{_libdir}/libhistory.a
%changelog
* Fri Feb 15 2019 Siteshwar Vashisht <svashisht@redhat.com> - 8.0-1
- Rebase to readline-8.0
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 7.0-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (readline-7.0.tar.gz) = 18243189d39bf0d4c8a76cddcce75243c1bae8824c686e9b6ba352667607e5b10c5feb79372a1093c1c388d821841670702e940df12eae94bcebdeed90047870
SHA512 (readline-8.0.tar.gz) = 41759d27bc3a258fefd7f4ff3277fa6ab9c21abb7b160e1a75aa8eba547bd90b288514e76264bd94fb0172da8a4faa54aab2c07b68a0356918ecf7f1969e866f