Rebase to upstream release v44.0
Instead of deleting unsupported providers after building, patch CMakeLists.txt to not build them at all. libcxgb3 and libnes do not exist anymore in rdma-core. ib_qib is not built in the RHEL kernel (CONFIG_INFINIBAND_QIB is not set), so modprobe config for truescale is unneeded. Resolves: rhbz#2112984, rhbz#2142687 Signed-off-by: Michal Schmidt <mschmidt@redhat.com>
This commit is contained in:
parent
a0a9855bcf
commit
1211e44e97
1
.gitignore
vendored
1
.gitignore
vendored
@ -16,3 +16,4 @@
|
||||
/rdma-core-37.1.tar.gz
|
||||
/rdma-core-37.2.tar.gz
|
||||
/rdma-core-41.0.tar.gz
|
||||
/rdma-core-44.0.tar.gz
|
||||
|
@ -0,0 +1,53 @@
|
||||
From ce79efe9af3e6b112c148e2c89d715937e6643bb Mon Sep 17 00:00:00 2001
|
||||
From: Michal Schmidt <mschmidt@redhat.com>
|
||||
Date: Wed, 1 Feb 2023 15:24:23 +0100
|
||||
Subject: [PATCH] CMakeLists: disable providers that were not enabled in RHEL
|
||||
9.1
|
||||
|
||||
Doing a package rebase, but don't want to enable additional drivers
|
||||
unless explicitly requested.
|
||||
|
||||
Upstream Status: RHEL only
|
||||
|
||||
Signed-off-by: Michal Schmidt <mschmidt@redhat.com>
|
||||
---
|
||||
CMakeLists.txt | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index bac10516bb85..b7eca65f0fe2 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -711,23 +711,23 @@ add_subdirectory(providers/bnxt_re)
|
||||
add_subdirectory(providers/cxgb4) # NO SPARSE
|
||||
add_subdirectory(providers/efa)
|
||||
add_subdirectory(providers/efa/man)
|
||||
-add_subdirectory(providers/erdma)
|
||||
+#add_subdirectory(providers/erdma)
|
||||
add_subdirectory(providers/hns)
|
||||
add_subdirectory(providers/irdma)
|
||||
-add_subdirectory(providers/mana)
|
||||
-add_subdirectory(providers/mana/man)
|
||||
+#add_subdirectory(providers/mana)
|
||||
+#add_subdirectory(providers/mana/man)
|
||||
add_subdirectory(providers/mlx4)
|
||||
add_subdirectory(providers/mlx4/man)
|
||||
add_subdirectory(providers/mlx5)
|
||||
add_subdirectory(providers/mlx5/man)
|
||||
-add_subdirectory(providers/mthca)
|
||||
-add_subdirectory(providers/ocrdma)
|
||||
+#add_subdirectory(providers/mthca)
|
||||
+#add_subdirectory(providers/ocrdma)
|
||||
add_subdirectory(providers/qedr)
|
||||
add_subdirectory(providers/vmw_pvrdma)
|
||||
endif()
|
||||
|
||||
add_subdirectory(providers/hfi1verbs)
|
||||
-add_subdirectory(providers/ipathverbs)
|
||||
+#add_subdirectory(providers/ipathverbs)
|
||||
add_subdirectory(providers/rxe)
|
||||
add_subdirectory(providers/rxe/man)
|
||||
add_subdirectory(providers/siw)
|
||||
--
|
||||
2.39.1
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: rdma-core
|
||||
Version: 41.0
|
||||
Release: 3%{?dist}
|
||||
Version: 44.0
|
||||
Release: 1%{?dist}
|
||||
Summary: RDMA core userspace libraries and daemons
|
||||
|
||||
# Almost everything is licensed under the OFA dual GPLv2, 2 Clause BSD license
|
||||
@ -12,6 +12,7 @@ Url: https://github.com/linux-rdma/rdma-core
|
||||
Source: https://github.com/linux-rdma/rdma-core/releases/download/v%{version}/%{name}-%{version}.tar.gz
|
||||
Patch1: 0001-kernel-boot-Do-not-perform-device-rename-on-OPA-devi.patch
|
||||
Patch2: udev-keep-NAME_KERNEL-as-default-interface-naming-co.patch
|
||||
Patch3: 0003-CMakeLists-disable-providers-that-were-not-enabled-i.patch
|
||||
# Do not build static libs by default.
|
||||
%define with_static %{?_with_static: 1} %{?!_with_static: 0}
|
||||
|
||||
@ -268,6 +269,7 @@ easy, object-oriented access to IB verbs.
|
||||
%endif
|
||||
%if 0%{?rhel}
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%endif
|
||||
|
||||
%build
|
||||
@ -323,7 +325,6 @@ mkdir -p %{buildroot}/%{_sysconfdir}/rdma
|
||||
# Red Hat specific glue
|
||||
%global dracutlibdir %{_prefix}/lib/dracut
|
||||
%global sysmodprobedir %{_prefix}/lib/modprobe.d
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d
|
||||
mkdir -p %{buildroot}%{_libexecdir}
|
||||
mkdir -p %{buildroot}%{_udevrulesdir}
|
||||
mkdir -p %{buildroot}%{dracutlibdir}/modules.d/05rdma
|
||||
@ -344,18 +345,6 @@ install -D -m0644 redhat/rdma.conf %{buildroot}%{_sysconfdir}/rdma/modules/rdma.
|
||||
rm -rf %{buildroot}/%{_initrddir}/
|
||||
rm -f %{buildroot}/%{_sbindir}/srp_daemon.sh
|
||||
|
||||
# Remove ibverbs provider libs we don't support
|
||||
rm -f %{buildroot}/%{_libdir}/libibverbs/libcxgb3-rdmav*.so
|
||||
rm -f %{buildroot}/%{_sysconfdir}/libibverbs.d/cxgb3.driver
|
||||
rm -f %{buildroot}/%{_libdir}/libibverbs/libocrdma-rdmav*.so
|
||||
rm -f %{buildroot}/%{_sysconfdir}/libibverbs.d/ocrdma.driver
|
||||
rm -f %{buildroot}/%{_libdir}/libibverbs/libnes-rdmav*.so
|
||||
rm -f %{buildroot}/%{_sysconfdir}/libibverbs.d/nes.driver
|
||||
rm -f %{buildroot}/%{_libdir}/libibverbs/libmthca-rdmav*.so
|
||||
rm -f %{buildroot}/%{_sysconfdir}/libibverbs.d/mthca.driver
|
||||
rm -f %{buildroot}/%{_libdir}/libibverbs/libipathverbs-rdmav*.so
|
||||
rm -f %{buildroot}/%{_sysconfdir}/libibverbs.d/ipathverbs.driver
|
||||
|
||||
%ldconfig_scriptlets -n libibverbs
|
||||
|
||||
%ldconfig_scriptlets -n libibumad
|
||||
@ -393,6 +382,7 @@ fi
|
||||
%files
|
||||
%dir %{_sysconfdir}/rdma
|
||||
%dir %{_docdir}/%{name}
|
||||
%doc %{_docdir}/%{name}/70-persistent-ipoib.rules
|
||||
%doc %{_docdir}/%{name}/README.md
|
||||
%doc %{_docdir}/%{name}/rxe.md
|
||||
%doc %{_docdir}/%{name}/udev.md
|
||||
@ -403,10 +393,8 @@ fi
|
||||
%config(noreplace) %{_sysconfdir}/rdma/modules/opa.conf
|
||||
%config(noreplace) %{_sysconfdir}/rdma/modules/rdma.conf
|
||||
%config(noreplace) %{_sysconfdir}/rdma/modules/roce.conf
|
||||
%config(noreplace) %{_sysconfdir}/udev/rules.d/*
|
||||
%dir %{_sysconfdir}/modprobe.d
|
||||
%config(noreplace) %{_sysconfdir}/modprobe.d/mlx4.conf
|
||||
%config(noreplace) %{_sysconfdir}/modprobe.d/truescale.conf
|
||||
%{_unitdir}/rdma-hw.target
|
||||
%{_unitdir}/rdma-load-modules@.service
|
||||
%dir %{dracutlibdir}
|
||||
@ -424,7 +412,6 @@ fi
|
||||
%dir %{sysmodprobedir}
|
||||
%{sysmodprobedir}/libmlx4.conf
|
||||
%{_libexecdir}/mlx4-setup.sh
|
||||
%{_libexecdir}/truescale-serdes.cmds
|
||||
%{_sbindir}/rdma-ndd
|
||||
%{_unitdir}/rdma-ndd.service
|
||||
%{_mandir}/man7/rxe*
|
||||
@ -622,6 +609,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Feb 01 2023 Michal Schmidt <mschmidt@redhat.com> - 44.0-1
|
||||
- Rebase to upstream release v44.0
|
||||
- Resolves: rhbz#2112984, rhbz#2142687, rhbz#2111134
|
||||
|
||||
* Tue Aug 02 2022 Michal Schmidt <mschmidt@redhat.com> - 41.0-3
|
||||
- Rebase to upstream release v41.0
|
||||
- Resolves: rhbz#2049521
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (rdma-core-41.0.tar.gz) = 428d12d986effa0d58bc8b284fd5b7eab74fd484e1618cd3ebcfb1e4a142b5193fe4a7d305868d93bc44bcc591f08b81edfb0358c280111974a5335a79ae4f4c
|
||||
SHA512 (rdma-core-44.0.tar.gz) = f31c63aee415fb4aa721fdec2e4d9fb2bef964b1bea93f0170d30fb03b1e798cb11d46bb123db4b2a5002dec17ec16dc6e6aeaebe9f84517bf538dd114726ae1
|
||||
|
Loading…
Reference in New Issue
Block a user