radvd/radvd-c99-1.patch

32 lines
941 B
Diff

commit ff7ab0cf445236f30e58531175ba912614fed952
Author: Sam James <sam@gentoo.org>
Date: Thu Nov 17 22:03:25 2022 +0000
Makefile.am: drop -Wno-implicit-function-declaration
1. Clang 16 makes -Wimplicit-function-declaration error by default
(and it's planned that GCC 14 will do the same) so we need to fix
the real problem. This is papering over it.
2. It's not true that there's nothing we can do about it. Fix in a follow-up
commit.
Bug: https://bugs.gentoo.org/880823
Fixes: b5e6b09cf914a960ac3b1676b77d3ea9f91821c7
Signed-off-by: Sam James <sam@gentoo.org>
diff --git a/Makefile.am b/Makefile.am
index 3a52e3a4abab088b..88b0c3514d265524 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,9 +66,6 @@ radvd_LDADD = \
scanner.c: gram.h
gram.h: gram.c
-libradvd_parser_a_CFLAGS = \
- -Wno-implicit-function-declaration
-
libradvd_parser_a_SOURCES = \
gram.h \
gram.y \