- update to new upstream version
- remove patch fixed in upstream: initscript
This commit is contained in:
parent
20bc7b39c1
commit
dc83a550e6
@ -1 +1 @@
|
||||
radvd-1.0.tar.gz
|
||||
radvd-1.1.tar.gz
|
||||
|
@ -1,94 +0,0 @@
|
||||
diff -up radvd-1.0/redhat/radvd.init.initscript radvd-1.0/redhat/radvd.init
|
||||
--- radvd-1.0/redhat/radvd.init.initscript 2002-01-08 10:00:50.000000000 +0100
|
||||
+++ radvd-1.0/redhat/radvd.init 2007-11-12 17:12:17.000000000 +0100
|
||||
@@ -2,7 +2,10 @@
|
||||
#
|
||||
# $Id: radvd.init,v 1.2 2002/01/08 09:00:50 psavola Exp $
|
||||
#
|
||||
+### BEGIN INIT INFO
|
||||
+# provides: radvd
|
||||
# chkconfig: - 54 46
|
||||
+# short-Description: router advertisement daemon for IPv6
|
||||
# description: radvd is the router advertisement daemon for IPv6. It \
|
||||
# listens to router solicitations and sends router \
|
||||
# advertisements as described in "Neighbor Discovery for IP \
|
||||
@@ -15,6 +18,7 @@
|
||||
# pidfile: /var/run/radvd.pid
|
||||
# config: /etc/radvd.conf
|
||||
# config: /etc/sysconfig/radvd
|
||||
+### END INIT INFO
|
||||
|
||||
# Source function library.
|
||||
. /etc/rc.d/init.d/functions
|
||||
@@ -22,31 +26,37 @@
|
||||
# Get config.
|
||||
. /etc/sysconfig/network
|
||||
|
||||
-# Check that networking is up.
|
||||
-[ x${NETWORKING_IPV6} = "xyes" ] || exit 0
|
||||
-
|
||||
[ -f /etc/sysconfig/radvd ] && . /etc/sysconfig/radvd
|
||||
|
||||
-[ -f /usr/sbin/radvd ] || exit 0
|
||||
+if [ $1 == 'status' ]; then
|
||||
+ [ -f /usr/sbin/radvd ] || exit 4
|
||||
+else
|
||||
+ [ -f /usr/sbin/radvd ] || exit 1
|
||||
+fi
|
||||
|
||||
RETVAL=0
|
||||
-prog="radvd"
|
||||
+PROG="radvd"
|
||||
+LOCKFILE=/var/lock/subsys/radvd
|
||||
|
||||
# See how we were called.
|
||||
case "$1" in
|
||||
start)
|
||||
- echo -n $"Starting $prog: "
|
||||
+
|
||||
+ # Check that networking is up.
|
||||
+ [ x${NETWORKING_IPV6} = "xyes" ] || exit 1
|
||||
+
|
||||
+ echo -n $"Starting $PROG: "
|
||||
daemon radvd $OPTIONS
|
||||
RETVAL=$?
|
||||
echo
|
||||
- [ $RETVAL -eq 0 ] && touch /var/lock/subsys/radvd
|
||||
+ [ $RETVAL -eq 0 ] && touch $LOCKFILE
|
||||
;;
|
||||
stop)
|
||||
- echo -n $"Stopping $prog: "
|
||||
+ echo -n $"Stopping $PROG: "
|
||||
killproc radvd
|
||||
RETVAL=$?
|
||||
echo
|
||||
- [ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/radvd
|
||||
+ [ $RETVAL -eq 0 ] && rm -f $LOCKFILE
|
||||
;;
|
||||
status)
|
||||
status radvd
|
||||
@@ -58,13 +68,13 @@ case "$1" in
|
||||
RETVAL=$?
|
||||
;;
|
||||
reload)
|
||||
- echo -n $"Reloading $prog: "
|
||||
+ echo -n $"Reloading $PROG: "
|
||||
killproc radvd -HUP
|
||||
RETVAL=$?
|
||||
echo
|
||||
;;
|
||||
condrestart)
|
||||
- if [ -f /var/lock/subsys/radvd ]; then
|
||||
+ if [ -f $LOCKFILE ]; then
|
||||
$0 stop
|
||||
$0 start
|
||||
RETVAL=$?
|
||||
@@ -72,7 +82,7 @@ case "$1" in
|
||||
;;
|
||||
*)
|
||||
echo $"Usage: $0 {start|stop|status|restart|reload|condrestart}"
|
||||
- exit 1
|
||||
+ exit 2
|
||||
esac
|
||||
|
||||
exit $RETVAL
|
10
radvd.spec
10
radvd.spec
@ -4,14 +4,13 @@
|
||||
%define RADVD_UID 75
|
||||
Summary: A Router Advertisement daemon
|
||||
Name: radvd
|
||||
Version: 1.0
|
||||
Release: 6%{?dist}
|
||||
Version: 1.1
|
||||
Release: 1%{?dist}
|
||||
# The code includes the advertising clause, so it's GPL-incompatible
|
||||
License: BSD-style
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.litech.org/radvd/
|
||||
Source: http://www.litech.org/radvd/dist/%{name}-%{version}.tar.gz
|
||||
Patch1: radvd-1.0-initscript.patch
|
||||
Requires(postun): chkconfig, /usr/sbin/userdel, initscripts
|
||||
Requires(preun): chkconfig, initscripts
|
||||
Requires(post): chkconfig
|
||||
@ -32,7 +31,6 @@ services.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .initscript
|
||||
|
||||
%build
|
||||
export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIE"
|
||||
@ -94,6 +92,10 @@ fi
|
||||
%{_sbindir}/radvdump
|
||||
|
||||
%changelog
|
||||
* Mon Feb 25 2008 Martin Nagy <mnagy@redhat.com> - 1.1-1
|
||||
- update to new upstream version
|
||||
- remove patch fixed in upstream: initscript
|
||||
|
||||
* Mon Feb 11 2008 Martin Nagy <mnagy@redhat.com> - 1.0-6
|
||||
- rebuild for gcc-4.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user