update to latest upstream version 1.8.1
This commit is contained in:
parent
36a108a9bf
commit
540634de11
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
radvd-1.6.tar.gz
|
radvd-1.6.tar.gz
|
||||||
/radvd-1.7.tar.gz
|
/radvd-1.7.tar.gz
|
||||||
/radvd-1.8.tar.gz
|
/radvd-1.8.tar.gz
|
||||||
|
/radvd-1.8.1.tar.gz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
diff -up radvd-1.8/process.c.logs radvd-1.8/process.c
|
|
||||||
--- radvd-1.8/process.c.logs 2011-04-18 00:23:21.000000000 +0200
|
|
||||||
+++ radvd-1.8/process.c 2011-08-12 07:45:39.345324023 +0200
|
|
||||||
@@ -132,12 +132,12 @@ process(struct Interface *ifacel, unsign
|
|
||||||
|
|
||||||
if (icmph->icmp6_type == ND_ROUTER_SOLICIT)
|
|
||||||
{
|
|
||||||
- flog(LOG_WARNING, "received RS from %s", addr_str);
|
|
||||||
+ dlog(LOG_WARNING, 4, "received RS from %s", addr_str);
|
|
||||||
process_rs(iface, msg, len, addr);
|
|
||||||
}
|
|
||||||
else if (icmph->icmp6_type == ND_ROUTER_ADVERT)
|
|
||||||
{
|
|
||||||
- flog(LOG_WARNING, "received RA from %s", addr_str);
|
|
||||||
+ dlog(LOG_WARNING, 4, "received RA from %s", addr_str);
|
|
||||||
process_ra(iface, msg, len, addr);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
@@ -194,13 +194,12 @@ process_rs(struct Interface *iface, unsi
|
|
||||||
delay = MAX_RA_DELAY_TIME * rand() / (RAND_MAX +1.0);
|
|
||||||
|
|
||||||
if (iface->UnicastOnly) {
|
|
||||||
- dlog(LOG_DEBUG, 3, "random mdelay for %s: %g seconds.", iface->Name, delay/1000.0);
|
|
||||||
+ dlog(LOG_DEBUG, 5, "random mdelay for %s: %g seconds.", iface->Name, delay/1000.0);
|
|
||||||
mdelay(delay);
|
|
||||||
send_ra_forall(iface, &addr->sin6_addr);
|
|
||||||
}
|
|
||||||
else if ( timevaldiff(&tv, &iface->last_multicast) / 1000.0 < iface->MinDelayBetweenRAs ) {
|
|
||||||
/* last RA was sent only a few moments ago, don't send another immediately. */
|
|
||||||
- dlog(LOG_DEBUG, 3, "random mdelay for %s: %g seconds.", iface->Name, delay/1000.0);
|
|
||||||
next = iface->MinDelayBetweenRAs - (tv.tv_sec + tv.tv_usec / 1000000.0) + (iface->last_multicast.tv_sec + iface->last_multicast.tv_usec / 1000000.0) + delay/1000.0;
|
|
||||||
iface->next_multicast = next_timeval(next);
|
|
||||||
}
|
|
11
radvd.spec
11
radvd.spec
@ -3,8 +3,8 @@
|
|||||||
%define RADVD_UID 75
|
%define RADVD_UID 75
|
||||||
Summary: A Router Advertisement daemon
|
Summary: A Router Advertisement daemon
|
||||||
Name: radvd
|
Name: radvd
|
||||||
Version: 1.8
|
Version: 1.8.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
# The code includes the advertising clause, so it's GPL-incompatible
|
# The code includes the advertising clause, so it's GPL-incompatible
|
||||||
License: BSD with advertising
|
License: BSD with advertising
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -20,8 +20,6 @@ Requires(pre): /usr/sbin/useradd
|
|||||||
BuildRequires: flex, flex-static, byacc
|
BuildRequires: flex, flex-static, byacc
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Patch1: radvd-1.8-logs.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
radvd is the router advertisement daemon for IPv6. It listens to router
|
radvd is the router advertisement daemon for IPv6. It listens to router
|
||||||
solicitations and sends router advertisements as described in "Neighbor
|
solicitations and sends router advertisements as described in "Neighbor
|
||||||
@ -36,8 +34,6 @@ services.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1 -b .logs
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIE"
|
export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIE"
|
||||||
export LDFLAGS='-pie -Wl,-z,relro,-z,now,-z,noexecstack,-z,nodlopen'
|
export LDFLAGS='-pie -Wl,-z,relro,-z,now,-z,noexecstack,-z,nodlopen'
|
||||||
@ -113,6 +109,9 @@ exit 0
|
|||||||
%{_sbindir}/radvdump
|
%{_sbindir}/radvdump
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 24 2011 Jiri Skala <jskala@redhat.com> - 1.8.1-1
|
||||||
|
- update to latest upstream version 1.8.1
|
||||||
|
|
||||||
* Fri Aug 12 2011 Jiri Skala <jskala@redhat.com> - 1.8-2
|
* Fri Aug 12 2011 Jiri Skala <jskala@redhat.com> - 1.8-2
|
||||||
- fixes #729367 - supress unadvisable messages - applied upstream changes
|
- fixes #729367 - supress unadvisable messages - applied upstream changes
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user