import qt5-qtbase-5.11.1-7.el8
This commit is contained in:
commit
3359c92abc
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/qtbase-everywhere-src-5.11.1.tar.xz
|
1
.qt5-qtbase.metadata
Normal file
1
.qt5-qtbase.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
41c43cfd4713381b4e9f31db11836e9afdc0877e SOURCES/qtbase-everywhere-src-5.11.1.tar.xz
|
14
SOURCES/10-qt5-check-opengl2.sh
Executable file
14
SOURCES/10-qt5-check-opengl2.sh
Executable file
@ -0,0 +1,14 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
if [ -z "$QT_XCB_FORCE_SOFTWARE_OPENGL" ]; then
|
||||||
|
|
||||||
|
QT5_CHECK_OPENGL_VERSION=`LANG=C glxinfo 2> /dev/null | grep '^OpenGL version string: ' | head -n 1 | sed -e 's/^OpenGL version string: \([0-9]\).*$/\1/g'` ||:
|
||||||
|
|
||||||
|
if [ "$QT5_CHECK_OPENGL_VERSION" == "1" ]; then
|
||||||
|
QT_XCB_FORCE_SOFTWARE_OPENGL=1
|
||||||
|
export QT_XCB_FORCE_SOFTWARE_OPENGL
|
||||||
|
fi
|
||||||
|
|
||||||
|
unset QT5_CHECK_OPENGL_VERSION
|
||||||
|
|
||||||
|
fi
|
4
SOURCES/macros.qt5-qtbase
Normal file
4
SOURCES/macros.qt5-qtbase
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
%_qt5 @@NAME@@
|
||||||
|
%_qt5_epoch @@EPOCH@@
|
||||||
|
%_qt5_version @@VERSION@@
|
||||||
|
%_qt5_evr @@EVR@@
|
23
SOURCES/qconfig-multilib.h
Normal file
23
SOURCES/qconfig-multilib.h
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
/* qconfig.h */
|
||||||
|
/* This file is here to prevent a file conflict on multiarch systems. A
|
||||||
|
* conflict will occur because qconfig.h has arch-specific definitions.
|
||||||
|
*
|
||||||
|
* DO NOT INCLUDE THE NEW FILE DIRECTLY -- ALWAYS INCLUDE THIS ONE INSTEAD. */
|
||||||
|
|
||||||
|
#ifndef QCONFIG_MULTILIB_H
|
||||||
|
#define QCONFIG_MULTILIB_H
|
||||||
|
|
||||||
|
#ifndef __WORDSIZE
|
||||||
|
#include <bits/wordsize.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#if __WORDSIZE == 32
|
||||||
|
#include "QtCore/qconfig-32.h"
|
||||||
|
#elif __WORDSIZE == 64
|
||||||
|
#include "QtCore/qconfig-64.h"
|
||||||
|
#else
|
||||||
|
#error "unexpected value for __WORDSIZE macro"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#endif
|
||||||
|
|
32
SOURCES/qt5-qtbase-5.9.1-firebird.patch
Normal file
32
SOURCES/qt5-qtbase-5.9.1-firebird.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff --git a/src/plugins/sqldrivers/configure.json b/src/plugins/sqldrivers/configure.json
|
||||||
|
index 234f880..7b13671 100644
|
||||||
|
--- a/src/plugins/sqldrivers/configure.json
|
||||||
|
+++ b/src/plugins/sqldrivers/configure.json
|
||||||
|
@@ -50,11 +50,12 @@
|
||||||
|
"ibase": {
|
||||||
|
"label": "InterBase",
|
||||||
|
"test": {
|
||||||
|
- "include": "ibase.h"
|
||||||
|
+ "include": "firebird/ibase.h"
|
||||||
|
},
|
||||||
|
"sources": [
|
||||||
|
{ "libs": "-lgds32_ms", "condition": "config.win32" },
|
||||||
|
- { "libs": "-lgds", "condition": "!config.win32" }
|
||||||
|
+ { "libs": "-lgds", "condition": "!config.win32" },
|
||||||
|
+ { "libs": "-lfbclient", "condition": "!config.win32" }
|
||||||
|
]
|
||||||
|
},
|
||||||
|
"mysql": {
|
||||||
|
diff --git a/src/plugins/sqldrivers/ibase/qsql_ibase_p.h b/src/plugins/sqldrivers/ibase/qsql_ibase_p.h
|
||||||
|
index c7cee41..6a9c56c 100644
|
||||||
|
--- a/src/plugins/sqldrivers/ibase/qsql_ibase_p.h
|
||||||
|
+++ b/src/plugins/sqldrivers/ibase/qsql_ibase_p.h
|
||||||
|
@@ -52,7 +52,7 @@
|
||||||
|
//
|
||||||
|
|
||||||
|
#include <QtSql/qsqldriver.h>
|
||||||
|
-#include <ibase.h>
|
||||||
|
+#include <firebird/ibase.h>
|
||||||
|
|
||||||
|
#ifdef QT_PLUGIN
|
||||||
|
#define Q_EXPORT_SQLDRIVER_IBASE
|
13
SOURCES/qt5-qtbase-CVE-2018-15518.patch
Normal file
13
SOURCES/qt5-qtbase-CVE-2018-15518.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/src/corelib/serialization/qxmlstream_p.h b/src/corelib/serialization/qxmlstream_p.h
|
||||||
|
index 4157fbbd..f8b1ede9 100644
|
||||||
|
--- a/src/corelib/serialization/qxmlstream_p.h
|
||||||
|
+++ b/src/corelib/serialization/qxmlstream_p.h
|
||||||
|
@@ -1250,7 +1250,7 @@ bool QXmlStreamReaderPrivate::parse()
|
||||||
|
state_stack[tos] = 0;
|
||||||
|
return true;
|
||||||
|
} else if (act > 0) {
|
||||||
|
- if (++tos == stack_size-1)
|
||||||
|
+ if (++tos >= stack_size-1)
|
||||||
|
reallocateStack();
|
||||||
|
|
||||||
|
Value &val = sym_stack[tos];
|
25
SOURCES/qt5-qtbase-CVE-2018-19870.patch
Normal file
25
SOURCES/qt5-qtbase-CVE-2018-19870.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff --git a/src/plugins/imageformats/gif/qgifhandler.cpp b/src/plugins/imageformats/gif/qgifhandler.cpp
|
||||||
|
index e0f7f44..ebe5964 100644
|
||||||
|
--- a/src/plugins/imageformats/gif/qgifhandler.cpp
|
||||||
|
+++ b/src/plugins/imageformats/gif/qgifhandler.cpp
|
||||||
|
@@ -354,7 +354,8 @@ int QGIFFormat::decode(QImage *image, const uchar *buffer, int length,
|
||||||
|
(*image) = QImage(swidth, sheight, format);
|
||||||
|
bpl = image->bytesPerLine();
|
||||||
|
bits = image->bits();
|
||||||
|
- memset(bits, 0, image->sizeInBytes());
|
||||||
|
+ if (bits)
|
||||||
|
+ memset(bits, 0, image->sizeInBytes());
|
||||||
|
}
|
||||||
|
|
||||||
|
// Check if the previous attempt to create the image failed. If it
|
||||||
|
@@ -415,6 +416,10 @@ int QGIFFormat::decode(QImage *image, const uchar *buffer, int length,
|
||||||
|
backingstore = QImage(qMax(backingstore.width(), w),
|
||||||
|
qMax(backingstore.height(), h),
|
||||||
|
QImage::Format_RGB32);
|
||||||
|
+ if (backingstore.isNull()) {
|
||||||
|
+ state = Error;
|
||||||
|
+ return -1;
|
||||||
|
+ }
|
||||||
|
memset(backingstore.bits(), 0, backingstore.sizeInBytes());
|
||||||
|
}
|
||||||
|
const int dest_bpl = backingstore.bytesPerLine();
|
13
SOURCES/qt5-qtbase-CVE-2018-19873.patch
Normal file
13
SOURCES/qt5-qtbase-CVE-2018-19873.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/src/gui/image/qbmphandler.cpp b/src/gui/image/qbmphandler.cpp
|
||||||
|
index 587f375c..5dff4ab0 100644
|
||||||
|
--- a/src/gui/image/qbmphandler.cpp
|
||||||
|
+++ b/src/gui/image/qbmphandler.cpp
|
||||||
|
@@ -188,6 +188,8 @@ static bool read_dib_infoheader(QDataStream &s, BMP_INFOHDR &bi)
|
||||||
|
if (!(comp == BMP_RGB || (nbits == 4 && comp == BMP_RLE4) ||
|
||||||
|
(nbits == 8 && comp == BMP_RLE8) || ((nbits == 16 || nbits == 32) && comp == BMP_BITFIELDS)))
|
||||||
|
return false; // weird compression type
|
||||||
|
+ if (bi.biWidth < 0 || quint64(bi.biWidth) * qAbs(bi.biHeight) > 16384 * 16384)
|
||||||
|
+ return false;
|
||||||
|
|
||||||
|
return true;
|
||||||
|
}
|
13
SOURCES/qt5-qtbase-cxxflag.patch
Normal file
13
SOURCES/qt5-qtbase-cxxflag.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/mkspecs/common/gcc-base.conf b/mkspecs/common/gcc-base.conf
|
||||||
|
index e7e6ee1..ff2a939 100644
|
||||||
|
--- a/mkspecs/common/gcc-base.conf
|
||||||
|
+++ b/mkspecs/common/gcc-base.conf
|
||||||
|
@@ -32,7 +32,7 @@
|
||||||
|
#
|
||||||
|
|
||||||
|
QMAKE_CFLAGS_OPTIMIZE = -O2
|
||||||
|
-QMAKE_CFLAGS_OPTIMIZE_FULL = -O3
|
||||||
|
+QMAKE_CFLAGS_OPTIMIZE_FULL = -O2
|
||||||
|
QMAKE_CFLAGS_OPTIMIZE_DEBUG = -Og
|
||||||
|
QMAKE_CFLAGS_OPTIMIZE_SIZE = -Os
|
||||||
|
|
73
SOURCES/qt5-qtbase-glibc.patch
Normal file
73
SOURCES/qt5-qtbase-glibc.patch
Normal file
@ -0,0 +1,73 @@
|
|||||||
|
diff --git a/src/corelib/configure.json b/src/corelib/configure.json
|
||||||
|
index dfb575da..e87c3fd4 100644
|
||||||
|
--- a/src/corelib/configure.json
|
||||||
|
+++ b/src/corelib/configure.json
|
||||||
|
@@ -508,7 +508,7 @@
|
||||||
|
},
|
||||||
|
"getentropy": {
|
||||||
|
"label": "getentropy()",
|
||||||
|
- "condition": "config.unix && tests.getentropy",
|
||||||
|
+ "disable": "true",
|
||||||
|
"output": [ "privateFeature" ]
|
||||||
|
},
|
||||||
|
"glib": {
|
||||||
|
@@ -636,7 +636,7 @@
|
||||||
|
},
|
||||||
|
"renameat2": {
|
||||||
|
"label": "renameat2()",
|
||||||
|
- "condition": "config.linux && tests.renameat2",
|
||||||
|
+ "disable": "true",
|
||||||
|
"output": [ "privateFeature" ]
|
||||||
|
},
|
||||||
|
"slog2": {
|
||||||
|
@@ -646,7 +646,7 @@
|
||||||
|
},
|
||||||
|
"statx": {
|
||||||
|
"label": "statx() in libc",
|
||||||
|
- "condition": "config.linux && tests.statx",
|
||||||
|
+ "disable": "true",
|
||||||
|
"output": [ "privateFeature" ]
|
||||||
|
},
|
||||||
|
"syslog": {
|
||||||
|
diff --git a/src/corelib/io/qfilesystemengine_unix.cpp b/src/corelib/io/qfilesystemengine_unix.cpp
|
||||||
|
index be6ce48d..5b337c0f 100644
|
||||||
|
--- a/src/corelib/io/qfilesystemengine_unix.cpp
|
||||||
|
+++ b/src/corelib/io/qfilesystemengine_unix.cpp
|
||||||
|
@@ -50,9 +50,10 @@
|
||||||
|
#include <pwd.h>
|
||||||
|
#include <stdlib.h> // for realpath()
|
||||||
|
#include <sys/types.h>
|
||||||
|
-#include <sys/stat.h>
|
||||||
|
#include <unistd.h>
|
||||||
|
+#define renameat2 renameat2_unused
|
||||||
|
#include <stdio.h>
|
||||||
|
+#undef renameat2
|
||||||
|
#include <errno.h>
|
||||||
|
|
||||||
|
#if QT_HAS_INCLUDE(<paths.h>)
|
||||||
|
@@ -91,7 +92,9 @@ extern "C" NSString *NSTemporaryDirectory();
|
||||||
|
# include <sys/syscall.h>
|
||||||
|
# include <sys/sendfile.h>
|
||||||
|
# include <linux/fs.h>
|
||||||
|
-# include <linux/stat.h>
|
||||||
|
+#define statx statx_unused
|
||||||
|
+# include <sys/stat.h>
|
||||||
|
+#undef statx
|
||||||
|
|
||||||
|
// in case linux/fs.h is too old and doesn't define it:
|
||||||
|
#ifndef FICLONE
|
||||||
|
@@ -107,12 +110,12 @@ extern "C" NSString *NSTemporaryDirectory();
|
||||||
|
# undef STATX_BASIC_STATS
|
||||||
|
# else
|
||||||
|
# if !QT_CONFIG(renameat2) && defined(SYS_renameat2)
|
||||||
|
-static int renameat2(int oldfd, const char *oldpath, int newfd, const char *newpath, unsigned flags)
|
||||||
|
+extern int renameat2(int oldfd, const char *oldpath, int newfd, const char *newpath, unsigned flags)
|
||||||
|
{ return syscall(SYS_renameat2, oldfd, oldpath, newfd, newpath, flags); }
|
||||||
|
# endif
|
||||||
|
|
||||||
|
# if !QT_CONFIG(statx) && defined(SYS_statx)
|
||||||
|
-static int statx(int dirfd, const char *pathname, int flag, unsigned mask, struct statx *statxbuf)
|
||||||
|
+extern int statx(int dirfd, const char *pathname, int flag, unsigned mask, struct statx *statxbuf)
|
||||||
|
{ return syscall(SYS_statx, dirfd, pathname, flag, mask, statxbuf); }
|
||||||
|
# elif !QT_CONFIG(statx) && !defined(SYS_statx)
|
||||||
|
# undef STATX_BASIC_STATS
|
13
SOURCES/qtbase-allow-dbus-not-running-during-build.patch
Normal file
13
SOURCES/qtbase-allow-dbus-not-running-during-build.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/tests/auto/auto.pro b/tests/auto/auto.pro
|
||||||
|
index fbd89e40..722281c1 100644
|
||||||
|
--- a/tests/auto/auto.pro
|
||||||
|
+++ b/tests/auto/auto.pro
|
||||||
|
@@ -37,7 +37,7 @@ else:!qtConfig(process): SUBDIRS -= tools
|
||||||
|
!cross_compile:qtHaveModule(dbus) {
|
||||||
|
!system("dbus-send --session --type=signal / local.AutotestCheck.Hello >$$QMAKE_SYSTEM_NULL_DEVICE 2>&1") {
|
||||||
|
qtConfig(dbus-linked): \
|
||||||
|
- error("QtDBus is enabled but session bus is not available. Please check the installation.")
|
||||||
|
+ warning("QtDBus is enabled but session bus is not available. Please check the installation.")
|
||||||
|
else: \
|
||||||
|
warning("QtDBus is enabled with runtime support, but session bus is not available. Skipping QtDBus tests.")
|
||||||
|
SUBDIRS -= dbus
|
16
SOURCES/qtbase-always-generate-private-includes.patch
Normal file
16
SOURCES/qtbase-always-generate-private-includes.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff --git a/mkspecs/features/create_cmake.prf b/mkspecs/features/create_cmake.prf
|
||||||
|
index 2ed708e0..5d0282a7 100644
|
||||||
|
--- a/mkspecs/features/create_cmake.prf
|
||||||
|
+++ b/mkspecs/features/create_cmake.prf
|
||||||
|
@@ -28,11 +28,6 @@ CMAKE_OUT_DIR = $$MODULE_BASE_OUTDIR/lib/cmake
|
||||||
|
|
||||||
|
CMAKE_MODULE_NAME = $$cmakeModuleName($${MODULE})
|
||||||
|
|
||||||
|
-!generated_privates {
|
||||||
|
- isEmpty(SYNCQT.INJECTED_PRIVATE_HEADER_FILES):isEmpty(SYNCQT.PRIVATE_HEADER_FILES): \
|
||||||
|
- CMAKE_NO_PRIVATE_INCLUDES = true
|
||||||
|
-}
|
||||||
|
-
|
||||||
|
split_incpath {
|
||||||
|
CMAKE_ADD_SOURCE_INCLUDE_DIRS = true
|
||||||
|
CMAKE_SOURCE_INCLUDES = \
|
10
SOURCES/qtbase-ambiguous-python-shebang.patch
Normal file
10
SOURCES/qtbase-ambiguous-python-shebang.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
diff --git a/mkspecs/features/uikit/devices.py b/mkspecs/features/uikit/devices.py
|
||||||
|
index 0443e838..3c6ededb 100755
|
||||||
|
--- a/mkspecs/features/uikit/devices.py
|
||||||
|
+++ b/mkspecs/features/uikit/devices.py
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
+#!/usr/bin/python3
|
||||||
|
|
||||||
|
#############################################################################
|
||||||
|
##
|
12
SOURCES/qtbase-fdo101667.patch
Normal file
12
SOURCES/qtbase-fdo101667.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up qtbase-opensource-src-5.9.4/src/corelib/mimetypes/qmimetype.cpp.fdo101667 qtbase-opensource-src-5.9.4/src/corelib/mimetypes/qmimetype.cpp
|
||||||
|
--- qtbase-opensource-src-5.9.4/src/corelib/mimetypes/qmimetype.cpp.fdo101667 2018-01-16 00:53:43.000000000 -0600
|
||||||
|
+++ qtbase-opensource-src-5.9.4/src/corelib/mimetypes/qmimetype.cpp 2018-01-28 07:18:09.502534397 -0600
|
||||||
|
@@ -418,6 +418,8 @@ QStringList QMimeType::suffixes() const
|
||||||
|
*/
|
||||||
|
QString QMimeType::preferredSuffix() const
|
||||||
|
{
|
||||||
|
+ if (isDefault()) // workaround for unwanted *.bin suffix for octet-stream, https://bugs.freedesktop.org/show_bug.cgi?id=101667, fixed upstream in 1.10
|
||||||
|
+ return QString();
|
||||||
|
const QStringList suffixList = suffixes();
|
||||||
|
return suffixList.isEmpty() ? QString() : suffixList.at(0);
|
||||||
|
}
|
13
SOURCES/qtbase-hidpi_scale_at_192.patch
Normal file
13
SOURCES/qtbase-hidpi_scale_at_192.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/src/plugins/platforms/xcb/qxcbscreen.cpp b/src/plugins/platforms/xcb/qxcbscreen.cpp
|
||||||
|
index ec0f9ba..6d0d7a6 100644
|
||||||
|
--- a/src/plugins/platforms/xcb/qxcbscreen.cpp
|
||||||
|
+++ b/src/plugins/platforms/xcb/qxcbscreen.cpp
|
||||||
|
@@ -747,7 +747,7 @@ void QXcbScreen::updateGeometry(const QRect &geometry, uint8_t rotation)
|
||||||
|
m_sizeMillimeters = sizeInMillimeters(geometry.size(), virtualDpi());
|
||||||
|
|
||||||
|
qreal dpi = geometry.width() / physicalSize().width() * qreal(25.4);
|
||||||
|
- m_pixelDensity = qMax(1, qRound(dpi/96));
|
||||||
|
+ m_pixelDensity = qMax(1, (int) (dpi/96)); // instead of rounding at 1.5, round at 2.0 (same as GNOME)
|
||||||
|
m_geometry = geometry;
|
||||||
|
m_availableGeometry = geometry & m_virtualDesktop->workArea();
|
||||||
|
QWindowSystemInterface::handleScreenGeometryChange(QPlatformScreen::screen(), m_geometry, m_availableGeometry);
|
33
SOURCES/qtbase-multilib_optflags.patch
Normal file
33
SOURCES/qtbase-multilib_optflags.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
diff -r -u a/mkspecs/linux-g++/qmake.conf b/mkspecs/linux-g++/qmake.conf
|
||||||
|
--- a/mkspecs/linux-g++/qmake.conf 2015-10-30 06:20:01.000000000 -0200
|
||||||
|
+++ b/mkspecs/linux-g++/qmake.conf 2015-11-05 11:23:23.230741601 -0200
|
||||||
|
@@ -5,6 +5,7 @@
|
||||||
|
MAKEFILE_GENERATOR = UNIX
|
||||||
|
CONFIG += incremental
|
||||||
|
QMAKE_INCREMENTAL_STYLE = sublib
|
||||||
|
+QMAKE_CFLAGS_RELEASE += -O2
|
||||||
|
|
||||||
|
include(../common/linux.conf)
|
||||||
|
include(../common/gcc-base-unix.conf)
|
||||||
|
diff -r -u a/mkspecs/linux-g++-32/qmake.conf b/mkspecs/linux-g++-32/qmake.conf
|
||||||
|
--- a/mkspecs/linux-g++-32/qmake.conf 2015-10-30 06:20:01.000000000 -0200
|
||||||
|
+++ b/mkspecs/linux-g++-32/qmake.conf 2015-11-05 11:22:19.761494470 -0200
|
||||||
|
@@ -10,6 +10,7 @@
|
||||||
|
|
||||||
|
QMAKE_CFLAGS = -m32
|
||||||
|
QMAKE_LFLAGS = -m32
|
||||||
|
+QMAKE_CFLAGS_RELEASE += -O2
|
||||||
|
|
||||||
|
include(../common/gcc-base-unix.conf)
|
||||||
|
include(../common/g++-unix.conf)
|
||||||
|
diff -r -u a/mkspecs/linux-g++-64/qmake.conf b/mkspecs/linux-g++-64/qmake.conf
|
||||||
|
--- a/mkspecs/linux-g++-64/qmake.conf 2015-10-30 06:20:01.000000000 -0200
|
||||||
|
+++ b/mkspecs/linux-g++-64/qmake.conf 2015-11-05 11:22:49.497610248 -0200
|
||||||
|
@@ -13,6 +13,7 @@
|
||||||
|
|
||||||
|
QMAKE_CFLAGS = -m64
|
||||||
|
QMAKE_LFLAGS = -m64
|
||||||
|
+QMAKE_CFLAGS_RELEASE += -O2
|
||||||
|
|
||||||
|
include(../common/gcc-base-unix.conf)
|
||||||
|
include(../common/g++-unix.conf)
|
13
SOURCES/qtbase-opensource-src-5.3.2-QTBUG-35459.patch
Normal file
13
SOURCES/qtbase-opensource-src-5.3.2-QTBUG-35459.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff -up qtbase-opensource-src-5.3.2/src/xml/sax/qxml.cpp.QTBUG-35459 qtbase-opensource-src-5.3.2/src/xml/sax/qxml.cpp
|
||||||
|
diff -up qtbase-opensource-src-5.3.2/src/xml/sax/qxml_p.h.QTBUG-35459 qtbase-opensource-src-5.3.2/src/xml/sax/qxml_p.h
|
||||||
|
--- qtbase-opensource-src-5.3.2/src/xml/sax/qxml_p.h.QTBUG-35459 2014-09-11 05:48:05.000000000 -0500
|
||||||
|
+++ qtbase-opensource-src-5.3.2/src/xml/sax/qxml_p.h 2014-09-16 09:35:01.189255615 -0500
|
||||||
|
@@ -223,7 +223,7 @@ private:
|
||||||
|
// for the DTD currently being parsed.
|
||||||
|
static const int dtdRecursionLimit = 2;
|
||||||
|
// The maximum amount of characters an entity value may contain, after expansion.
|
||||||
|
- static const int entityCharacterLimit = 1024;
|
||||||
|
+ static const int entityCharacterLimit = 4096;
|
||||||
|
|
||||||
|
const QString &string();
|
||||||
|
void stringClear();
|
15
SOURCES/qtbase-opensource-src-5.7.1-moc_macros.patch
Normal file
15
SOURCES/qtbase-opensource-src-5.7.1-moc_macros.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff -up qtbase-opensource-src-5.7.1/src/tools/moc/main.cpp.moc_WORDSIZE qtbase-opensource-src-5.7.1/src/tools/moc/main.cpp
|
||||||
|
--- qtbase-opensource-src-5.7.1/src/tools/moc/main.cpp.moc_WORDSIZE 2016-12-01 02:17:04.000000000 -0600
|
||||||
|
+++ qtbase-opensource-src-5.7.1/src/tools/moc/main.cpp 2016-12-08 12:37:28.931589338 -0600
|
||||||
|
@@ -179,6 +179,11 @@ int runMoc(int argc, char **argv)
|
||||||
|
Moc moc;
|
||||||
|
pp.macros["Q_MOC_RUN"];
|
||||||
|
pp.macros["__cplusplus"];
|
||||||
|
+ pp.macros["_SYS_SYSMACROS_H_OUTER"];
|
||||||
|
+ Macro macro;
|
||||||
|
+ macro.symbols = Preprocessor::tokenize(QByteArray::number(Q_PROCESSOR_WORDSIZE*8), 1, Preprocessor::TokenizeDefine);
|
||||||
|
+ macro.symbols.removeLast(); // remove the EOF symbol
|
||||||
|
+ pp.macros.insert("__WORDSIZE", macro);
|
||||||
|
|
||||||
|
// Don't stumble over GCC extensions
|
||||||
|
Macro dummyVariadicFunctionMacro;
|
11
SOURCES/qtbase-opensource-src-5.8.0-QT_VERSION_CHECK.patch
Normal file
11
SOURCES/qtbase-opensource-src-5.8.0-QT_VERSION_CHECK.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- qtbase-opensource-src-5.8.0/src/corelib/global/qglobal.h.orig 2017-01-26 10:45:40.905010896 +0100
|
||||||
|
+++ qtbase-opensource-src-5.8.0/src/corelib/global/qglobal.h 2017-01-26 10:46:50.299858887 +0100
|
||||||
|
@@ -55,7 +55,7 @@
|
||||||
|
/*
|
||||||
|
can be used like #if (QT_VERSION >= QT_VERSION_CHECK(4, 4, 0))
|
||||||
|
*/
|
||||||
|
-#define QT_VERSION_CHECK(major, minor, patch) ((major<<16)|(minor<<8)|(patch))
|
||||||
|
+#define QT_VERSION_CHECK(qt_version_check_major, qt_version_check_minor, qt_version_check_patch) ((qt_version_check_major<<16)|(qt_version_check_minor<<8)|(qt_version_check_patch))
|
||||||
|
|
||||||
|
#ifdef QT_BOOTSTRAPPED
|
||||||
|
#include <QtCore/qconfig-bootstrapped.h>
|
12
SOURCES/qtbase-opensource-src-5.9.0-mysql.patch
Normal file
12
SOURCES/qtbase-opensource-src-5.9.0-mysql.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up qtbase-opensource-src-5.9.0/src/plugins/sqldrivers/mysql/qsql_mysql.cpp.than qtbase-opensource-src-5.9.0/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
|
||||||
|
diff -up qtbase-opensource-src-5.9.0/src/plugins/sqldrivers/mysql/qsql_mysql_p.h.than qtbase-opensource-src-5.9.0/src/plugins/sqldrivers/mysql/qsql_mysql_p.h
|
||||||
|
--- qtbase-opensource-src-5.9.0/src/plugins/sqldrivers/mysql/qsql_mysql_p.h.than 2017-07-14 13:43:50.831203768 +0200
|
||||||
|
+++ qtbase-opensource-src-5.9.0/src/plugins/sqldrivers/mysql/qsql_mysql_p.h 2017-07-14 13:44:24.364948006 +0200
|
||||||
|
@@ -58,6 +58,7 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#include <mysql.h>
|
||||||
|
+#include <mysql_version.h>
|
||||||
|
|
||||||
|
#ifdef QT_PLUGIN
|
||||||
|
#define Q_EXPORT_SQLDRIVER_MYSQL
|
12
SOURCES/qtbase-qmake_LFLAGS.patch
Normal file
12
SOURCES/qtbase-qmake_LFLAGS.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up qtbase-everywhere-src-5.10.1/qmake/Makefile.unix.qmake_LFLAGS qtbase-everywhere-src-5.10.1/qmake/Makefile.unix
|
||||||
|
--- qtbase-everywhere-src-5.10.1/qmake/Makefile.unix.qmake_LFLAGS 2018-02-08 12:24:48.000000000 -0600
|
||||||
|
+++ qtbase-everywhere-src-5.10.1/qmake/Makefile.unix 2018-02-15 10:25:07.077763061 -0600
|
||||||
|
@@ -142,7 +142,7 @@ CPPFLAGS = -g $(EXTRA_CPPFLAGS) \
|
||||||
|
-DQT_NO_FOREACH
|
||||||
|
|
||||||
|
CXXFLAGS = $(EXTRA_CXXFLAGS) $(CONFIG_CXXFLAGS) $(CPPFLAGS)
|
||||||
|
-LFLAGS = $(EXTRA_LFLAGS) $(CONFIG_LFLAGS)
|
||||||
|
+LFLAGS = $(EXTRA_LFLAGS) $(CONFIG_LFLAGS) $(QMAKE_LFLAGS_RELEASE)
|
||||||
|
|
||||||
|
first all: $(BUILD_PATH)/bin/qmake$(EXEEXT)
|
||||||
|
qmake: $(BUILD_PATH)/bin/qmake$(EXEEXT)
|
3
SOURCES/qtlogging.ini
Normal file
3
SOURCES/qtlogging.ini
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
[Rules]
|
||||||
|
*.debug=false
|
||||||
|
qt.qpa.xcb.xcberror.warning=false
|
16
SOURCES/tell-the-truth-about-private-api.patch
Normal file
16
SOURCES/tell-the-truth-about-private-api.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff --git a/mkspecs/features/qt_module.prf b/mkspecs/features/qt_module.prf
|
||||||
|
index e6a0d97..cf93041 100644
|
||||||
|
--- a/mkspecs/features/qt_module.prf
|
||||||
|
+++ b/mkspecs/features/qt_module.prf
|
||||||
|
@@ -216,9 +216,9 @@ android: CONFIG += qt_android_deps no_linker_version_script
|
||||||
|
QMAKE_LFLAGS += $${QMAKE_LFLAGS_VERSION_SCRIPT}$$verscript
|
||||||
|
|
||||||
|
internal_module {
|
||||||
|
- verscript_content = "Qt_$${QT_MAJOR_VERSION}_PRIVATE_API { *; };"
|
||||||
|
+ verscript_content = "Qt_$${QT_MAJOR_VERSION}.$${QT_MINOR_VERSION}.$${QT_PATCH_VERSION}_PRIVATE_API { *; };"
|
||||||
|
} else {
|
||||||
|
- verscript_content = "Qt_$${QT_MAJOR_VERSION}_PRIVATE_API {" \
|
||||||
|
+ verscript_content = "Qt_$${QT_MAJOR_VERSION}.$${QT_MINOR_VERSION}.$${QT_PATCH_VERSION}_PRIVATE_API {" \
|
||||||
|
" qt_private_api_tag*;"
|
||||||
|
|
||||||
|
private_api_headers = $$SYNCQT.PRIVATE_HEADER_FILES $$SYNCQT.QPA_HEADER_FILES
|
41
SOURCES/xcberror_filter.patch
Normal file
41
SOURCES/xcberror_filter.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
From 911762e077c8b2f9795171c1e628942a0a979801 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jan Grulich <jgrulich@redhat.com>
|
||||||
|
Date: Fri, 15 Dec 2017 11:56:12 +0100
|
||||||
|
Subject: foo
|
||||||
|
|
||||||
|
|
||||||
|
diff --git a/src/plugins/platforms/xcb/qxcbconnection.cpp b/src/plugins/platforms/xcb/qxcbconnection.cpp
|
||||||
|
index 536c709..c6eb1b1 100644
|
||||||
|
--- a/src/plugins/platforms/xcb/qxcbconnection.cpp
|
||||||
|
+++ b/src/plugins/platforms/xcb/qxcbconnection.cpp
|
||||||
|
@@ -111,6 +111,8 @@ Q_LOGGING_CATEGORY(lcQpaXInputEvents, "qt.qpa.input.events")
|
||||||
|
Q_LOGGING_CATEGORY(lcQpaScreen, "qt.qpa.screen")
|
||||||
|
Q_LOGGING_CATEGORY(lcQpaEvents, "qt.qpa.events")
|
||||||
|
Q_LOGGING_CATEGORY(lcQpaXcb, "qt.qpa.xcb") // for general (uncategorized) XCB logging
|
||||||
|
+Q_LOGGING_CATEGORY(lcQpaXcbError, "qt.qpa.xcb.xcberror")
|
||||||
|
+// TODO: How to categorize by xcberror type? (e.g. only BadWindow)
|
||||||
|
Q_LOGGING_CATEGORY(lcQpaPeeker, "qt.qpa.peeker")
|
||||||
|
|
||||||
|
// this event type was added in libxcb 1.10,
|
||||||
|
@@ -964,7 +966,8 @@ void QXcbConnection::handleXcbError(xcb_generic_error_t *error)
|
||||||
|
uint clamped_error_code = qMin<uint>(error->error_code, (sizeof(xcb_errors) / sizeof(xcb_errors[0])) - 1);
|
||||||
|
uint clamped_major_code = qMin<uint>(error->major_code, (sizeof(xcb_protocol_request_codes) / sizeof(xcb_protocol_request_codes[0])) - 1);
|
||||||
|
|
||||||
|
- qWarning("QXcbConnection: XCB error: %d (%s), sequence: %d, resource id: %d, major code: %d (%s), minor code: %d",
|
||||||
|
+ qCWarning(lcQpaXcbError,
|
||||||
|
+ "QXcbConnection: XCB error: %d (%s), sequence: %d, resource id: %d, major code: %d (%s), minor code: %d",
|
||||||
|
int(error->error_code), xcb_errors[clamped_error_code],
|
||||||
|
int(error->sequence), int(error->resource_id),
|
||||||
|
int(error->major_code), xcb_protocol_request_codes[clamped_major_code],
|
||||||
|
diff --git a/src/plugins/platforms/xcb/qxcbconnection.h b/src/plugins/platforms/xcb/qxcbconnection.h
|
||||||
|
index 999dc06..554611c 100644
|
||||||
|
--- a/src/plugins/platforms/xcb/qxcbconnection.h
|
||||||
|
+++ b/src/plugins/platforms/xcb/qxcbconnection.h
|
||||||
|
@@ -91,6 +91,7 @@ Q_DECLARE_LOGGING_CATEGORY(lcQpaXInputEvents)
|
||||||
|
Q_DECLARE_LOGGING_CATEGORY(lcQpaScreen)
|
||||||
|
Q_DECLARE_LOGGING_CATEGORY(lcQpaEvents)
|
||||||
|
Q_DECLARE_LOGGING_CATEGORY(lcQpaXcb)
|
||||||
|
+Q_DECLARE_LOGGING_CATEGORY(lcQpaXcbError)
|
||||||
|
Q_DECLARE_LOGGING_CATEGORY(lcQpaPeeker)
|
||||||
|
|
||||||
|
class QXcbVirtualDesktop;
|
1957
SPECS/qt5-qtbase.spec
Normal file
1957
SPECS/qt5-qtbase.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user