Update to 2015.2-7.2.0.

- Split out libqhull, libqhull_p, libqhull_r packages.
- drop pkgconfig.
This commit is contained in:
Ralf Corsépius 2016-04-29 13:15:36 +02:00
parent bd157d2bcc
commit 9e1831a975
11 changed files with 161 additions and 2854 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
qhull-2003.1.tar.gz
/qhull-2015-src-7.2.0.tgz

View File

@ -0,0 +1,45 @@
From eae8b33bc3a828b74422fb3bd41d52ba6f0b0048 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ralf=20Cors=C3=A9pius?= <corsepiu@fedoraproject.org>
Date: Wed, 27 Apr 2016 08:05:53 +0200
Subject: [PATCH 1/2] Link executables against shared libs.
---
CMakeLists.txt | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 59dff41..df26bd0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -477,22 +477,22 @@ set(qvoronoi_SOURCES src/qvoronoi/qvoronoi.c)
set(qhalf_SOURCES src/qhalf/qhalf.c)
add_executable(qhull ${qhull_SOURCES})
-target_link_libraries(qhull ${qhull_STATICR})
+target_link_libraries(qhull ${qhull_SHAREDR})
add_executable(rbox ${rbox_SOURCES})
-target_link_libraries(rbox ${qhull_STATIC})
+target_link_libraries(rbox ${qhull_SHARED})
add_executable(qconvex ${qconvex_SOURCES})
-target_link_libraries(qconvex ${qhull_STATIC})
+target_link_libraries(qconvex ${qhull_SHARED})
add_executable(qdelaunay ${qdelaunay_SOURCES})
-target_link_libraries(qdelaunay ${qhull_STATIC})
+target_link_libraries(qdelaunay ${qhull_SHARED})
add_executable(qvoronoi ${qvoronoi_SOURCES})
-target_link_libraries(qvoronoi ${qhull_STATIC})
+target_link_libraries(qvoronoi ${qhull_SHARED})
add_executable(qhalf ${qhalf_SOURCES})
-target_link_libraries(qhalf ${qhull_STATIC})
+target_link_libraries(qhalf ${qhull_SHARED})
# ---------------------------------------
# Define options for linking to qhull_SHAREDR or qhull_SHARED
--
2.5.5

View File

@ -0,0 +1,33 @@
From ce134bdbddf2fbb28d799792332423dd91faa470 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ralf=20Cors=C3=A9pius?= <corsepiu@fedoraproject.org>
Date: Wed, 27 Apr 2016 08:59:21 +0200
Subject: [PATCH 2/2] Install docs into subdirs.
---
CMakeLists.txt | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df26bd0..ee647c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -616,11 +616,12 @@ install(TARGETS ${qhull_TARGETS_INSTALL}
ARCHIVE DESTINATION ${LIB_INSTALL_DIR})
install(FILES ${libqhull_HEADERS} DESTINATION ${INCLUDE_INSTALL_DIR}/libqhull)
-install(FILES ${libqhull_DOC} DESTINATION ${INCLUDE_INSTALL_DIR}/libqhull)
-install(FILES ${libqhullr_HEADERS} DESTINATION ${INCLUDE_INSTALL_DIR}/libqhull_r)
-install(FILES ${libqhullr_DOC} DESTINATION ${INCLUDE_INSTALL_DIR}/libqhull_r)
+install(FILES ${libqhull_DOC} DESTINATION ${DOC_INSTALL_DIR}/src/libqhull)
+install(FILES ${libqhullr_HEADERS} DESTINATION ${INCLUDE_INSTALL_DIR}/libqhull_r)
+install(FILES ${libqhullr_DOC} DESTINATION ${DOC_INSTALL_DIR}/src/libqhull_r)
install(FILES ${libqhullcpp_HEADERS} DESTINATION ${INCLUDE_INSTALL_DIR}/libqhullcpp)
install(FILES html/qhull.man DESTINATION ${MAN_INSTALL_DIR} RENAME qhull.1)
install(FILES html/rbox.man DESTINATION ${MAN_INSTALL_DIR} RENAME rbox.1)
install(FILES ${doc_FILES} DESTINATION ${DOC_INSTALL_DIR})
-install(DIRECTORY html/ DESTINATION ${DOC_INSTALL_DIR})
+install(DIRECTORY html/ DESTINATION ${DOC_INSTALL_DIR}/html)
+install(FILES src/Changes.txt DESTINATION ${DOC_INSTALL_DIR}/src)
--
2.5.5

View File

@ -1,26 +0,0 @@
diff -Naur qhull-2003.1-17/src/io.c qhull-2003.1/src/io.c
--- qhull-2003.1-17/src/io.c 2004-02-29 23:44:43.000000000 +0100
+++ qhull-2003.1/src/io.c 2012-07-08 10:46:03.935558318 +0200
@@ -66,8 +66,8 @@
qh_memstatistics (qh ferr);
d_1= sizeof(setT) + (qh hull_dim - 1) * SETelemsize;
fprintf(qh ferr, "\
- size in bytes: merge %d ridge %d vertex %d facet %d\n\
- normal %d ridge vertices %d facet vertices or neighbors %d\n",
+ size in bytes: merge %zd ridge %zd vertex %zd facet %zd\n\
+ normal %d ridge vertices %d facet vertices or neighbors %zd\n",
sizeof(mergeT), sizeof(ridgeT),
sizeof(vertexT), sizeof(facetT),
qh normal_size, d_1, d_1 + SETelemsize);
diff -Naur qhull-2003.1-17/src/stat.c qhull-2003.1/src/stat.c
--- qhull-2003.1-17/src/stat.c 2004-01-31 12:00:15.000000000 +0100
+++ qhull-2003.1/src/stat.c 2012-07-08 10:39:41.827320428 +0200
@@ -460,7 +460,7 @@
qh_allstatI();
if (qhstat next > sizeof(qhstat id)) {
fprintf (qhmem.ferr, "qhull error (qh_initstatistics): increase size of qhstat.id[].\n\
- qhstat.next %d should be <= sizeof(qhstat id) %d\n", qhstat next, sizeof(qhstat id));
+ qhstat.next %d should be <= sizeof(qhstat id) %zd\n", qhstat next, sizeof(qhstat id));
#if 0 /* for locating error, Znumridges should be duplicated */
for (i=0; i < ZEND; i++) {
int j;

View File

@ -1,24 +0,0 @@
--- qhull-2003.1/src/qset.c.alias 2008-02-27 14:46:42.000000000 -0700
+++ qhull-2003.1/src/qset.c 2008-02-28 16:44:20.000000000 -0700
@@ -126,8 +126,7 @@
*/
void qh_setappend(setT **setp, void *newelem) {
- int *sizep;
- void **endp;
+ int *sizep, end_idx;
if (!newelem)
return;
@@ -135,8 +134,9 @@
qh_setlarger(setp);
sizep= SETsizeaddr_(*setp);
}
- *(endp= &((*setp)->e[(*sizep)++ - 1].p))= newelem;
- *(++endp)= NULL;
+ end_idx = (*sizep)++ - 1;
+ (*setp)->e[end_idx].p = newelem;
+ (*setp)->e[end_idx + 1].p = NULL;
} /* setappend */
/*-<a href="qh-set.htm#TOC"

File diff suppressed because it is too large Load Diff

View File

@ -1,12 +0,0 @@
diff -Naur qhull-2003.1.orig/src/io.c qhull-2003.1/src/io.c
--- qhull-2003.1.orig/src/io.c 2014-04-14 18:38:38.000000000 +0200
+++ qhull-2003.1/src/io.c 2014-04-14 18:42:15.924000000 +0200
@@ -2166,7 +2166,7 @@
qh_memfree (point, qh normal_size);
qh_settempfree(&points);
qh_settempfree(&vertices);
- fprintf(fp, endfmt);
+ fprintf(fp, "%s", endfmt);
} /* printfacet3math */

View File

@ -1,15 +0,0 @@
diff -Naur qhull-2003.1.orig/qhull.pc.in qhull-2003.1/qhull.pc.in
--- qhull-2003.1.orig/qhull.pc.in 1970-01-01 01:00:00.000000000 +0100
+++ qhull-2003.1/qhull.pc.in 2012-07-08 08:04:07.795336862 +0200
@@ -0,0 +1,11 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+includedir=@includedir@
+libdir=@libdir@
+
+Name: qhull
+Description: General dimension convex hull library
+Version: @VERSION@
+Requires:
+Libs: -L${libdir} -lqhull -lm
+Cflags: -I${includedir}

View File

@ -1,25 +0,0 @@
diff -up qhull-2003.1/src/poly.c.qh_gethash qhull-2003.1/src/poly.c
--- qhull-2003.1/src/poly.c.qh_gethash 2004-01-31 04:00:15.000000000 -0700
+++ qhull-2003.1/src/poly.c 2010-02-01 14:07:45.851966800 -0700
@@ -403,6 +403,7 @@ unsigned qh_gethash (int hashsize, setT
void **elemp= SETelemaddr_(set, firstindex, void);
ptr_intT hash = 0, elem;
int i;
+ unsigned result;
switch (size-firstindex) {
case 1:
@@ -441,9 +442,10 @@ unsigned qh_gethash (int hashsize, setT
}while(*elemp);
break;
}
- hash %= (ptr_intT) hashsize;
- /* hash= 0; for debugging purposes */
- return hash;
+ result= (unsigned)hash;
+ result %= (unsigned)hashsize;
+ /* result= 0; for debugging purposes */
+ return result;
} /* gethash */
/*-<a href="qh-poly.htm#TOC"

View File

@ -1,24 +1,20 @@
# Upstream's versioning is bizarre
%global tarvers 2015-src-7.2.0
Summary: General dimension convex hull programs
Name: qhull
Version: 2003.1
Release: 28%{?dist}
Version: 2015.2
Release: 1%{?dist}
License: Qhull
Group: System Environment/Libraries
Source0: http://www.qhull.org/download/qhull-%{version}.tar.gz
Patch0: qhull-2003.1-alias.patch
Patch1: http://www.qhull.org/download/qhull-2003.1-qh_gethash.patch
# Add pkgconfig support
Patch2: qhull-2003.1-pkgconfig.patch
# Misc. fixes related to 64bit compliance
Patch3: qhull-2003.1-64bit.patch
# Update config.{guess,sub} for *-aarch64 (RHBZ #926411)
Patch4: qhull-2003.1-config.patch
Patch5: qhull-2003.1-format-security.patch
Source0: http://www.qhull.org/download/qhull-%{tarvers}.tgz
Patch1: 0001-Link-executables-against-shared-libs.patch
Patch2: 0002-Install-docs-into-subdirs.patch
URL: http://www.qhull.org
Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
BuildRequires: cmake
BuildRequires: chrpath
%description
Qhull is a general dimension convex hull program that reads a set
@ -27,10 +23,29 @@ the points to stdout. It also generates Delaunay triangulations, Voronoi
diagrams, furthest-site Voronoi diagrams, and halfspace intersections
about a point.
%package -n libqhull
Summary: -n libqhull
%description -n libqhull
%{summary}
%package -n libqhull_r
Summary: libqhull_r
%description -n libqhull_r
%{summary}
%package -n libqhull_p
Summary: libqhull_p
%description -n libqhull_p
%{summary}
%package devel
Group: Development/Libraries
Summary: Development files for qhull
Requires: %{name} = %{version}-%{release}
Requires: lib%{name}%{?_isa} = %{version}-%{release}
Requires: lib%{name}_r%{?_isa} = %{version}-%{release}
Requires: lib%{name}_p%{?_isa} = %{version}-%{release}
%description devel
Qhull is a general dimension convex hull program that reads a set
@ -41,55 +56,72 @@ about a point.
%prep
%setup -q -n %{name}-%{version}
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
sed -i -e "s,\"../html/,\"html/,g" src/*.htm
%build
%configure --disable-static
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
make
sed -e 's|@prefix@|%{_prefix}|' \
-e 's|@exec_prefix@|%{_exec_prefix}|' \
-e 's|@includedir@|%{_includedir}|' \
-e 's|@libdir@|%{_libdir}|' \
-e 's|@VERSION@|%{version}|' \
qhull.pc.in > qhull.pc
mkdir -p build
cd build
%cmake ..
make VERBOSE=1 %{?_smp_mflags}
cd ..
%install
make DESTDIR=$RPM_BUILD_ROOT \
docdir=%{_pkgdocdir} install
rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
cd build
make VERBOSE=1 DESTDIR=$RPM_BUILD_ROOT install
cd ..
install -m644 -D qhull.pc ${RPM_BUILD_ROOT}%{_libdir}/pkgconfig/qhull.pc
chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/lib*.so.*
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%license COPYING.txt
%_bindir/*
%_libdir/*.so.*
%_mandir/man1/*
%files devel
%{_pkgdocdir}
%exclude %{_pkgdocdir}/COPYING.txt
%exclude %{_pkgdocdir}/src/libqhull
%exclude %{_pkgdocdir}/src/libqhull_r
%license COPYING.txt
%{_bindir}/*
%{_mandir}/man1/*
%files -n libqhull
%{_libdir}/libqhull.so.*
%post -n libqhull -p /sbin/ldconfig
%postun -n libqhull -p /sbin/ldconfig
%files -n libqhull_r
%{_libdir}/libqhull_r.so.*
%post -n libqhull_r -p /sbin/ldconfig
%postun -n libqhull_r -p /sbin/ldconfig
%files -n libqhull_p
%{_libdir}/libqhull_p.so.*
%post -n libqhull_p -p /sbin/ldconfig
%postun -n libqhull_p -p /sbin/ldconfig
%files devel
%{_pkgdocdir}/src/libqhull
%{_pkgdocdir}/src/libqhull_r
%{_libdir}/*.so
%{_libdir}/pkgconfig/qhull.pc
%{_includedir}/*
%{_libdir}/libqhullcpp.a
%exclude %{_libdir}/libqhullstatic*.a
%changelog
* Fri Apr 29 2016 Ralf Corsépius <corsepiu@fedoraproject.org> - 2015.2-1
- Update to 2015.2-7.2.0.
- Split out libqhull, libqhull_p, libqhull_r packages.
- drop pkgconfig.
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2003.1-28
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

View File

@ -1 +1 @@
48228e26422bff85ef1f45df5b6e3314 qhull-2003.1.tar.gz
e6270733a826a6a7c32b796e005ec3dc qhull-2015-src-7.2.0.tgz