303 lines
12 KiB
Diff
303 lines
12 KiB
Diff
From 69de445124e71df949a3d5289f8a10a5f771bac2 Mon Sep 17 00:00:00 2001
|
|
From: Miroslav Rezanina <mrezanin@redhat.com>
|
|
Date: Fri, 19 Oct 2018 13:48:41 +0200
|
|
Subject: Enable make check
|
|
|
|
Fixing tests after device disabling and machine types changes and enabling
|
|
make check run during build.
|
|
|
|
Signed-off-by: Miroslav Rezanina <mrezanin@redhat.com>
|
|
|
|
Rebase changes (4.0.0):
|
|
- Remove testing for pseries-2.7 in endianess test
|
|
- Disable device-plug-test on s390x as it use disabled device
|
|
- Do not run cpu-plug-tests on 7.3 and older machine types
|
|
|
|
Rebase changes (4.1.0-rc0):
|
|
- removed iotests 068
|
|
|
|
Rebase changes (4.1.0-rc1):
|
|
- remove all 205 tests (unstable)
|
|
|
|
Rebase changes (4.2.0-rc0):
|
|
- partially disable hd-geo-test (requires lsi53c895a)
|
|
|
|
Rebase changes (weekly-200129):
|
|
- Disable qtest/q35-test (uses upstream machine types)
|
|
|
|
Rebased changes (weekly-200212):
|
|
- Do not run iotests on make checka
|
|
|
|
Rebase changes (5.1.0-rc1):
|
|
- Enabled iotests 071 and 099
|
|
|
|
Merged patches (4.0.0):
|
|
- f7ffd13 Remove 7 qcow2 and luks iotests that are taking > 25 sec to run during the fast train build proce
|
|
|
|
Merged patches (4.1.0-rc0):
|
|
- 41288ff redhat: Remove raw iotest 205
|
|
|
|
Signed-off-by: Danilo C. L. de Paula <ddepaula@redhat.com>
|
|
---
|
|
redhat/qemu-kvm.spec.template | 2 +-
|
|
tests/qemu-iotests/051 | 12 ++++++------
|
|
tests/qtest/Makefile.include | 12 ++++++------
|
|
tests/qtest/boot-serial-test.c | 6 +++++-
|
|
tests/qtest/cpu-plug-test.c | 4 ++--
|
|
tests/qtest/e1000-test.c | 2 ++
|
|
tests/qtest/hd-geo-test.c | 4 ++++
|
|
tests/qtest/prom-env-test.c | 4 ++++
|
|
tests/qtest/test-x86-cpuid-compat.c | 2 ++
|
|
tests/qtest/usb-hcd-xhci-test.c | 4 ++++
|
|
10 files changed, 36 insertions(+), 16 deletions(-)
|
|
|
|
diff --git a/tests/qemu-iotests/051 b/tests/qemu-iotests/051
|
|
index bee26075b2..61d25c4ed7 100755
|
|
--- a/tests/qemu-iotests/051
|
|
+++ b/tests/qemu-iotests/051
|
|
@@ -183,11 +183,11 @@ run_qemu -drive if=virtio
|
|
case "$QEMU_DEFAULT_MACHINE" in
|
|
pc)
|
|
run_qemu -drive if=none,id=disk -device ide-cd,drive=disk
|
|
- run_qemu -drive if=none,id=disk -device lsi53c895a -device scsi-cd,drive=disk
|
|
+# run_qemu -drive if=none,id=disk -device lsi53c895a -device scsi-cd,drive=disk
|
|
run_qemu -drive if=none,id=disk -device ide-drive,drive=disk
|
|
run_qemu -drive if=none,id=disk -device ide-hd,drive=disk
|
|
- run_qemu -drive if=none,id=disk -device lsi53c895a -device scsi-disk,drive=disk
|
|
- run_qemu -drive if=none,id=disk -device lsi53c895a -device scsi-hd,drive=disk
|
|
+# run_qemu -drive if=none,id=disk -device lsi53c895a -device scsi-disk,drive=disk
|
|
+# run_qemu -drive if=none,id=disk -device lsi53c895a -device scsi-hd,drive=disk
|
|
;;
|
|
*)
|
|
;;
|
|
@@ -236,11 +236,11 @@ run_qemu -drive file="$TEST_IMG",if=virtio,readonly=on
|
|
case "$QEMU_DEFAULT_MACHINE" in
|
|
pc)
|
|
run_qemu -drive file="$TEST_IMG",if=none,id=disk,readonly=on -device ide-cd,drive=disk
|
|
- run_qemu -drive file="$TEST_IMG",if=none,id=disk,readonly=on -device lsi53c895a -device scsi-cd,drive=disk
|
|
+# run_qemu -drive file="$TEST_IMG",if=none,id=disk,readonly=on -device lsi53c895a -device scsi-cd,drive=disk
|
|
run_qemu -drive file="$TEST_IMG",if=none,id=disk,readonly=on -device ide-drive,drive=disk
|
|
run_qemu -drive file="$TEST_IMG",if=none,id=disk,readonly=on -device ide-hd,drive=disk
|
|
- run_qemu -drive file="$TEST_IMG",if=none,id=disk,readonly=on -device lsi53c895a -device scsi-disk,drive=disk
|
|
- run_qemu -drive file="$TEST_IMG",if=none,id=disk,readonly=on -device lsi53c895a -device scsi-hd,drive=disk
|
|
+# run_qemu -drive file="$TEST_IMG",if=none,id=disk,readonly=on -device lsi53c895a -device scsi-disk,drive=disk
|
|
+# run_qemu -drive file="$TEST_IMG",if=none,id=disk,readonly=on -device lsi53c895a -device scsi-hd,drive=disk
|
|
;;
|
|
*)
|
|
;;
|
|
diff --git a/tests/qtest/Makefile.include b/tests/qtest/Makefile.include
|
|
index b0204e44f2..cf8a138791 100644
|
|
--- a/tests/qtest/Makefile.include
|
|
+++ b/tests/qtest/Makefile.include
|
|
@@ -29,7 +29,7 @@ check-qtest-i386-y += ide-test
|
|
check-qtest-i386-$(CONFIG_TOOLS) += ahci-test
|
|
check-qtest-i386-y += hd-geo-test
|
|
check-qtest-i386-y += boot-order-test
|
|
-check-qtest-i386-y += bios-tables-test
|
|
+#check-qtest-i386-y += bios-tables-test
|
|
check-qtest-i386-$(CONFIG_SGA) += boot-serial-test
|
|
check-qtest-i386-$(CONFIG_SLIRP) += pxe-test
|
|
check-qtest-i386-y += rtc-test
|
|
@@ -51,7 +51,7 @@ check-qtest-i386-$(CONFIG_USB_UHCI) += usb-hcd-uhci-test
|
|
check-qtest-i386-$(call land,$(CONFIG_USB_EHCI),$(CONFIG_USB_UHCI)) += usb-hcd-ehci-test
|
|
check-qtest-i386-$(CONFIG_USB_XHCI_NEC) += usb-hcd-xhci-test
|
|
check-qtest-i386-y += cpu-plug-test
|
|
-check-qtest-i386-y += q35-test
|
|
+#check-qtest-i386-y += q35-test
|
|
check-qtest-i386-y += vmgenid-test
|
|
check-qtest-i386-$(CONFIG_TPM_CRB) += tpm-crb-swtpm-test
|
|
check-qtest-i386-$(CONFIG_TPM_CRB) += tpm-crb-test
|
|
@@ -90,7 +90,7 @@ check-qtest-mips64el-$(CONFIG_VGA) += display-vga-test
|
|
check-qtest-moxie-y += boot-serial-test
|
|
|
|
check-qtest-ppc-$(CONFIG_ISA_TESTDEV) = endianness-test
|
|
-check-qtest-ppc-y += boot-order-test
|
|
+#check-qtest-ppc-y += boot-order-test
|
|
check-qtest-ppc-y += prom-env-test
|
|
check-qtest-ppc-y += drive_del-test
|
|
check-qtest-ppc-y += boot-serial-test
|
|
@@ -104,8 +104,8 @@ check-qtest-ppc64-$(CONFIG_PSERIES) += rtas-test
|
|
check-qtest-ppc64-$(CONFIG_SLIRP) += pxe-test
|
|
check-qtest-ppc64-$(CONFIG_USB_UHCI) += usb-hcd-uhci-test
|
|
check-qtest-ppc64-$(CONFIG_USB_XHCI_NEC) += usb-hcd-xhci-test
|
|
-check-qtest-ppc64-$(CONFIG_SLIRP) += test-netfilter
|
|
-check-qtest-ppc64-$(CONFIG_POSIX) += test-filter-mirror
|
|
+#check-qtest-ppc64-$(CONFIG_SLIRP) += test-netfilter
|
|
+#check-qtest-ppc64-$(CONFIG_POSIX) += test-filter-mirror
|
|
check-qtest-ppc64-$(CONFIG_RTL8139_PCI) += test-filter-redirector
|
|
check-qtest-ppc64-$(CONFIG_VGA) += display-vga-test
|
|
check-qtest-ppc64-y += numa-test
|
|
@@ -154,7 +154,7 @@ check-qtest-s390x-$(CONFIG_SLIRP) += test-netfilter
|
|
check-qtest-s390x-$(CONFIG_POSIX) += test-filter-mirror
|
|
check-qtest-s390x-$(CONFIG_POSIX) += test-filter-redirector
|
|
check-qtest-s390x-y += drive_del-test
|
|
-check-qtest-s390x-y += device-plug-test
|
|
+#check-qtest-s390x-y += device-plug-test
|
|
check-qtest-s390x-y += virtio-ccw-test
|
|
check-qtest-s390x-y += cpu-plug-test
|
|
check-qtest-s390x-y += migration-test
|
|
diff --git a/tests/qtest/boot-serial-test.c b/tests/qtest/boot-serial-test.c
|
|
index bfe7624dc6..1ffaa0bd7e 100644
|
|
--- a/tests/qtest/boot-serial-test.c
|
|
+++ b/tests/qtest/boot-serial-test.c
|
|
@@ -120,19 +120,23 @@ static testdef_t tests[] = {
|
|
{ "ppc", "g3beige", "", "PowerPC,750" },
|
|
{ "ppc", "mac99", "", "PowerPC,G4" },
|
|
{ "ppc", "sam460ex", "-m 256", "DRAM: 256 MiB" },
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
{ "ppc64", "ppce500", "", "U-Boot" },
|
|
{ "ppc64", "40p", "-m 192", "Memory: 192M" },
|
|
{ "ppc64", "mac99", "", "PowerPC,970FX" },
|
|
+#endif
|
|
{ "ppc64", "pseries",
|
|
"-machine " PSERIES_DEFAULT_CAPABILITIES,
|
|
"Open Firmware" },
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
{ "ppc64", "powernv8", "", "OPAL" },
|
|
{ "ppc64", "powernv9", "", "OPAL" },
|
|
{ "ppc64", "sam460ex", "-device e1000", "8086 100e" },
|
|
+#endif
|
|
{ "i386", "isapc", "-cpu qemu32 -device sga", "SGABIOS" },
|
|
{ "i386", "pc", "-device sga", "SGABIOS" },
|
|
{ "i386", "q35", "-device sga", "SGABIOS" },
|
|
- { "x86_64", "isapc", "-cpu qemu32 -device sga", "SGABIOS" },
|
|
+ { "x86_64", "pc", "-cpu qemu32 -device sga", "SGABIOS" },
|
|
{ "x86_64", "q35", "-device sga", "SGABIOS" },
|
|
{ "sparc", "LX", "", "TMS390S10" },
|
|
{ "sparc", "SS-4", "", "MB86904" },
|
|
diff --git a/tests/qtest/cpu-plug-test.c b/tests/qtest/cpu-plug-test.c
|
|
index e8ffbbce4b..fda7269c82 100644
|
|
--- a/tests/qtest/cpu-plug-test.c
|
|
+++ b/tests/qtest/cpu-plug-test.c
|
|
@@ -181,8 +181,8 @@ static void add_pseries_test_case(const char *mname)
|
|
char *path;
|
|
PlugTestData *data;
|
|
|
|
- if (!g_str_has_prefix(mname, "pseries-") ||
|
|
- (g_str_has_prefix(mname, "pseries-2.") && atoi(&mname[10]) < 7)) {
|
|
+ if (!g_str_has_prefix(mname, "pseries-rhel") ||
|
|
+ (g_str_has_prefix(mname, "pseries-rhel7.") && atoi(&mname[14]) < 4)) {
|
|
return;
|
|
}
|
|
data = g_new(PlugTestData, 1);
|
|
diff --git a/tests/qtest/e1000-test.c b/tests/qtest/e1000-test.c
|
|
index c387984ef6..c89112d6f8 100644
|
|
--- a/tests/qtest/e1000-test.c
|
|
+++ b/tests/qtest/e1000-test.c
|
|
@@ -22,9 +22,11 @@ struct QE1000 {
|
|
|
|
static const char *models[] = {
|
|
"e1000",
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
"e1000-82540em",
|
|
"e1000-82544gc",
|
|
"e1000-82545em",
|
|
+#endif
|
|
};
|
|
|
|
static void *e1000_get_driver(void *obj, const char *interface)
|
|
diff --git a/tests/qtest/hd-geo-test.c b/tests/qtest/hd-geo-test.c
|
|
index 48e8e02d6e..6496196b07 100644
|
|
--- a/tests/qtest/hd-geo-test.c
|
|
+++ b/tests/qtest/hd-geo-test.c
|
|
@@ -737,6 +737,7 @@ static void test_override_ide(void)
|
|
test_override(args, expected);
|
|
}
|
|
|
|
+#if 0 /* Require lsi53c895a - not supported on RHEL */
|
|
static void test_override_scsi(void)
|
|
{
|
|
TestArgs *args = create_args();
|
|
@@ -781,6 +782,7 @@ static void test_override_scsi_2_controllers(void)
|
|
add_scsi_disk(args, 3, 1, 0, 1, 2, 0, 1, 0);
|
|
test_override(args, expected);
|
|
}
|
|
+#endif
|
|
|
|
static void test_override_virtio_blk(void)
|
|
{
|
|
@@ -960,9 +962,11 @@ int main(int argc, char **argv)
|
|
qtest_add_func("hd-geo/ide/device/user/chst", test_ide_device_user_chst);
|
|
if (have_qemu_img()) {
|
|
qtest_add_func("hd-geo/override/ide", test_override_ide);
|
|
+#if 0 /* Require lsi53c895a - not supported on RHEL */
|
|
qtest_add_func("hd-geo/override/scsi", test_override_scsi);
|
|
qtest_add_func("hd-geo/override/scsi_2_controllers",
|
|
test_override_scsi_2_controllers);
|
|
+#endif
|
|
qtest_add_func("hd-geo/override/virtio_blk", test_override_virtio_blk);
|
|
qtest_add_func("hd-geo/override/zero_chs", test_override_zero_chs);
|
|
qtest_add_func("hd-geo/override/scsi_hot_unplug",
|
|
diff --git a/tests/qtest/prom-env-test.c b/tests/qtest/prom-env-test.c
|
|
index 60e6ec3153..f9d6adcfe9 100644
|
|
--- a/tests/qtest/prom-env-test.c
|
|
+++ b/tests/qtest/prom-env-test.c
|
|
@@ -89,10 +89,14 @@ int main(int argc, char *argv[])
|
|
if (!strcmp(arch, "ppc")) {
|
|
add_tests(ppc_machines);
|
|
} else if (!strcmp(arch, "ppc64")) {
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
add_tests(ppc_machines);
|
|
if (g_test_slow()) {
|
|
+#endif
|
|
qtest_add_data_func("prom-env/pseries", "pseries", test_machine);
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
}
|
|
+#endif
|
|
} else if (!strcmp(arch, "sparc")) {
|
|
add_tests(sparc_machines);
|
|
} else if (!strcmp(arch, "sparc64")) {
|
|
diff --git a/tests/qtest/test-x86-cpuid-compat.c b/tests/qtest/test-x86-cpuid-compat.c
|
|
index 7ca1883a29..983aa0719a 100644
|
|
--- a/tests/qtest/test-x86-cpuid-compat.c
|
|
+++ b/tests/qtest/test-x86-cpuid-compat.c
|
|
@@ -300,6 +300,7 @@ int main(int argc, char **argv)
|
|
"-cpu 486,xlevel2=0xC0000002,+xstore",
|
|
"xlevel2", 0xC0000002);
|
|
|
|
+#if 0 /* Disabled in Red Hat Enterprise Linux */
|
|
/* Check compatibility of old machine-types that didn't
|
|
* auto-increase level/xlevel/xlevel2: */
|
|
|
|
@@ -350,6 +351,7 @@ int main(int argc, char **argv)
|
|
add_cpuid_test("x86/cpuid/xlevel-compat/pc-i440fx-2.4/npt-on",
|
|
"-machine pc-i440fx-2.4 -cpu SandyBridge,+svm,+npt",
|
|
"xlevel", 0x80000008);
|
|
+#endif
|
|
|
|
/* Test feature parsing */
|
|
add_feature_test("x86/cpuid/features/plus",
|
|
diff --git a/tests/qtest/usb-hcd-xhci-test.c b/tests/qtest/usb-hcd-xhci-test.c
|
|
index 10ef9d2a91..3855873050 100644
|
|
--- a/tests/qtest/usb-hcd-xhci-test.c
|
|
+++ b/tests/qtest/usb-hcd-xhci-test.c
|
|
@@ -21,6 +21,7 @@ static void test_xhci_hotplug(void)
|
|
usb_test_hotplug(global_qtest, "xhci", "1", NULL);
|
|
}
|
|
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
static void test_usb_uas_hotplug(void)
|
|
{
|
|
QTestState *qts = global_qtest;
|
|
@@ -36,6 +37,7 @@ static void test_usb_uas_hotplug(void)
|
|
qtest_qmp_device_del(qts, "scsihd");
|
|
qtest_qmp_device_del(qts, "uas");
|
|
}
|
|
+#endif
|
|
|
|
static void test_usb_ccid_hotplug(void)
|
|
{
|
|
@@ -56,7 +58,9 @@ int main(int argc, char **argv)
|
|
|
|
qtest_add_func("/xhci/pci/init", test_xhci_init);
|
|
qtest_add_func("/xhci/pci/hotplug", test_xhci_hotplug);
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
qtest_add_func("/xhci/pci/hotplug/usb-uas", test_usb_uas_hotplug);
|
|
+#endif
|
|
qtest_add_func("/xhci/pci/hotplug/usb-ccid", test_usb_ccid_hotplug);
|
|
|
|
qtest_start("-device nec-usb-xhci,id=xhci"
|
|
--
|
|
2.27.0
|
|
|