88 lines
2.8 KiB
Diff
88 lines
2.8 KiB
Diff
From a9095850da8dd4ea3fdb725cb7f79118144e22fa Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Eugenio=20P=C3=A9rez?= <eperezma@redhat.com>
|
|
Date: Thu, 21 Jul 2022 15:39:27 +0200
|
|
Subject: [PATCH 22/32] vhost-net-vdpa: add stubs for when no virtio-net device
|
|
is present
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
RH-Author: Eugenio Pérez <eperezma@redhat.com>
|
|
RH-MergeRequest: 108: Net Control Virtqueue shadow Support
|
|
RH-Commit: [22/27] a2b25a805bb06094a5fab27ce8f82bee12a9fcb5 (eperezmartin/qemu-kvm)
|
|
RH-Bugzilla: 1939363
|
|
RH-Acked-by: Stefano Garzarella <sgarzare@redhat.com>
|
|
RH-Acked-by: Cindy Lu <lulu@redhat.com>
|
|
RH-Acked-by: Laurent Vivier <lvivier@redhat.com>
|
|
|
|
Bugzilla: https://bugzilla.redhat.com/1939363
|
|
|
|
Upstream Status: git://git.qemu.org/qemu.git
|
|
|
|
commit 94c643732dc110d04bbdf0eb43c41bce23b3593e
|
|
Author: Eugenio Pérez <eperezma@redhat.com>
|
|
Date: Wed Jul 20 08:59:41 2022 +0200
|
|
|
|
vhost-net-vdpa: add stubs for when no virtio-net device is present
|
|
|
|
net/vhost-vdpa.c will need functions that are declared in
|
|
vhost-shadow-virtqueue.c, that needs functions of virtio-net.c.
|
|
|
|
Copy the vhost-vdpa-stub.c code so
|
|
only the constructor net_init_vhost_vdpa needs to be defined.
|
|
|
|
Signed-off-by: Eugenio Pérez <eperezma@redhat.com>
|
|
Signed-off-by: Jason Wang <jasowang@redhat.com>
|
|
|
|
Signed-off-by: Eugenio Pérez <eperezma@redhat.com>
|
|
---
|
|
net/meson.build | 3 ++-
|
|
net/vhost-vdpa-stub.c | 21 +++++++++++++++++++++
|
|
2 files changed, 23 insertions(+), 1 deletion(-)
|
|
create mode 100644 net/vhost-vdpa-stub.c
|
|
|
|
diff --git a/net/meson.build b/net/meson.build
|
|
index c965e83b26..116a9e7cbb 100644
|
|
--- a/net/meson.build
|
|
+++ b/net/meson.build
|
|
@@ -41,7 +41,8 @@ endif
|
|
softmmu_ss.add(when: 'CONFIG_POSIX', if_true: files(tap_posix))
|
|
softmmu_ss.add(when: 'CONFIG_WIN32', if_true: files('tap-win32.c'))
|
|
if have_vhost_net_vdpa
|
|
- softmmu_ss.add(files('vhost-vdpa.c'))
|
|
+ softmmu_ss.add(when: 'CONFIG_VIRTIO_NET', if_true: files('vhost-vdpa.c'), if_false: files('vhost-vdpa-stub.c'))
|
|
+ softmmu_ss.add(when: 'CONFIG_ALL', if_true: files('vhost-vdpa-stub.c'))
|
|
endif
|
|
|
|
subdir('can')
|
|
diff --git a/net/vhost-vdpa-stub.c b/net/vhost-vdpa-stub.c
|
|
new file mode 100644
|
|
index 0000000000..1732ed2443
|
|
--- /dev/null
|
|
+++ b/net/vhost-vdpa-stub.c
|
|
@@ -0,0 +1,21 @@
|
|
+/*
|
|
+ * vhost-vdpa-stub.c
|
|
+ *
|
|
+ * Copyright (c) 2022 Red Hat, Inc.
|
|
+ *
|
|
+ * This work is licensed under the terms of the GNU GPL, version 2 or later.
|
|
+ * See the COPYING file in the top-level directory.
|
|
+ *
|
|
+ */
|
|
+
|
|
+#include "qemu/osdep.h"
|
|
+#include "clients.h"
|
|
+#include "net/vhost-vdpa.h"
|
|
+#include "qapi/error.h"
|
|
+
|
|
+int net_init_vhost_vdpa(const Netdev *netdev, const char *name,
|
|
+ NetClientState *peer, Error **errp)
|
|
+{
|
|
+ error_setg(errp, "vhost-vdpa requires frontend driver virtio-net-*");
|
|
+ return -1;
|
|
+}
|
|
--
|
|
2.31.1
|
|
|