1261d6ce5b
- Rebase to qemu-4.2 - Resolves: bz#1783250 (rebase qemu-kvm to 4.2)
168 lines
6.2 KiB
Diff
168 lines
6.2 KiB
Diff
From 4df157781801c50224373be57fa3c8c3741c0535 Mon Sep 17 00:00:00 2001
|
|
From: Miroslav Rezanina <mrezanin@redhat.com>
|
|
Date: Fri, 12 Oct 2018 07:31:11 +0200
|
|
Subject: Initial redhat build
|
|
|
|
This patch introduces redhat build structure in redhat subdirectory. In addition,
|
|
several issues are fixed in QEMU tree:
|
|
|
|
- Change of app name for sasl_server_init in VNC code from qemu to qemu-kvm
|
|
- As we use qemu-kvm as name in all places, this is updated to be consistent
|
|
- Man page renamed from qemu to qemu-kvm
|
|
- man page is installed using make install so we have to fix it in qemu tree
|
|
- Use "/share/qemu-kvm" as SHARE_SUFFIX
|
|
- We reconfigured our share to qemu-kvm to be consistent with used name
|
|
|
|
This rebase includes changes up to qemu-kvm-4.1.0-18.el8
|
|
|
|
Rebase notes (3.1.0):
|
|
- added new configure options
|
|
|
|
Rebase notes (4.0.0):
|
|
- Added dependency to perl-Test-Harness (upstream)
|
|
- Added dependency to python3-sphinx (upstream)
|
|
- Change location of icons (upstream)
|
|
- Remove .desktop file (added upstream)
|
|
- Added qemu-trace-stap (added upstream)
|
|
- Removed elf2dmp (added upstream)
|
|
- Remove .buildinfo
|
|
- Added pvh.bin rom (added upstream)
|
|
- Added interop documentation files
|
|
- Use python module instead of qemu.py (upstream)
|
|
|
|
Rebase notes (4.1.0):
|
|
- Remove edk2 files generated by build
|
|
- Switch to rhel-8.1-candidate build target
|
|
- Remove specs documentation
|
|
- Switched from libssh2 to libssh
|
|
- Add rc0 tarball usage hacks
|
|
- Added BuildRequires for wget, rpm-build and python3-sphinx
|
|
- Removed new unpacked files
|
|
- Update configure line to use new options
|
|
|
|
Rebase notes (4.2.0):
|
|
- Disable iotest run during make check
|
|
- README renamed to README.rst (upstream)
|
|
- Removed ui-spice-app.so
|
|
- Added relevant changes from "505f7f4 redhat: Adding slirp to the exploded tree"
|
|
- Removed qemu-ga.8 install from spec file - installed by make
|
|
- Removed spapr-rtas.bin (upstream)
|
|
- Require newer SLOF (20191022)
|
|
|
|
Merged patches (3.1.0):
|
|
- 01f0c9f RHEL8: Add disable configure options to qemu spec file
|
|
- Spec file cleanups
|
|
|
|
Merged patches (4.0.0):
|
|
- aa4297c Add edk2 Requires to qemu-kvm
|
|
- d124ff5779 Fixing brew build target
|
|
- eb204b5 Introduce the qemu-kvm-tests rpm
|
|
- 223cf0c Load kvm module during boot (partial)
|
|
|
|
Merged patches (4.1.0):
|
|
- ebb6e97 redhat: Fix LOCALVERSION creation
|
|
- b0ab0cc redhat: enable tpmdev passthrough (not disabling tests)
|
|
- 7cb3c4a Enable libpmem to support nvdimm
|
|
- 8943607 qemu-kvm.spec: bump libseccomp >= 2.4.0
|
|
- 27b7c44 rh: set CONFIG_BOCHS_DISPLAY=y for x86 (partial)
|
|
- e1fe9fe x86_64-rh-devices: enable TPM emulation (partial)
|
|
|
|
Merged patches (4.2.0):
|
|
- 69e1fb2 enable virgla
|
|
- d4f6115 enable virgl, for real this time ...
|
|
|
|
Signed-off-by: Danilo C. L. de Paula <ddepaula@redhat.com>
|
|
---
|
|
.gitignore | 1 +
|
|
Makefile | 3 +-
|
|
configure | 1 +
|
|
os-posix.c | 2 +-
|
|
redhat/Makefile | 82 +
|
|
redhat/Makefile.common | 51 +
|
|
redhat/README.tests | 39 +
|
|
redhat/qemu-kvm.spec.template | 2434 +++++++++++++++++++++++++++++
|
|
redhat/scripts/process-patches.sh | 7 +-
|
|
tests/Makefile.include | 2 +-
|
|
ui/vnc.c | 2 +-
|
|
11 files changed, 2615 insertions(+), 9 deletions(-)
|
|
create mode 100644 redhat/Makefile
|
|
create mode 100644 redhat/Makefile.common
|
|
create mode 100644 redhat/README.tests
|
|
create mode 100644 redhat/qemu-kvm.spec.template
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index b437a346d7..086727dbb9 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -512,6 +512,7 @@ CAP_CFLAGS += -DCAPSTONE_HAS_ARM
|
|
CAP_CFLAGS += -DCAPSTONE_HAS_ARM64
|
|
CAP_CFLAGS += -DCAPSTONE_HAS_POWERPC
|
|
CAP_CFLAGS += -DCAPSTONE_HAS_X86
|
|
+CAP_CFLAGS += -Wp,-D_GLIBCXX_ASSERTIONS
|
|
|
|
.PHONY: capstone/all
|
|
capstone/all: .git-submodule-status
|
|
@@ -826,7 +827,7 @@ install-doc: $(DOCS) install-sphinxdocs
|
|
$(INSTALL_DATA) docs/interop/qemu-qmp-ref.txt "$(DESTDIR)$(qemu_docdir)"
|
|
ifdef CONFIG_POSIX
|
|
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
|
|
- $(INSTALL_DATA) qemu.1 "$(DESTDIR)$(mandir)/man1"
|
|
+ $(INSTALL_DATA) qemu.1 "$(DESTDIR)$(mandir)/man1/qemu-kvm.1"
|
|
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man7"
|
|
$(INSTALL_DATA) docs/interop/qemu-qmp-ref.7 "$(DESTDIR)$(mandir)/man7"
|
|
$(INSTALL_DATA) docs/qemu-block-drivers.7 "$(DESTDIR)$(mandir)/man7"
|
|
diff --git a/configure b/configure
|
|
index 6099be1d84..16564f8ccc 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -2424,6 +2424,7 @@ if test "$seccomp" != "no" ; then
|
|
seccomp="no"
|
|
fi
|
|
fi
|
|
+
|
|
##########################################
|
|
# xen probe
|
|
|
|
diff --git a/os-posix.c b/os-posix.c
|
|
index 86cffd2c7d..1c9f86768d 100644
|
|
--- a/os-posix.c
|
|
+++ b/os-posix.c
|
|
@@ -83,7 +83,7 @@ void os_setup_signal_handling(void)
|
|
/* Find a likely location for support files using the location of the binary.
|
|
For installed binaries this will be "$bindir/../share/qemu". When
|
|
running from the build tree this will be "$bindir/../pc-bios". */
|
|
-#define SHARE_SUFFIX "/share/qemu"
|
|
+#define SHARE_SUFFIX "/share/qemu-kvm"
|
|
#define BUILD_SUFFIX "/pc-bios"
|
|
char *os_find_datadir(void)
|
|
{
|
|
diff --git a/tests/Makefile.include b/tests/Makefile.include
|
|
index 8566f5f119..b483790cf3 100644
|
|
--- a/tests/Makefile.include
|
|
+++ b/tests/Makefile.include
|
|
@@ -1194,7 +1194,7 @@ check-acceptance: check-venv $(TESTS_RESULTS_DIR)
|
|
check-qapi-schema: check-tests/qapi-schema/frontend check-tests/qapi-schema/doc-good.texi
|
|
check-qtest: $(patsubst %,check-qtest-%, $(QTEST_TARGETS))
|
|
check-block: $(patsubst %,check-%, $(check-block-y))
|
|
-check: check-block check-qapi-schema check-unit check-softfloat check-qtest check-decodetree
|
|
+check: check-qapi-schema check-unit check-softfloat check-qtest check-decodetree
|
|
check-clean:
|
|
rm -rf $(check-unit-y) tests/*.o $(QEMU_IOTESTS_HELPERS-y)
|
|
rm -rf $(sort $(foreach target,$(SYSEMU_TARGET_LIST), $(check-qtest-$(target)-y)) $(check-qtest-generic-y))
|
|
diff --git a/ui/vnc.c b/ui/vnc.c
|
|
index 87b8045afe..ecf6276f5b 100644
|
|
--- a/ui/vnc.c
|
|
+++ b/ui/vnc.c
|
|
@@ -3987,7 +3987,7 @@ void vnc_display_open(const char *id, Error **errp)
|
|
|
|
#ifdef CONFIG_VNC_SASL
|
|
if (sasl) {
|
|
- int saslErr = sasl_server_init(NULL, "qemu");
|
|
+ int saslErr = sasl_server_init(NULL, "qemu-kvm");
|
|
|
|
if (saslErr != SASL_OK) {
|
|
error_setg(errp, "Failed to initialize SASL auth: %s",
|
|
--
|
|
2.21.0
|
|
|