114 lines
3.8 KiB
Diff
114 lines
3.8 KiB
Diff
From 7634eed5aea61dc94f9a828c62ef3da9aeaa62ae Mon Sep 17 00:00:00 2001
|
|
From: Janosch Frank <frankja@linux.ibm.com>
|
|
Date: Mon, 17 Oct 2022 08:38:18 +0000
|
|
Subject: [PATCH 37/42] s390x: Add protected dump cap
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
RH-Author: Cédric Le Goater <clg@redhat.com>
|
|
RH-MergeRequest: 226: s390: Enhanced Interpretation for PCI Functions and Secure Execution guest dump
|
|
RH-Bugzilla: 1664378 2043909
|
|
RH-Acked-by: Thomas Huth <thuth@redhat.com>
|
|
RH-Acked-by: Cornelia Huck <cohuck@redhat.com>
|
|
RH-Acked-by: Jon Maloy <jmaloy@redhat.com>
|
|
RH-Commit: [37/41] 52e1e7bf1a00ce3a220d3db2f733a65548bfec6d
|
|
|
|
Add a protected dump capability for later feature checking.
|
|
|
|
Signed-off-by: Janosch Frank <frankja@linux.ibm.com>
|
|
Reviewed-by: Steffen Eiden <seiden@linux.ibm.com>
|
|
Reviewed-by: Thomas Huth <thuth@redhat.com>
|
|
Reviewed-by: Janis Schoetterl-Glausch <scgl@linux.ibm.com>
|
|
Message-Id: <20221017083822.43118-7-frankja@linux.ibm.com>
|
|
[ Marc-André - Add missing stubs when !kvm ]
|
|
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
|
(cherry picked from commit ad3b2e693daac6ed92db7361236028851d37c77c)
|
|
Signed-off-by: Cédric Le Goater <clg@redhat.com>
|
|
---
|
|
target/s390x/kvm/kvm.c | 7 +++++++
|
|
target/s390x/kvm/kvm_s390x.h | 1 +
|
|
target/s390x/kvm/meson.build | 2 ++
|
|
target/s390x/kvm/stubs.c | 12 ++++++++++++
|
|
4 files changed, 22 insertions(+)
|
|
create mode 100644 target/s390x/kvm/stubs.c
|
|
|
|
diff --git a/target/s390x/kvm/kvm.c b/target/s390x/kvm/kvm.c
|
|
index 30712487d4..d36b44f32a 100644
|
|
--- a/target/s390x/kvm/kvm.c
|
|
+++ b/target/s390x/kvm/kvm.c
|
|
@@ -159,6 +159,7 @@ static int cap_hpage_1m;
|
|
static int cap_vcpu_resets;
|
|
static int cap_protected;
|
|
static int cap_zpci_op;
|
|
+static int cap_protected_dump;
|
|
|
|
static bool mem_op_storage_key_support;
|
|
|
|
@@ -365,6 +366,7 @@ int kvm_arch_init(MachineState *ms, KVMState *s)
|
|
cap_vcpu_resets = kvm_check_extension(s, KVM_CAP_S390_VCPU_RESETS);
|
|
cap_protected = kvm_check_extension(s, KVM_CAP_S390_PROTECTED);
|
|
cap_zpci_op = kvm_check_extension(s, KVM_CAP_S390_ZPCI_OP);
|
|
+ cap_protected_dump = kvm_check_extension(s, KVM_CAP_S390_PROTECTED_DUMP);
|
|
|
|
kvm_vm_enable_cap(s, KVM_CAP_S390_USER_SIGP, 0);
|
|
kvm_vm_enable_cap(s, KVM_CAP_S390_VECTOR_REGISTERS, 0);
|
|
@@ -2042,6 +2044,11 @@ int kvm_s390_assign_subch_ioeventfd(EventNotifier *notifier, uint32_t sch,
|
|
return kvm_vm_ioctl(kvm_state, KVM_IOEVENTFD, &kick);
|
|
}
|
|
|
|
+int kvm_s390_get_protected_dump(void)
|
|
+{
|
|
+ return cap_protected_dump;
|
|
+}
|
|
+
|
|
int kvm_s390_get_ri(void)
|
|
{
|
|
return cap_ri;
|
|
diff --git a/target/s390x/kvm/kvm_s390x.h b/target/s390x/kvm/kvm_s390x.h
|
|
index aaae8570de..f9785564d0 100644
|
|
--- a/target/s390x/kvm/kvm_s390x.h
|
|
+++ b/target/s390x/kvm/kvm_s390x.h
|
|
@@ -26,6 +26,7 @@ int kvm_s390_set_cpu_state(S390CPU *cpu, uint8_t cpu_state);
|
|
void kvm_s390_vcpu_interrupt_pre_save(S390CPU *cpu);
|
|
int kvm_s390_vcpu_interrupt_post_load(S390CPU *cpu);
|
|
int kvm_s390_get_hpage_1m(void);
|
|
+int kvm_s390_get_protected_dump(void);
|
|
int kvm_s390_get_ri(void);
|
|
int kvm_s390_get_zpci_op(void);
|
|
int kvm_s390_get_clock(uint8_t *tod_high, uint64_t *tod_clock);
|
|
diff --git a/target/s390x/kvm/meson.build b/target/s390x/kvm/meson.build
|
|
index d1356356b1..aef52b6686 100644
|
|
--- a/target/s390x/kvm/meson.build
|
|
+++ b/target/s390x/kvm/meson.build
|
|
@@ -1,6 +1,8 @@
|
|
|
|
s390x_ss.add(when: 'CONFIG_KVM', if_true: files(
|
|
'kvm.c'
|
|
+), if_false: files(
|
|
+ 'stubs.c'
|
|
))
|
|
|
|
# Newer kernels on s390 check for an S390_PGSTE program header and
|
|
diff --git a/target/s390x/kvm/stubs.c b/target/s390x/kvm/stubs.c
|
|
new file mode 100644
|
|
index 0000000000..5fd63b9a7e
|
|
--- /dev/null
|
|
+++ b/target/s390x/kvm/stubs.c
|
|
@@ -0,0 +1,12 @@
|
|
+/*
|
|
+ * SPDX-License-Identifier: GPL-2.0-or-later
|
|
+ */
|
|
+
|
|
+#include "qemu/osdep.h"
|
|
+
|
|
+#include "kvm_s390x.h"
|
|
+
|
|
+int kvm_s390_get_protected_dump(void)
|
|
+{
|
|
+ return false;
|
|
+}
|
|
--
|
|
2.37.3
|
|
|