62 lines
2.0 KiB
Diff
62 lines
2.0 KiB
Diff
From 5481b8bcb37cfaf3016a09df49dbcfdeb5ae9d68 Mon Sep 17 00:00:00 2001
|
|
From: David Hildenbrand <david@redhat.com>
|
|
Date: Fri, 21 Dec 2018 15:36:12 +0000
|
|
Subject: [PATCH 10/22] hw/s390x: Include the tod-qemu also for builds with
|
|
--disable-tcg
|
|
|
|
RH-Author: David Hildenbrand <david@redhat.com>
|
|
Message-id: <20181221153614.27961-11-david@redhat.com>
|
|
Patchwork-id: 83753
|
|
O-Subject: [RHEL-8.0 qemu-kvm v2 PATCH 10/12] hw/s390x: Include the tod-qemu also for builds with --disable-tcg
|
|
Bugzilla: 1653569
|
|
RH-Acked-by: Cornelia Huck <cohuck@redhat.com>
|
|
RH-Acked-by: Thomas Huth <thuth@redhat.com>
|
|
RH-Acked-by: Laurent Vivier <lvivier@redhat.com>
|
|
|
|
The device is required for running qtests, see hw/s390x/tod.c:
|
|
|
|
void s390_init_tod(void)
|
|
{
|
|
Object *obj;
|
|
|
|
if (kvm_enabled()) {
|
|
obj = object_new(TYPE_KVM_S390_TOD);
|
|
} else {
|
|
obj = object_new(TYPE_QEMU_S390_TOD);
|
|
}
|
|
[...]
|
|
}
|
|
|
|
During qtests, we're running without kvm, so TYPE_QEMU_S390_TOD is
|
|
required to avoid that QEMU aborts here.
|
|
|
|
Fixes: 8046f374a6 ("s390x/tod: factor out TOD into separate device")
|
|
Signed-off-by: Thomas Huth <thuth@redhat.com>
|
|
Message-Id: <1539264723-741-1-git-send-email-thuth@redhat.com>
|
|
Reviewed-by: David Hildenbrand <david@redhat.com>
|
|
Signed-off-by: Cornelia Huck <cohuck@redhat.com>
|
|
(cherry picked from commit 0161215d435ef5680c4623bcbdfe89ce5b35cf42)
|
|
Signed-off-by: David Hildenbrand <david@redhat.com>
|
|
Signed-off-by: Danilo C. L. de Paula <ddepaula@redhat.com>
|
|
---
|
|
hw/s390x/Makefile.objs | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/hw/s390x/Makefile.objs b/hw/s390x/Makefile.objs
|
|
index add89b1..c57d706 100644
|
|
--- a/hw/s390x/Makefile.objs
|
|
+++ b/hw/s390x/Makefile.objs
|
|
@@ -15,8 +15,8 @@ obj-$(call lnot,$(CONFIG_PCI)) += s390-pci-stub.o
|
|
obj-y += s390-skeys.o
|
|
obj-y += s390-stattrib.o
|
|
obj-y += tod.o
|
|
+obj-y += tod-qemu.o
|
|
obj-$(CONFIG_KVM) += tod-kvm.o
|
|
-obj-$(CONFIG_TCG) += tod-qemu.o
|
|
obj-$(CONFIG_KVM) += s390-skeys-kvm.o
|
|
obj-$(CONFIG_KVM) += s390-stattrib-kvm.o
|
|
obj-y += s390-ccw.o
|
|
--
|
|
1.8.3.1
|
|
|