qemu-kvm/SOURCES/kvm-Do-not-build-bluetooth-...

130 lines
3.6 KiB
Diff

From b579d3287a75db4b7ee37d25d99b2087f4ed4475 Mon Sep 17 00:00:00 2001
From: Miroslav Rezanina <mrezanin@redhat.com>
Date: Fri, 30 Nov 2018 13:58:43 +0000
Subject: [PATCH 08/16] Do not build bluetooth support
RH-Author: Miroslav Rezanina <mrezanin@redhat.com>
Message-id: <1543586323-7323-1-git-send-email-mrezanin@redhat.com>
Patchwork-id: 83193
O-Subject: [RHEL-8 qemu-kvm PATCHv2] Do not build bluetooth support
Bugzilla: 1654651
RH-Acked-by: Thomas Huth <thuth@redhat.com>
RH-Acked-by: Dr. David Alan Gilbert <dgilbert@redhat.com>
RH-Acked-by: Gerd Hoffmann <kraxel@redhat.com>
From: Miroslav Rezanina <mrezanin@redhat.com>
BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1654651
Brew: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=19329246
Branch: rhel8/master-2.12.0
We do not support bt devices however some bt related code is built in.
As this code is deprecated upstream disabling build of this code downstream.
Signed-off-by: Miroslav Rezanina <mrezanin@redhat.com>
---
v2:
- Removed -bt option from qemu-options.hx
Signed-off-by: Danilo C. L. de Paula <ddepaula@redhat.com>
---
Makefile.objs | 4 ++--
hw/bt/Makefile.objs | 4 ++--
qemu-options.hx | 2 ++
vl.c | 7 +++++++
4 files changed, 13 insertions(+), 4 deletions(-)
diff --git a/Makefile.objs b/Makefile.objs
index c6c3554..be72238 100644
--- a/Makefile.objs
+++ b/Makefile.objs
@@ -115,8 +115,8 @@ common-obj-y += replay/
common-obj-y += ui/
common-obj-m += ui/
-common-obj-y += bt-host.o bt-vhci.o
-bt-host.o-cflags := $(BLUEZ_CFLAGS)
+#common-obj-y += bt-host.o bt-vhci.o
+#bt-host.o-cflags := $(BLUEZ_CFLAGS)
common-obj-y += dma-helpers.o
common-obj-y += vl.o
diff --git a/hw/bt/Makefile.objs b/hw/bt/Makefile.objs
index 867a7d2..e678e9e 100644
--- a/hw/bt/Makefile.objs
+++ b/hw/bt/Makefile.objs
@@ -1,3 +1,3 @@
-common-obj-y += core.o l2cap.o sdp.o hci.o hid.o
-common-obj-y += hci-csr.o
+#common-obj-y += core.o l2cap.o sdp.o hci.o hid.o
+#common-obj-y += hci-csr.o
diff --git a/qemu-options.hx b/qemu-options.hx
index 4271cd3..2e05112 100644
--- a/qemu-options.hx
+++ b/qemu-options.hx
@@ -2827,6 +2827,7 @@ STEXI
ETEXI
DEFHEADING()
+#if 0
DEFHEADING(Bluetooth(R) options:)
STEXI
@table @option
@@ -2901,6 +2902,7 @@ STEXI
@end table
ETEXI
DEFHEADING()
+#endif
#ifdef CONFIG_TPM
DEFHEADING(TPM device options:)
diff --git a/vl.c b/vl.c
index f253876..74fa8f2 100644
--- a/vl.c
+++ b/vl.c
@@ -923,6 +923,7 @@ static void configure_rtc(QemuOpts *opts)
}
}
+#if 0 // Disabled for Red Hat Enterprise Linux
/***********************************************************/
/* Bluetooth support */
static int nb_hcis;
@@ -1044,6 +1045,7 @@ static int bt_parse(const char *opt)
error_report("bad bluetooth parameter '%s'", opt);
return 1;
}
+#endif
static int parse_sandbox(void *opaque, QemuOpts *opts, Error **errp)
{
@@ -3367,9 +3369,12 @@ int main(int argc, char **argv, char **envp)
exit(1);
break;
#endif
+
+#if 0 // Disabled for Red Hat Enterprise Linux
case QEMU_OPTION_bt:
add_device_config(DEV_BT, optarg);
break;
+#endif
case QEMU_OPTION_audio_help:
AUD_help ();
exit (0);
@@ -4523,9 +4528,11 @@ int main(int argc, char **argv, char **envp)
exit(1);
}
+#if 0 // Disabled for Red Hat Enterprise Linux
/* init the bluetooth world */
if (foreach_device_config(DEV_BT, bt_parse))
exit(1);
+#endif
if (!xen_enabled()) {
/* On 32-bit hosts, QEMU is limited by virtual address space */
--
1.8.3.1