07d01bd47b
- Rebase to QEMU 8.0.0 - Resolves: bz#2180898 (Rebase to QEMU 8.0.0 for RHEL 9.3.0)
84 lines
2.5 KiB
Diff
84 lines
2.5 KiB
Diff
From 8173d2eabaf77312d36b00c618f6770948b80593 Mon Sep 17 00:00:00 2001
|
|
From: Miroslav Rezanina <mrezanin@redhat.com>
|
|
Date: Mon, 17 Apr 2023 01:24:18 -0400
|
|
Subject: Disable unwanted new devices
|
|
|
|
QEMU 8.0 adds two new device we do not want to support that can't
|
|
be disabled using configure switch.
|
|
|
|
1) ide-cf - virtual CompactFlash card
|
|
|
|
2) i2c-echo - testing echo device
|
|
|
|
Use manual disabling of the device by changing code (1) and meson configs (2).
|
|
|
|
Signed-off-by: Miroslav Rezanina <mrezanin@redhat.com>
|
|
---
|
|
hw/ide/qdev.c | 9 +++++++++
|
|
hw/misc/meson.build | 3 ++-
|
|
2 files changed, 11 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/hw/ide/qdev.c b/hw/ide/qdev.c
|
|
index 1b3b4da01d..454bfa5783 100644
|
|
--- a/hw/ide/qdev.c
|
|
+++ b/hw/ide/qdev.c
|
|
@@ -283,10 +283,13 @@ static void ide_cd_realize(IDEDevice *dev, Error **errp)
|
|
ide_dev_initfn(dev, IDE_CD, errp);
|
|
}
|
|
|
|
+/* Disabled for Red Hat Enterprise Linux */
|
|
+#if 0
|
|
static void ide_cf_realize(IDEDevice *dev, Error **errp)
|
|
{
|
|
ide_dev_initfn(dev, IDE_CFATA, errp);
|
|
}
|
|
+#endif
|
|
|
|
#define DEFINE_IDE_DEV_PROPERTIES() \
|
|
DEFINE_BLOCK_PROPERTIES(IDEDrive, dev.conf), \
|
|
@@ -346,6 +349,8 @@ static const TypeInfo ide_cd_info = {
|
|
.class_init = ide_cd_class_init,
|
|
};
|
|
|
|
+/* Disabled for Red Hat Enterprise Linux */
|
|
+#if 0
|
|
static Property ide_cf_properties[] = {
|
|
DEFINE_IDE_DEV_PROPERTIES(),
|
|
DEFINE_BLOCK_CHS_PROPERTIES(IDEDrive, dev.conf),
|
|
@@ -371,6 +376,7 @@ static const TypeInfo ide_cf_info = {
|
|
.instance_size = sizeof(IDEDrive),
|
|
.class_init = ide_cf_class_init,
|
|
};
|
|
+#endif
|
|
|
|
static void ide_device_class_init(ObjectClass *klass, void *data)
|
|
{
|
|
@@ -396,7 +402,10 @@ static void ide_register_types(void)
|
|
type_register_static(&ide_bus_info);
|
|
type_register_static(&ide_hd_info);
|
|
type_register_static(&ide_cd_info);
|
|
+/* Disabled for Red Hat Enterprise Linux */
|
|
+#if 0
|
|
type_register_static(&ide_cf_info);
|
|
+#endif
|
|
type_register_static(&ide_device_type_info);
|
|
}
|
|
|
|
diff --git a/hw/misc/meson.build b/hw/misc/meson.build
|
|
index a40245ad44..9cc5a61ed7 100644
|
|
--- a/hw/misc/meson.build
|
|
+++ b/hw/misc/meson.build
|
|
@@ -128,7 +128,8 @@ softmmu_ss.add(when: 'CONFIG_NRF51_SOC', if_true: files('nrf51_rng.c'))
|
|
|
|
softmmu_ss.add(when: 'CONFIG_GRLIB', if_true: files('grlib_ahb_apb_pnp.c'))
|
|
|
|
-softmmu_ss.add(when: 'CONFIG_I2C', if_true: files('i2c-echo.c'))
|
|
+# Disabled for Red Hat Enterprise Linux
|
|
+# softmmu_ss.add(when: 'CONFIG_I2C', if_true: files('i2c-echo.c'))
|
|
|
|
specific_ss.add(when: 'CONFIG_AVR_POWER', if_true: files('avr_power.c'))
|
|
|
|
--
|
|
2.39.1
|
|
|