qemu-kvm/0020-Build-RHEL-9.patch

63 lines
1.9 KiB
Diff

From 1a0497bf6405db1e9ee07db40d90309566bb9f25 Mon Sep 17 00:00:00 2001
From: Miroslav Rezanina <mrezanin@redhat.com>
Date: Thu, 26 Nov 2020 08:26:34 +0100
Subject: Build RHEL 9
---
migration/qemu-file.c | 2 +-
qobject/block-qdict.c | 2 +-
redhat/Makefile.common | 3 ++-
redhat/qemu-kvm.spec.template | 12 ------------
tests/meson.build | 4 ++--
5 files changed, 6 insertions(+), 17 deletions(-)
diff --git a/migration/qemu-file.c b/migration/qemu-file.c
index be21518..d6e03db 100644
--- a/migration/qemu-file.c
+++ b/migration/qemu-file.c
@@ -595,7 +595,7 @@ size_t qemu_get_buffer_in_place(QEMUFile *f, uint8_t **buf, size_t size)
{
if (size < IO_BUF_SIZE) {
size_t res;
- uint8_t *src;
+ uint8_t *src = NULL;
res = qemu_peek_buffer(f, &src, size, 0);
diff --git a/qobject/block-qdict.c b/qobject/block-qdict.c
index 1487cc5..b265244 100644
--- a/qobject/block-qdict.c
+++ b/qobject/block-qdict.c
@@ -224,7 +224,7 @@ void qdict_array_split(QDict *src, QList **dst)
for (i = 0; i < UINT_MAX; i++) {
QObject *subqobj;
bool is_subqdict;
- QDict *subqdict;
+ QDict *subqdict = NULL;
char indexstr[32], prefix[32];
size_t snprintf_ret;
diff --git a/tests/meson.build b/tests/meson.build
index afeb6be..52aeaf4 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -136,7 +136,7 @@ if have_block
'test-blockjob': [testblock],
'test-blockjob-txn': [testblock],
'test-block-backend': [testblock],
- 'test-block-iothread': [testblock],
+# 'test-block-iothread': [testblock],
'test-write-threshold': [testblock],
'test-crypto-hash': [crypto],
'test-crypto-hmac': [crypto],
@@ -286,5 +286,5 @@ if not get_option('tcg').disabled()
endif
subdir('qapi-schema')
-subdir('qtest')
+#subdir('qtest')
subdir('migration')
--
1.8.3.1