151 lines
4.6 KiB
Diff
151 lines
4.6 KiB
Diff
From 3927f54a56e29003b84e0e3726d3a0170681128b Mon Sep 17 00:00:00 2001
|
|
From: Cornelia Huck <cohuck@redhat.com>
|
|
Date: Tue, 19 Jan 2021 12:50:44 -0500
|
|
Subject: [PATCH 5/7] s390x/pci: Add routine to get the vfio dma available
|
|
count
|
|
|
|
RH-Author: Cornelia Huck <cohuck@redhat.com>
|
|
Message-id: <20210119125046.472811-6-cohuck@redhat.com>
|
|
Patchwork-id: 100679
|
|
O-Subject: [RHEL-8.4.0 qemu-kvm PATCH 5/7] s390x/pci: Add routine to get the vfio dma available count
|
|
Bugzilla: 1905391
|
|
RH-Acked-by: David Hildenbrand <david@redhat.com>
|
|
RH-Acked-by: Auger Eric <eric.auger@redhat.com>
|
|
RH-Acked-by: Thomas Huth <thuth@redhat.com>
|
|
|
|
From: Matthew Rosato <mjrosato@linux.ibm.com>
|
|
|
|
Create new files for separating out vfio-specific work for s390
|
|
pci. Add the first such routine, which issues VFIO_IOMMU_GET_INFO
|
|
ioctl to collect the current dma available count.
|
|
|
|
Signed-off-by: Matthew Rosato <mjrosato@linux.ibm.com>
|
|
Reviewed-by: Cornelia Huck <cohuck@redhat.com>
|
|
[aw: Fix non-Linux build with CONFIG_LINUX]
|
|
Signed-off-by: Alex Williamson <alex.williamson@redhat.com>
|
|
(cherry picked from commit cd7498d07fbb20fa04790ff7ee168a8a8d01cb30)
|
|
Signed-off-by: Cornelia Huck <cohuck@redhat.com>
|
|
|
|
Conflicts:
|
|
hw/s390x/meson.build
|
|
--> added the file in hw/s390x/Makefile.objs instead,
|
|
since we do not use Meson yet
|
|
hw/s390x/s390-pci-vfio.c
|
|
--> NULL-initialize "info" to avoid a downstream-only
|
|
compiler warning
|
|
|
|
Signed-off-by: Danilo C. L. de Paula <ddepaula@redhat.com>
|
|
---
|
|
hw/s390x/Makefile.objs | 1 +
|
|
hw/s390x/s390-pci-vfio.c | 54 ++++++++++++++++++++++++++++++++
|
|
include/hw/s390x/s390-pci-vfio.h | 24 ++++++++++++++
|
|
3 files changed, 79 insertions(+)
|
|
create mode 100644 hw/s390x/s390-pci-vfio.c
|
|
create mode 100644 include/hw/s390x/s390-pci-vfio.h
|
|
|
|
diff --git a/hw/s390x/Makefile.objs b/hw/s390x/Makefile.objs
|
|
index c4086ec3171..43756c9437d 100644
|
|
--- a/hw/s390x/Makefile.objs
|
|
+++ b/hw/s390x/Makefile.objs
|
|
@@ -7,6 +7,7 @@ obj-y += ipl.o
|
|
obj-y += css.o
|
|
obj-$(CONFIG_S390_CCW_VIRTIO) += s390-virtio-ccw.o
|
|
obj-$(CONFIG_TERMINAL3270) += 3270-ccw.o
|
|
+obj-$(CONFIG_LINUX) += s390-pci-vfio.o
|
|
ifeq ($(CONFIG_VIRTIO_CCW),y)
|
|
obj-y += virtio-ccw.o
|
|
obj-$(CONFIG_VIRTIO_SERIAL) += virtio-ccw-serial.o
|
|
diff --git a/hw/s390x/s390-pci-vfio.c b/hw/s390x/s390-pci-vfio.c
|
|
new file mode 100644
|
|
index 00000000000..0eb22ffec4c
|
|
--- /dev/null
|
|
+++ b/hw/s390x/s390-pci-vfio.c
|
|
@@ -0,0 +1,54 @@
|
|
+/*
|
|
+ * s390 vfio-pci interfaces
|
|
+ *
|
|
+ * Copyright 2020 IBM Corp.
|
|
+ * Author(s): Matthew Rosato <mjrosato@linux.ibm.com>
|
|
+ *
|
|
+ * This work is licensed under the terms of the GNU GPL, version 2 or (at
|
|
+ * your option) any later version. See the COPYING file in the top-level
|
|
+ * directory.
|
|
+ */
|
|
+
|
|
+#include <sys/ioctl.h>
|
|
+
|
|
+#include "qemu/osdep.h"
|
|
+#include "hw/s390x/s390-pci-vfio.h"
|
|
+#include "hw/vfio/vfio-common.h"
|
|
+
|
|
+/*
|
|
+ * Get the current DMA available count from vfio. Returns true if vfio is
|
|
+ * limiting DMA requests, false otherwise. The current available count read
|
|
+ * from vfio is returned in avail.
|
|
+ */
|
|
+bool s390_pci_update_dma_avail(int fd, unsigned int *avail)
|
|
+{
|
|
+ g_autofree struct vfio_iommu_type1_info *info = NULL;
|
|
+ uint32_t argsz;
|
|
+
|
|
+ assert(avail);
|
|
+
|
|
+ argsz = sizeof(struct vfio_iommu_type1_info);
|
|
+ info = g_malloc0(argsz);
|
|
+
|
|
+ /*
|
|
+ * If the specified argsz is not large enough to contain all capabilities
|
|
+ * it will be updated upon return from the ioctl. Retry until we have
|
|
+ * a big enough buffer to hold the entire capability chain.
|
|
+ */
|
|
+retry:
|
|
+ info->argsz = argsz;
|
|
+
|
|
+ if (ioctl(fd, VFIO_IOMMU_GET_INFO, info)) {
|
|
+ return false;
|
|
+ }
|
|
+
|
|
+ if (info->argsz > argsz) {
|
|
+ argsz = info->argsz;
|
|
+ info = g_realloc(info, argsz);
|
|
+ goto retry;
|
|
+ }
|
|
+
|
|
+ /* If the capability exists, update with the current value */
|
|
+ return vfio_get_info_dma_avail(info, avail);
|
|
+}
|
|
+
|
|
diff --git a/include/hw/s390x/s390-pci-vfio.h b/include/hw/s390x/s390-pci-vfio.h
|
|
new file mode 100644
|
|
index 00000000000..1727292e9b5
|
|
--- /dev/null
|
|
+++ b/include/hw/s390x/s390-pci-vfio.h
|
|
@@ -0,0 +1,24 @@
|
|
+/*
|
|
+ * s390 vfio-pci interfaces
|
|
+ *
|
|
+ * Copyright 2020 IBM Corp.
|
|
+ * Author(s): Matthew Rosato <mjrosato@linux.ibm.com>
|
|
+ *
|
|
+ * This work is licensed under the terms of the GNU GPL, version 2 or (at
|
|
+ * your option) any later version. See the COPYING file in the top-level
|
|
+ * directory.
|
|
+ */
|
|
+
|
|
+#ifndef HW_S390_PCI_VFIO_H
|
|
+#define HW_S390_PCI_VFIO_H
|
|
+
|
|
+#ifdef CONFIG_LINUX
|
|
+bool s390_pci_update_dma_avail(int fd, unsigned int *avail);
|
|
+#else
|
|
+static inline bool s390_pci_update_dma_avail(int fd, unsigned int *avail)
|
|
+{
|
|
+ return false;
|
|
+}
|
|
+#endif
|
|
+
|
|
+#endif
|
|
--
|
|
2.27.0
|
|
|