a799a516c5
- kvm-block-compile-out-assert_bdrv_graph_readable-by-defa.patch [bz#2186725] - kvm-graph-lock-Disable-locking-for-now.patch [bz#2186725] - kvm-nbd-server-Fix-drained_poll-to-wake-coroutine-in-rig.patch [bz#2186725] - kvm-iotests-Test-commit-with-iothreads-and-ongoing-I-O.patch [bz#2186725] - kvm-memory-prevent-dma-reentracy-issues.patch [RHEL-516] - kvm-async-Add-an-optional-reentrancy-guard-to-the-BH-API.patch [RHEL-516] - kvm-checkpatch-add-qemu_bh_new-aio_bh_new-checks.patch [RHEL-516] - kvm-hw-replace-most-qemu_bh_new-calls-with-qemu_bh_new_g.patch [RHEL-516] - kvm-lsi53c895a-disable-reentrancy-detection-for-script-R.patch [RHEL-516] - kvm-bcm2835_property-disable-reentrancy-detection-for-io.patch [RHEL-516] - kvm-raven-disable-reentrancy-detection-for-iomem.patch [RHEL-516] - kvm-apic-disable-reentrancy-detection-for-apic-msi.patch [RHEL-516] - kvm-async-avoid-use-after-free-on-re-entrancy-guard.patch [RHEL-516] - kvm-loongarch-mark-loongarch_ipi_iocsr-re-entrnacy-safe.patch [RHEL-516] - kvm-memory-stricter-checks-prior-to-unsetting-engaged_in.patch [RHEL-516] - kvm-lsi53c895a-disable-reentrancy-detection-for-MMIO-reg.patch [RHEL-516] - kvm-hw-scsi-lsi53c895a-Fix-reentrancy-issues-in-the-LSI-.patch [RHEL-516] - kvm-hw-pci-Disable-PCI_ERR_UNCOR_MASK-register-for-machi.patch [bz#2189423] - kvm-multifd-Fix-the-number-of-channels-ready.patch [bz#2196289] - kvm-util-async-teardown-wire-up-query-command-line-optio.patch [bz#2168500] - kvm-s390x-pv-Fix-spurious-warning-with-asynchronous-tear.patch [bz#2168500] - Resolves: bz#2186725 (Qemu hang when commit during fio running(iothread enable)) - Resolves: RHEL-516 (CVE-2023-2680 qemu-kvm: QEMU: hcd-ehci: DMA reentrancy issue (incomplete fix for CVE-2021-3750) [rhel-9]) - Resolves: bz#2189423 (Failed to migrate VM from rhel 9.3 to rhel 9.2) - Resolves: bz#2196289 (Fix number of ready channels on multifd) - Resolves: bz#2168500 ([IBM 9.3 FEAT] KVM: Improve memory reclaiming for z15 Secure Execution guests - qemu part)
122 lines
5.4 KiB
Diff
122 lines
5.4 KiB
Diff
From d9190117f3c701380701d6e9b2aa3c2446b9708f Mon Sep 17 00:00:00 2001
|
|
From: Stefan Hajnoczi <stefanha@redhat.com>
|
|
Date: Mon, 1 May 2023 13:34:43 -0400
|
|
Subject: [PATCH 01/21] block: compile out assert_bdrv_graph_readable() by
|
|
default
|
|
|
|
RH-Author: Kevin Wolf <kwolf@redhat.com>
|
|
RH-MergeRequest: 166: block/graph-lock: Disable locking for now
|
|
RH-Bugzilla: 2186725
|
|
RH-Acked-by: Eric Blake <eblake@redhat.com>
|
|
RH-Acked-by: Emanuele Giuseppe Esposito <eesposit@redhat.com>
|
|
RH-Acked-by: Stefan Hajnoczi <stefanha@redhat.com>
|
|
RH-Commit: [1/4] d8cb4bb832c85e8216d97e57679a34c7bc6a8f71 (kmwolf/centos-qemu-kvm)
|
|
|
|
reader_count() is a performance bottleneck because the global
|
|
aio_context_list_lock mutex causes thread contention. Put this debugging
|
|
assertion behind a new ./configure --enable-debug-graph-lock option and
|
|
disable it by default.
|
|
|
|
The --enable-debug-graph-lock option is also enabled by the more general
|
|
--enable-debug option.
|
|
|
|
Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
|
|
Message-Id: <20230501173443.153062-1-stefanha@redhat.com>
|
|
Reviewed-by: Kevin Wolf <kwolf@redhat.com>
|
|
Signed-off-by: Kevin Wolf <kwolf@redhat.com>
|
|
(cherry picked from commit 58a2e3f5c37be02dac3086b81bdda9414b931edf)
|
|
Signed-off-by: Kevin Wolf <kwolf@redhat.com>
|
|
---
|
|
block/graph-lock.c | 3 +++
|
|
configure | 1 +
|
|
meson.build | 2 ++
|
|
meson_options.txt | 2 ++
|
|
scripts/meson-buildoptions.sh | 4 ++++
|
|
5 files changed, 12 insertions(+)
|
|
|
|
diff --git a/block/graph-lock.c b/block/graph-lock.c
|
|
index 454c31e691..259a7a0bde 100644
|
|
--- a/block/graph-lock.c
|
|
+++ b/block/graph-lock.c
|
|
@@ -265,7 +265,10 @@ void bdrv_graph_rdunlock_main_loop(void)
|
|
|
|
void assert_bdrv_graph_readable(void)
|
|
{
|
|
+ /* reader_count() is slow due to aio_context_list_lock lock contention */
|
|
+#ifdef CONFIG_DEBUG_GRAPH_LOCK
|
|
assert(qemu_in_main_thread() || reader_count());
|
|
+#endif
|
|
}
|
|
|
|
void assert_bdrv_graph_writable(void)
|
|
diff --git a/configure b/configure
|
|
index 800b5850f4..a62a3e6be9 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -806,6 +806,7 @@ for opt do
|
|
--enable-debug)
|
|
# Enable debugging options that aren't excessively noisy
|
|
debug_tcg="yes"
|
|
+ meson_option_parse --enable-debug-graph-lock ""
|
|
meson_option_parse --enable-debug-mutex ""
|
|
meson_option_add -Doptimization=0
|
|
fortify_source="no"
|
|
diff --git a/meson.build b/meson.build
|
|
index c44d05a13f..d964e741e7 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -1956,6 +1956,7 @@ if get_option('debug_stack_usage') and have_coroutine_pool
|
|
have_coroutine_pool = false
|
|
endif
|
|
config_host_data.set10('CONFIG_COROUTINE_POOL', have_coroutine_pool)
|
|
+config_host_data.set('CONFIG_DEBUG_GRAPH_LOCK', get_option('debug_graph_lock'))
|
|
config_host_data.set('CONFIG_DEBUG_MUTEX', get_option('debug_mutex'))
|
|
config_host_data.set('CONFIG_DEBUG_STACK_USAGE', get_option('debug_stack_usage'))
|
|
config_host_data.set('CONFIG_GPROF', get_option('gprof'))
|
|
@@ -3833,6 +3834,7 @@ summary_info += {'PIE': get_option('b_pie')}
|
|
summary_info += {'static build': config_host.has_key('CONFIG_STATIC')}
|
|
summary_info += {'malloc trim support': has_malloc_trim}
|
|
summary_info += {'membarrier': have_membarrier}
|
|
+summary_info += {'debug graph lock': get_option('debug_graph_lock')}
|
|
summary_info += {'debug stack usage': get_option('debug_stack_usage')}
|
|
summary_info += {'mutex debugging': get_option('debug_mutex')}
|
|
summary_info += {'memory allocator': get_option('malloc')}
|
|
diff --git a/meson_options.txt b/meson_options.txt
|
|
index fc9447d267..bc857fe68b 100644
|
|
--- a/meson_options.txt
|
|
+++ b/meson_options.txt
|
|
@@ -311,6 +311,8 @@ option('rng_none', type: 'boolean', value: false,
|
|
description: 'dummy RNG, avoid using /dev/(u)random and getrandom()')
|
|
option('coroutine_pool', type: 'boolean', value: true,
|
|
description: 'coroutine freelist (better performance)')
|
|
+option('debug_graph_lock', type: 'boolean', value: false,
|
|
+ description: 'graph lock debugging support')
|
|
option('debug_mutex', type: 'boolean', value: false,
|
|
description: 'mutex debugging support')
|
|
option('debug_stack_usage', type: 'boolean', value: false,
|
|
diff --git a/scripts/meson-buildoptions.sh b/scripts/meson-buildoptions.sh
|
|
index 009fab1515..30e1f25259 100644
|
|
--- a/scripts/meson-buildoptions.sh
|
|
+++ b/scripts/meson-buildoptions.sh
|
|
@@ -21,6 +21,8 @@ meson_options_help() {
|
|
printf "%s\n" ' QEMU'
|
|
printf "%s\n" ' --enable-cfi Control-Flow Integrity (CFI)'
|
|
printf "%s\n" ' --enable-cfi-debug Verbose errors in case of CFI violation'
|
|
+ printf "%s\n" ' --enable-debug-graph-lock'
|
|
+ printf "%s\n" ' graph lock debugging support'
|
|
printf "%s\n" ' --enable-debug-mutex mutex debugging support'
|
|
printf "%s\n" ' --enable-debug-stack-usage'
|
|
printf "%s\n" ' measure coroutine stack usage'
|
|
@@ -249,6 +251,8 @@ _meson_option_parse() {
|
|
--datadir=*) quote_sh "-Ddatadir=$2" ;;
|
|
--enable-dbus-display) printf "%s" -Ddbus_display=enabled ;;
|
|
--disable-dbus-display) printf "%s" -Ddbus_display=disabled ;;
|
|
+ --enable-debug-graph-lock) printf "%s" -Ddebug_graph_lock=true ;;
|
|
+ --disable-debug-graph-lock) printf "%s" -Ddebug_graph_lock=false ;;
|
|
--enable-debug-mutex) printf "%s" -Ddebug_mutex=true ;;
|
|
--disable-debug-mutex) printf "%s" -Ddebug_mutex=false ;;
|
|
--enable-debug-stack-usage) printf "%s" -Ddebug_stack_usage=true ;;
|
|
--
|
|
2.39.3
|
|
|