41331165db
- Rebase to qemu 4.1.0 rc4 [bz#1705235] - Resolves: bz#1705235 (Rebase qemu-kvm for RHEL-AV 8.1.0)
145 lines
5.0 KiB
Diff
145 lines
5.0 KiB
Diff
From d7ed59eb82b87992582d05933bbf68107962ba43 Mon Sep 17 00:00:00 2001
|
|
From: Miroslav Rezanina <mrezanin@redhat.com>
|
|
Date: Fri, 12 Oct 2018 07:31:11 +0200
|
|
Subject: Initial redhat build
|
|
|
|
This patch introduces redhat build structure in redhat subdirectory. In addition,
|
|
several issues are fixed in QEMU tree:
|
|
|
|
- Change of app name for sasl_server_init in VNC code from qemu to qemu-kvm
|
|
- As we use qemu-kvm as name in all places, this is updated to be consistent
|
|
- Man page renamed from qemu to qemu-kvm
|
|
- man page is installed using make install so we have to fix it in qemu tree
|
|
- Use "/share/qemu-kvm" as SHARE_SUFFIX
|
|
- We reconfigured our share to qemu-kvm to be consistent with used name
|
|
|
|
This rebase includes changes up to qemu-kvm-4.0.0-6.el8
|
|
|
|
Rebase notes (3.1.0):
|
|
- added new configure options
|
|
|
|
Rebase notes (4.0.0):
|
|
- Added dependency to perl-Test-Harness (upstream)
|
|
- Added dependency to python3-sphinx (upstream)
|
|
- Change location of icons (upstream)
|
|
- Remove .desktop file (added upstream)
|
|
- Added qemu-trace-stap (added upstream)
|
|
- Removed elf2dmp (added upstream)
|
|
- Remove .buildinfo
|
|
- Added pvh.bin rom (added upstream)
|
|
- Added interop documentation files
|
|
- Use python module instead of qemu.py (upstream)
|
|
|
|
Rebase notes (4.1.0-rc0):
|
|
- Remove edk2 files generated by build
|
|
- Switch to rhel-8.1-candidate build target
|
|
- Remove specs documentation
|
|
- Switched from libssh2 to libssh
|
|
- Add rc0 tarball usage hacks
|
|
|
|
Rebase notes (4.1.0-rc1):
|
|
- Added BuildRequires for wget, rpm-build and python3-sphinx
|
|
|
|
Rebase notes (4.1.0-rc2):
|
|
- Removed new unpacked files
|
|
- Update configure line to use new options
|
|
|
|
Merged patches (3.1.0):
|
|
- 01f0c9f RHEL8: Add disable configure options to qemu spec file
|
|
- Spec file cleanups
|
|
|
|
Merged patches (4.0.0):
|
|
- aa4297c Add edk2 Requires to qemu-kvm
|
|
- d124ff5779 Fixing brew build target
|
|
- eb204b5 Introduce the qemu-kvm-tests rpm
|
|
- 223cf0c Load kvm module during boot (partial)
|
|
|
|
Merged patches (4.1.0-rc0):
|
|
- ebb6e97 redhat: Fix LOCALVERSION creation
|
|
- b0ab0cc redhat: enable tpmdev passthrough (not disabling tests)
|
|
- 7cb3c4a Enable libpmem to support nvdimm
|
|
- 8943607 qemu-kvm.spec: bump libseccomp >= 2.4.0
|
|
- 27b7c44 rh: set CONFIG_BOCHS_DISPLAY=y for x86 (partial)
|
|
|
|
Merged patches (4.1.0-rc3):
|
|
- e1fe9fe x86_64-rh-devices: enable TPM emulation (partial)
|
|
---
|
|
.gitignore | 1 +
|
|
Makefile | 3 +-
|
|
configure | 1 +
|
|
os-posix.c | 2 +-
|
|
redhat/Makefile | 82 ++
|
|
redhat/Makefile.common | 51 +
|
|
redhat/README.tests | 39 +
|
|
redhat/qemu-kvm.spec.template | 2202 +++++++++++++++++++++++++++++++++++++
|
|
redhat/scripts/process-patches.sh | 7 +-
|
|
ui/vnc.c | 2 +-
|
|
10 files changed, 2382 insertions(+), 8 deletions(-)
|
|
create mode 100644 redhat/Makefile
|
|
create mode 100644 redhat/Makefile.common
|
|
create mode 100644 redhat/README.tests
|
|
create mode 100644 redhat/qemu-kvm.spec.template
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 85862fb..288a5ac 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -493,6 +493,7 @@ CAP_CFLAGS += -DCAPSTONE_HAS_ARM
|
|
CAP_CFLAGS += -DCAPSTONE_HAS_ARM64
|
|
CAP_CFLAGS += -DCAPSTONE_HAS_POWERPC
|
|
CAP_CFLAGS += -DCAPSTONE_HAS_X86
|
|
+CAP_CFLAGS += -Wp,-D_GLIBCXX_ASSERTIONS
|
|
|
|
.PHONY: capstone/all
|
|
capstone/all: .git-submodule-status
|
|
@@ -804,7 +805,7 @@ install-doc: $(DOCS) install-sphinxdocs
|
|
$(INSTALL_DATA) docs/interop/qemu-qmp-ref.txt "$(DESTDIR)$(qemu_docdir)"
|
|
ifdef CONFIG_POSIX
|
|
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
|
|
- $(INSTALL_DATA) qemu.1 "$(DESTDIR)$(mandir)/man1"
|
|
+ $(INSTALL_DATA) qemu.1 "$(DESTDIR)$(mandir)/man1/qemu-kvm.1"
|
|
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man7"
|
|
$(INSTALL_DATA) docs/interop/qemu-qmp-ref.7 "$(DESTDIR)$(mandir)/man7"
|
|
$(INSTALL_DATA) docs/qemu-block-drivers.7 "$(DESTDIR)$(mandir)/man7"
|
|
diff --git a/configure b/configure
|
|
index 714e7fb..4ecc861 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -2424,6 +2424,7 @@ if test "$seccomp" != "no" ; then
|
|
seccomp="no"
|
|
fi
|
|
fi
|
|
+
|
|
##########################################
|
|
# xen probe
|
|
|
|
diff --git a/os-posix.c b/os-posix.c
|
|
index 3ba7df8..ff26068 100644
|
|
--- a/os-posix.c
|
|
+++ b/os-posix.c
|
|
@@ -83,7 +83,7 @@ void os_setup_signal_handling(void)
|
|
/* Find a likely location for support files using the location of the binary.
|
|
For installed binaries this will be "$bindir/../share/qemu". When
|
|
running from the build tree this will be "$bindir/../pc-bios". */
|
|
-#define SHARE_SUFFIX "/share/qemu"
|
|
+#define SHARE_SUFFIX "/share/qemu-kvm"
|
|
#define BUILD_SUFFIX "/pc-bios"
|
|
char *os_find_datadir(void)
|
|
{
|
|
diff --git a/ui/vnc.c b/ui/vnc.c
|
|
index 38f92bf..933dc36 100644
|
|
--- a/ui/vnc.c
|
|
+++ b/ui/vnc.c
|
|
@@ -3976,7 +3976,7 @@ void vnc_display_open(const char *id, Error **errp)
|
|
|
|
#ifdef CONFIG_VNC_SASL
|
|
if (sasl) {
|
|
- int saslErr = sasl_server_init(NULL, "qemu");
|
|
+ int saslErr = sasl_server_init(NULL, "qemu-kvm");
|
|
|
|
if (saslErr != SASL_OK) {
|
|
error_setg(errp, "Failed to initialize SASL auth: %s",
|
|
--
|
|
1.8.3.1
|
|
|