qemu-kvm/0005-Initial-redhat-build.p...

210 lines
6.7 KiB
Diff

From b9d95992b85d3667c13df3a321933c44c7157d0b Mon Sep 17 00:00:00 2001
From: Miroslav Rezanina <mrezanin@redhat.com>
Date: Fri, 12 Oct 2018 07:31:11 +0200
Subject: Initial redhat build
This patch introduces redhat build structure in redhat subdirectory. In addition,
several issues are fixed in QEMU tree:
- Change of app name for sasl_server_init in VNC code from qemu to qemu-kvm
- As we use qemu-kvm as name in all places, this is updated to be consistent
- Man page renamed from qemu to qemu-kvm
- man page is installed using make install so we have to fix it in qemu tree
This rebase includes changes up to qemu-kvm-4.2.0-28.el8
Rebase notes (3.1.0):
- added new configure options
Rebase notes (4.0.0):
- Added dependency to perl-Test-Harness (upstream)
- Added dependency to python3-sphinx (upstream)
- Change location of icons (upstream)
- Remove .desktop file (added upstream)
- Added qemu-trace-stap (added upstream)
- Removed elf2dmp (added upstream)
- Remove .buildinfo
- Added pvh.bin rom (added upstream)
- Added interop documentation files
- Use python module instead of qemu.py (upstream)
Rebase notes (4.1.0):
- Remove edk2 files generated by build
- Switch to rhel-8.1-candidate build target
- Remove specs documentation
- Switched from libssh2 to libssh
- Add rc0 tarball usage hacks
- Added BuildRequires for wget, rpm-build and python3-sphinx
- Removed new unpacked files
- Update configure line to use new options
Rebase notes (4.2.0):
- Disable iotest run during make check
- README renamed to README.rst (upstream)
- Removed ui-spice-app.so
- Added relevant changes from "505f7f4 redhat: Adding slirp to the exploded tree"
- Removed qemu-ga.8 install from spec file - installed by make
- Removed spapr-rtas.bin (upstream)
- Require newer SLOF (20191022)
Rebase notes (weekly-200115):
- Added index.html (upstream)
Rebase notes (weekly-200122):
- Use python3 for virtio_seg_max_adjust.py test
- Removed qemu-trace-stap shebang from spec file
Rebase notes (weekly-200129):
- Ship docs/qemu-kvm/system help files (added upstream)
Rebase notes (weekly-200212):
- Added virtiofsd.1 (upstream)
Rebase notes (weekly-200219):
- Use out-of-tree build
Rebase notes (weekly-200226):
- added tools documentation (upstream)
Rebase notes (weekly-200304):
- Update local build
Rebase notes (weekly-200311):
- Add docs/qemu-kvm/user help files (added upstream)
- Removing installed qemu-storage-daemon (added upstream)
Rebase notes (weekly-200318):
- Removing opensbi-riscv32-sifive_u-fw_jump.bin (added upstream)
Rebase notes (weekly-200325):
- Disable iotests (moved from Enable make check commit)
Rebase notes (5.0.0 rc2):
- Added missing configure options
Rebase notes (5.0.0 rc3):
- Reorder configure options
Rebase notes (weekly-200617):
- Fixing qemu-kvm-tests rpm content
- Fixed python shenigans
- Include all qemu-iotests files
- qemu-pr-helper moved to /usr/libexec/ (upstream)
Rebase notes (weekly-200701):
- Moved qemu-ga-ref.* and qemu-qmp-ref.* docs files to interop diretory (upstream)
Merged patches (3.1.0):
- 01f0c9f RHEL8: Add disable configure options to qemu spec file
- Spec file cleanups
Merged patches (4.0.0):
- aa4297c Add edk2 Requires to qemu-kvm
- d124ff5779 Fixing brew build target
- eb204b5 Introduce the qemu-kvm-tests rpm
- 223cf0c Load kvm module during boot (partial)
Merged patches (4.1.0):
- ebb6e97 redhat: Fix LOCALVERSION creation
- b0ab0cc redhat: enable tpmdev passthrough (not disabling tests)
- 7cb3c4a Enable libpmem to support nvdimm
- 8943607 qemu-kvm.spec: bump libseccomp >= 2.4.0
- 27b7c44 rh: set CONFIG_BOCHS_DISPLAY=y for x86 (partial)
- e1fe9fe x86_64-rh-devices: enable TPM emulation (partial)
Merged patches (4.2.0):
- 69e1fb2 enable virgla
- d4f6115 enable virgl, for real this time ...
Merged patches (weekly-200205):
- 5edf6bd Add support for rh-brew-module
- f77d52d redhat: ship virtiofsd vhost-user device backend
Merged patches (weekly-200610):
- 63f12d4 redhat: Always use module build target for rh-brew (modified)
- 9b1e140 redhat: updating the modular target
Merged patches (weekly-200617):
- 44b8bd0 spec: Fix python shenigans for tests
---
.gitignore | 1 +
Makefile | 3 +-
configure | 1 +
redhat/Makefile | 86 +
redhat/Makefile.common | 53 +
redhat/README.tests | 39 +
redhat/qemu-kvm.spec.template | 2956 +++++++++++++++++++++++++++++++++++
redhat/qemu-pr-helper.service | 2 +-
redhat/scripts/extract_build_cmd.py | 2 +-
redhat/scripts/process-patches.sh | 7 +-
tests/check-block.sh | 2 +
ui/vnc.c | 2 +-
12 files changed, 3145 insertions(+), 9 deletions(-)
create mode 100644 redhat/Makefile
create mode 100644 redhat/Makefile.common
create mode 100644 redhat/README.tests
create mode 100644 redhat/qemu-kvm.spec.template
diff --git a/Makefile b/Makefile
index b1b8a5a..88b7565 100644
--- a/Makefile
+++ b/Makefile
@@ -549,6 +549,7 @@ CAP_CFLAGS += -DCAPSTONE_HAS_ARM
CAP_CFLAGS += -DCAPSTONE_HAS_ARM64
CAP_CFLAGS += -DCAPSTONE_HAS_POWERPC
CAP_CFLAGS += -DCAPSTONE_HAS_X86
+CAP_CFLAGS += -Wp,-D_GLIBCXX_ASSERTIONS
.PHONY: capstone/all
capstone/all: .git-submodule-status
@@ -878,7 +879,7 @@ install-doc: $(DOCS) install-sphinxdocs
$(INSTALL_DATA) docs/interop/qemu-qmp-ref.txt "$(DESTDIR)$(qemu_docdir)/interop"
ifdef CONFIG_POSIX
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
- $(INSTALL_DATA) $(MANUAL_BUILDDIR)/system/qemu.1 "$(DESTDIR)$(mandir)/man1"
+ $(INSTALL_DATA) $(MANUAL_BUILDDIR)/system/qemu.1 "$(DESTDIR)$(mandir)/man1/qemu-kvm.1"
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man7"
$(INSTALL_DATA) docs/interop/qemu-qmp-ref.7 "$(DESTDIR)$(mandir)/man7"
$(INSTALL_DATA) $(MANUAL_BUILDDIR)/system/qemu-block-drivers.7 "$(DESTDIR)$(mandir)/man7"
diff --git a/configure b/configure
index 4a22dcd..53979dc 100755
--- a/configure
+++ b/configure
@@ -2596,6 +2596,7 @@ if test "$seccomp" != "no" ; then
seccomp="no"
fi
fi
+
##########################################
# xen probe
diff --git a/tests/check-block.sh b/tests/check-block.sh
index 8e29c86..e9bcb5a 100755
--- a/tests/check-block.sh
+++ b/tests/check-block.sh
@@ -53,6 +53,8 @@ if ! (sed --version | grep 'GNU sed') > /dev/null 2>&1 ; then
fi
fi
+exit 0
+
cd tests/qemu-iotests
ret=0
diff --git a/ui/vnc.c b/ui/vnc.c
index 12a1271..89fb616 100644
--- a/ui/vnc.c
+++ b/ui/vnc.c
@@ -3972,7 +3972,7 @@ void vnc_display_open(const char *id, Error **errp)
#ifdef CONFIG_VNC_SASL
if (sasl) {
- int saslErr = sasl_server_init(NULL, "qemu");
+ int saslErr = sasl_server_init(NULL, "qemu-kvm");
if (saslErr != SASL_OK) {
error_setg(errp, "Failed to initialize SASL auth: %s",
--
1.8.3.1