qemu-kvm/SOURCES/kvm-enable-ramfb.patch

73 lines
2.3 KiB
Diff

From 441128e2f13a56d4949b70971edd2f6902772959 Mon Sep 17 00:00:00 2001
From: Gerd Hoffmann <kraxel@redhat.com>
Date: Wed, 3 Jun 2020 15:15:56 +0100
Subject: [PATCH 01/17] enable ramfb
RH-Author: Gerd Hoffmann <kraxel@redhat.com>
Message-id: <20200603151556.1195-2-kraxel@redhat.com>
Patchwork-id: 97097
O-Subject: [RHEL-AV-8.2.0.z qemu-kvm PATCH 1/1] enable ramfb
Bugzilla: 1841068
RH-Acked-by: Danilo de Paula <ddepaula@redhat.com>
RH-Acked-by: Kevin Wolf <kwolf@redhat.com>
RH-Acked-by: Stefan Hajnoczi <stefanha@redhat.com>
---
hw/vfio/pci.c | 5 -----
hw/display/Makefile.objs | 5 ++---
2 files changed, 2 insertions(+), 8 deletions(-)
Signed-off-by: Danilo C. L. de Paula <ddepaula@redhat.com>
---
hw/display/Makefile.objs | 5 ++---
hw/vfio/pci.c | 5 -----
2 files changed, 2 insertions(+), 8 deletions(-)
diff --git a/hw/display/Makefile.objs b/hw/display/Makefile.objs
index 3d0cda1..f2182e3 100644
--- a/hw/display/Makefile.objs
+++ b/hw/display/Makefile.objs
@@ -1,9 +1,8 @@
common-obj-$(CONFIG_DDC) += i2c-ddc.o
common-obj-$(CONFIG_EDID) += edid-generate.o edid-region.o
-# Disabled for Red Hat Enterprise Linux
-#common-obj-$(CONFIG_FW_CFG_DMA) += ramfb.o
-#common-obj-$(CONFIG_FW_CFG_DMA) += ramfb-standalone.o
+common-obj-$(CONFIG_FW_CFG_DMA) += ramfb.o
+common-obj-$(CONFIG_FW_CFG_DMA) += ramfb-standalone.o
common-obj-$(CONFIG_ADS7846) += ads7846.o
common-obj-$(CONFIG_VGA_CIRRUS) += cirrus_vga.o
diff --git a/hw/vfio/pci.c b/hw/vfio/pci.c
index d717520..f191904 100644
--- a/hw/vfio/pci.c
+++ b/hw/vfio/pci.c
@@ -3249,7 +3249,6 @@ static const TypeInfo vfio_pci_dev_info = {
},
};
-#if 0 /* Disabled for Red Hat Enterprise Linux */
static Property vfio_pci_dev_nohotplug_properties[] = {
DEFINE_PROP_BOOL("ramfb", VFIOPCIDevice, enable_ramfb, false),
DEFINE_PROP_END_OF_LIST(),
@@ -3269,15 +3268,11 @@ static const TypeInfo vfio_pci_nohotplug_dev_info = {
.instance_size = sizeof(VFIOPCIDevice),
.class_init = vfio_pci_nohotplug_dev_class_init,
};
-#endif
static void register_vfio_pci_dev_type(void)
{
type_register_static(&vfio_pci_dev_info);
-
-#if 0 /* Disabled for Red Hat Enterprise Linux */
type_register_static(&vfio_pci_nohotplug_dev_info);
-#endif
}
type_init(register_vfio_pci_dev_type)
--
1.8.3.1