* Tue Aug 20 2019 Danilo Cesar Lemes de Paula <ddepaula@redhat.com> - 4.1.0-4.el8
- kvm-RHEL-disable-hostmem-memfd.patch [bz#1738626 bz#1740797] - Resolves: bz#1738626 (Disable memfd in QEMU) - Resolves: bz#1740797 (Disable memfd in QEMU)
This commit is contained in:
parent
4312e9a495
commit
9d9148b01f
56
kvm-RHEL-disable-hostmem-memfd.patch
Normal file
56
kvm-RHEL-disable-hostmem-memfd.patch
Normal file
@ -0,0 +1,56 @@
|
|||||||
|
From f7587ddb9a2731bf678a24156b6285dda79a4b2b Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
|
||||||
|
Date: Mon, 19 Aug 2019 21:18:27 -0300
|
||||||
|
Subject: [PATCH] RHEL: disable hostmem-memfd
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
RH-Author: Marc-André Lureau <marcandre.lureau@redhat.com>
|
||||||
|
Message-id: <20190814085210.18462-1-marcandre.lureau@redhat.com>
|
||||||
|
Patchwork-id: 89974
|
||||||
|
O-Subject: [RHEL-8.1.0 qemu-kvm PATCH] RHEL: disable hostmem-memfd
|
||||||
|
Bugzilla: 1738626 1740797
|
||||||
|
RH-Acked-by: Stefan Hajnoczi <stefanha@redhat.com>
|
||||||
|
RH-Acked-by: Philippe Mathieu-Daudé <philmd@redhat.com>
|
||||||
|
RH-Acked-by: John Snow <jsnow@redhat.com>
|
||||||
|
|
||||||
|
BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1740797
|
||||||
|
BRANCH: rhel8/rhel-8.1.0
|
||||||
|
UPSTREAM: n/a (downstream only)
|
||||||
|
BREW: 23060214
|
||||||
|
|
||||||
|
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
||||||
|
Signed-off-by: Danilo C. L. de Paula <ddepaula@redhat.com>
|
||||||
|
---
|
||||||
|
backends/Makefile.objs | 3 ++-
|
||||||
|
util/memfd.c | 2 +-
|
||||||
|
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/backends/Makefile.objs b/backends/Makefile.objs
|
||||||
|
index 981e8e1..ad54cd6 100644
|
||||||
|
--- a/backends/Makefile.objs
|
||||||
|
+++ b/backends/Makefile.objs
|
||||||
|
@@ -16,4 +16,5 @@ endif
|
||||||
|
|
||||||
|
common-obj-$(call land,$(CONFIG_VHOST_USER),$(CONFIG_VIRTIO)) += vhost-user.o
|
||||||
|
|
||||||
|
-common-obj-$(CONFIG_LINUX) += hostmem-memfd.o
|
||||||
|
+# RHEL: disable memfd
|
||||||
|
+# common-obj-$(CONFIG_LINUX) += hostmem-memfd.o
|
||||||
|
diff --git a/util/memfd.c b/util/memfd.c
|
||||||
|
index 00334e5..e2320af 100644
|
||||||
|
--- a/util/memfd.c
|
||||||
|
+++ b/util/memfd.c
|
||||||
|
@@ -193,7 +193,7 @@ bool qemu_memfd_alloc_check(void)
|
||||||
|
*/
|
||||||
|
bool qemu_memfd_check(unsigned int flags)
|
||||||
|
{
|
||||||
|
-#ifdef CONFIG_LINUX
|
||||||
|
+#if 0 /* RHEL: memfd support disabled */
|
||||||
|
int mfd = memfd_create("test", flags | MFD_CLOEXEC);
|
||||||
|
|
||||||
|
if (mfd >= 0) {
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
@ -67,7 +67,7 @@ Obsoletes: %1-rhev
|
|||||||
Summary: QEMU is a machine emulator and virtualizer
|
Summary: QEMU is a machine emulator and virtualizer
|
||||||
Name: qemu-kvm
|
Name: qemu-kvm
|
||||||
Version: 4.1.0
|
Version: 4.1.0
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
# Epoch because we pushed a qemu-1.0 package. AIUI this can't ever be dropped
|
# Epoch because we pushed a qemu-1.0 package. AIUI this can't ever be dropped
|
||||||
Epoch: 15
|
Epoch: 15
|
||||||
License: GPLv2 and GPLv2+ and CC-BY
|
License: GPLv2 and GPLv2+ and CC-BY
|
||||||
@ -133,6 +133,9 @@ Patch24: kvm-x86-machine-types-add-pc-q35-rhel8.1.0.patch
|
|||||||
Patch25: kvm-machine-types-Update-hw_compat_rhel_8_0-from-hw_comp.patch
|
Patch25: kvm-machine-types-Update-hw_compat_rhel_8_0-from-hw_comp.patch
|
||||||
# For bz#1719649 - 8.1 machine type for x86
|
# For bz#1719649 - 8.1 machine type for x86
|
||||||
Patch26: kvm-virtio-Make-disable-legacy-disable-modern-compat-pro.patch
|
Patch26: kvm-virtio-Make-disable-legacy-disable-modern-compat-pro.patch
|
||||||
|
# For bz#1738626 - Disable memfd in QEMU
|
||||||
|
# For bz#1740797 - Disable memfd in QEMU
|
||||||
|
Patch27: kvm-RHEL-disable-hostmem-memfd.patch
|
||||||
|
|
||||||
BuildRequires: wget
|
BuildRequires: wget
|
||||||
BuildRequires: rpm-build
|
BuildRequires: rpm-build
|
||||||
@ -1074,6 +1077,13 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 20 2019 Danilo Cesar Lemes de Paula <ddepaula@redhat.com> - 4.1.0-4.el8
|
||||||
|
- kvm-RHEL-disable-hostmem-memfd.patch [bz#1738626 bz#1740797]
|
||||||
|
- Resolves: bz#1738626
|
||||||
|
(Disable memfd in QEMU)
|
||||||
|
- Resolves: bz#1740797
|
||||||
|
(Disable memfd in QEMU)
|
||||||
|
|
||||||
* Mon Aug 19 2019 Danilo Cesar Lemes de Paula <ddepaula@redhat.com> - 4.1.0-3.el8
|
* Mon Aug 19 2019 Danilo Cesar Lemes de Paula <ddepaula@redhat.com> - 4.1.0-3.el8
|
||||||
- kvm-x86-machine-types-pc_rhel_8_0_compat.patch [bz#1719649]
|
- kvm-x86-machine-types-pc_rhel_8_0_compat.patch [bz#1719649]
|
||||||
- kvm-x86-machine-types-q35-Fixup-units_per_default_bus.patch [bz#1719649]
|
- kvm-x86-machine-types-q35-Fixup-units_per_default_bus.patch [bz#1719649]
|
||||||
|
Loading…
Reference in New Issue
Block a user