- Update to new version.
This commit is contained in:
parent
72e5637ea6
commit
fc72d4c4a3
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ qdox-1.6.1-src.tar.gz
|
||||
qdox-1.9.2-src.tar.gz
|
||||
qdox-1.10.1.tar.bz2
|
||||
qdox-1.11-project.tar.bz2
|
||||
qdox-1.12-project.tar.bz2
|
||||
|
@ -1,14 +1,16 @@
|
||||
--- pom.xml.sav 2010-03-13 12:43:16.000000000 +0200
|
||||
+++ pom.xml 2010-03-15 17:52:45.147525923 +0200
|
||||
@@ -282,7 +282,7 @@
|
||||
--- pom.xml.sav 2010-06-11 19:17:14.000000000 +0300
|
||||
+++ pom.xml 2010-10-05 22:53:09.146608222 +0300
|
||||
@@ -282,8 +282,8 @@
|
||||
<templateFile>${basedir}/src/site/templates/site-template.vm</templateFile>
|
||||
</configuration>
|
||||
</plugin>
|
||||
- <plugin>
|
||||
- <groupId>org.codehaus.xsite</groupId>
|
||||
+ <!--plugin>
|
||||
<groupId>org.codehaus.xsite</groupId>
|
||||
+ <groupId>org.codehaus.site</groupId>
|
||||
<artifactId>xsite-maven-plugin</artifactId>
|
||||
<version>1.0</version>
|
||||
<configuration>
|
||||
@@ -301,11 +301,11 @@
|
||||
</goals>
|
||||
</execution>
|
||||
@ -23,28 +25,25 @@
|
||||
<execution>
|
||||
<id>pre-copy-resources</id>
|
||||
<phase>pre-site</phase>
|
||||
@@ -352,9 +352,9 @@
|
||||
@@ -352,7 +352,7 @@
|
||||
</resources>
|
||||
</configuration>
|
||||
</execution>
|
||||
- </executions>
|
||||
+ </executions-->
|
||||
</plugin>
|
||||
- <plugin>
|
||||
+ <!--plugin>
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-release-plugin</artifactId>
|
||||
<version>2.0</version>
|
||||
@@ -364,7 +364,7 @@
|
||||
<tagBase>https://svn.codehaus.org/qdox/tags</tagBase>
|
||||
<arguments>-Dproject.rel.org.thoughtworks.qdox:qdox=${project.rel.org.thoughtworks.qdox:qdox} -Dproject.dev.org.thoughtworks.qdox:qdox=${project.dev.org.thoughtworks.qdox:qdox}</arguments>
|
||||
</configuration>
|
||||
- </plugin>
|
||||
+ </plugin-->
|
||||
</plugins>
|
||||
</build>
|
||||
@@ -371,7 +371,7 @@
|
||||
|
||||
@@ -383,12 +383,12 @@
|
||||
<dependencies>
|
||||
<dependency>
|
||||
- <groupId>ant</groupId>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
<artifactId>ant</artifactId>
|
||||
<version>1.5.1</version>
|
||||
<scope>compile</scope>
|
||||
@@ -384,12 +384,12 @@
|
||||
<scope>compile</scope>
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
|
80
qdox.spec
80
qdox.spec
@ -28,21 +28,15 @@
|
||||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
#
|
||||
|
||||
# If you don't want to build with maven, and use straight ant instead,
|
||||
# give rpmbuild option '--without maven'
|
||||
|
||||
%global with_maven 1
|
||||
|
||||
Summary: Extract class/interface/method definitions from sources
|
||||
Name: qdox
|
||||
Version: 1.11
|
||||
Release: 3%{?dist}
|
||||
Version: 1.12
|
||||
Release: 1%{?dist}
|
||||
Epoch: 0
|
||||
License: ASL 2.0
|
||||
URL: http://qdox.codehaus.org/
|
||||
Group: Development/Libraries
|
||||
Source0: http://repository.codehaus.org/com/thoughtworks/qdox/qdox/%{version}/%{name}-%{version}-project.tar.bz2
|
||||
Source1: build.xml.tar.gz
|
||||
Source0: http://repo2.maven.org/maven2/com/thoughtworks/qdox/qdox/%{version}/%{name}-%{version}-project.tar.bz2
|
||||
Patch0: %{name}-disable-xsite.patch
|
||||
|
||||
BuildRequires: jpackage-utils >= 0:1.7.4
|
||||
@ -52,26 +46,25 @@ BuildRequires: ant-junit >= 0:1.6
|
||||
BuildRequires: junit >= 0:3.8.1
|
||||
BuildRequires: byaccj
|
||||
BuildRequires: jflex
|
||||
%if %{with_maven}
|
||||
BuildRequires: maven2 >= 2.0.7
|
||||
BuildRequires: maven2-plugin-ant
|
||||
BuildRequires: maven2-plugin-antrun
|
||||
BuildRequires: maven2-plugin-assembly
|
||||
BuildRequires: maven2-plugin-compiler
|
||||
BuildRequires: maven2-plugin-changes
|
||||
BuildRequires: maven2-plugin-clean
|
||||
BuildRequires: maven-ant-plugin
|
||||
BuildRequires: maven-antrun-plugin
|
||||
BuildRequires: maven-assembly-plugin
|
||||
BuildRequires: maven-compiler-plugin
|
||||
BuildRequires: maven-changes-plugin
|
||||
BuildRequires: maven-clean-plugin
|
||||
BuildRequires: maven-plugin-cobertura
|
||||
BuildRequires: maven2-plugin-dependency
|
||||
BuildRequires: maven2-plugin-deploy
|
||||
BuildRequires: maven2-plugin-install
|
||||
BuildRequires: maven2-plugin-jar
|
||||
BuildRequires: maven2-plugin-javadoc
|
||||
BuildRequires: maven2-plugin-site
|
||||
BuildRequires: maven2-plugin-resources
|
||||
BuildRequires: maven-surefire-maven-plugin
|
||||
BuildRequires: maven-dependency-plugin
|
||||
BuildRequires: maven-deploy-plugin
|
||||
BuildRequires: maven-install-plugin
|
||||
BuildRequires: maven-jar-plugin
|
||||
BuildRequires: maven-javadoc-plugin
|
||||
BuildRequires: maven-site-plugin
|
||||
BuildRequires: maven-resources-plugin
|
||||
BuildRequires: maven-surefire-plugin
|
||||
BuildRequires: maven-surefire-provider-junit
|
||||
BuildRequires: maven-jflex-plugin
|
||||
%endif
|
||||
BuildRequires: maven-release-plugin
|
||||
|
||||
Requires: java >= 1:1.6.0
|
||||
Requires(post): jpackage-utils >= 0:1.7.4
|
||||
@ -110,41 +103,17 @@ ln -s /usr/bin/byaccj bootstrap/yacc.linux
|
||||
ln -s /usr/bin/byaccj bootstrap/yacc.linux.x86_64
|
||||
ln -s $(build-classpath jflex) bootstrap
|
||||
#ln -s $(build-classpath java-cup) bootstrap
|
||||
mkdir -p .m2/repository/JPP/maven2/default_poms
|
||||
tar xzf %{SOURCE1}
|
||||
|
||||
%build
|
||||
%if %{with_maven}
|
||||
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
|
||||
mkdir -p $MAVEN_REPO_LOCAL
|
||||
|
||||
mvn-jpp \
|
||||
-e \
|
||||
-s settings.xml \
|
||||
-Dmaven.test.skip=true \
|
||||
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
|
||||
ant:ant install javadoc:javadoc
|
||||
|
||||
%else
|
||||
mkdir -p src/java/com/thoughtworks/qdox/parser/impl
|
||||
export CLASSPATH=$(build-classpath jmock jflex):target/classes:target/test-classes
|
||||
java JFlex.Main \
|
||||
-d src/java/com/thoughtworks/qdox/parser/impl \
|
||||
src/grammar/lexer.flex
|
||||
pushd src
|
||||
byaccj \
|
||||
-Jnorun \
|
||||
-Jnoconstruct \
|
||||
-Jclass=Parser \
|
||||
-Jsemantic=Value \
|
||||
-Jpackage=com.thoughtworks.qdox.parser.impl \
|
||||
grammar/parser.y
|
||||
popd
|
||||
mv src/Parser.java src/java/com/thoughtworks/qdox/parser/impl
|
||||
#TODO reenable test when jmock is imported
|
||||
ant -Dbuild.sysclasspath=only -Dmaven.test.skip=true -Dmaven.mode.offline=true jar javadoc
|
||||
%endif
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
@ -159,9 +128,9 @@ cp -p target/%{name}-%{version}.jar \
|
||||
|
||||
|
||||
# poms
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/maven2/poms
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
|
||||
install -m 644 pom.xml \
|
||||
$RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP-%{name}.pom
|
||||
$RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{name}.pom
|
||||
|
||||
# javadoc
|
||||
mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||
@ -178,19 +147,22 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%update_maven_depmap
|
||||
|
||||
%files
|
||||
%defattr(0644,root,root,0755)
|
||||
%defattr(-,root,root,-)
|
||||
%doc LICENSE.txt README.txt
|
||||
%{_javadir}/%{name}.jar
|
||||
%{_javadir}/%{name}-%{version}.jar
|
||||
%{_datadir}/maven2/poms/*
|
||||
%{_mavenpomdir}/*
|
||||
%{_mavendepmapfragdir}/*
|
||||
|
||||
%files javadoc
|
||||
%defattr(0644,root,root,0755)
|
||||
%defattr(-,root,root,-)
|
||||
%doc %{_javadocdir}/%{name}-%{version}
|
||||
%doc %{_javadocdir}/%{name}
|
||||
|
||||
%changelog
|
||||
* Tue Oct 5 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.12-1
|
||||
- Update to new version.
|
||||
|
||||
* Mon Jun 7 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.11-3
|
||||
- Make sure to remove all yacc executables.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user