Update to upstream 1.10.1.
This commit is contained in:
parent
04145628d7
commit
ecd6cb5114
@ -1,2 +1,3 @@
|
||||
qdox-1.6.1-src.tar.gz
|
||||
qdox-1.9.2-src.tar.gz
|
||||
qdox-1.10.1.tar.bz2
|
||||
|
61
qdox-disable-xsite.patch
Normal file
61
qdox-disable-xsite.patch
Normal file
@ -0,0 +1,61 @@
|
||||
--- pom.xml.sav 2009-12-31 18:37:19.000000000 +0200
|
||||
+++ pom.xml 2010-01-08 16:26:05.294855545 +0200
|
||||
@@ -264,7 +264,7 @@
|
||||
<templateFile>${basedir}/src/site/templates/site-template.vm</templateFile>
|
||||
</configuration>
|
||||
</plugin>
|
||||
- <plugin>
|
||||
+ <!--<plugin>
|
||||
<groupId>org.codehaus.xsite</groupId>
|
||||
<artifactId>xsite-maven-plugin</artifactId>
|
||||
<version>1.0</version>
|
||||
@@ -283,11 +283,11 @@
|
||||
</goals>
|
||||
</execution>
|
||||
</executions>
|
||||
- </plugin>
|
||||
+ </plugin>-->
|
||||
<plugin>
|
||||
<artifactId>maven-resources-plugin</artifactId>
|
||||
<version>2.3</version>
|
||||
- <executions>
|
||||
+ <!--executions>
|
||||
<execution>
|
||||
<id>pre-copy-resources</id>
|
||||
<phase>pre-site</phase>
|
||||
@@ -332,9 +332,9 @@
|
||||
</resources>
|
||||
</configuration>
|
||||
</execution>
|
||||
- </executions>
|
||||
+ </executions-->
|
||||
</plugin>
|
||||
- <plugin>
|
||||
+ <!--plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-release-plugin</artifactId>
|
||||
<version>2.0-beta-9</version>
|
||||
@@ -344,7 +344,7 @@
|
||||
<goals>deploy</goals>
|
||||
<tagBase>https://svn.codehaus.org/qdox/tags</tagBase>
|
||||
</configuration>
|
||||
- </plugin>
|
||||
+ </plugin-->
|
||||
</plugins>
|
||||
</build>
|
||||
|
||||
@@ -363,12 +363,12 @@
|
||||
<scope>compile</scope>
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
- <dependency>
|
||||
+ <!--dependency>
|
||||
<groupId>jmock</groupId>
|
||||
<artifactId>jmock</artifactId>
|
||||
<version>1.0.0</version>
|
||||
<scope>test</scope>
|
||||
- </dependency>
|
||||
+ </dependency-->
|
||||
</dependencies>
|
||||
|
||||
<distributionManagement>
|
65
qdox.spec
65
qdox.spec
@ -31,27 +31,28 @@
|
||||
# If you don't want to build with maven, and use straight ant instead,
|
||||
# give rpmbuild option '--without maven'
|
||||
|
||||
%define with_maven 0
|
||||
%define without_maven 1
|
||||
%define with_maven 1
|
||||
|
||||
%define section free
|
||||
|
||||
Summary: Extract class/interface/method definitions from sources
|
||||
Name: qdox
|
||||
Version: 1.9.2
|
||||
Release: 2%{?dist}
|
||||
Version: 1.10.1
|
||||
Release: 1%{?dist}
|
||||
Epoch: 0
|
||||
License: ASL 2.0
|
||||
URL: http://qdox.codehaus.org/
|
||||
Group: Development/Libraries
|
||||
Source0: %{name}-%{version}-src.tar.gz
|
||||
# svn export http://svn.codehaus.org/qdox/tags/qdox-1.8/
|
||||
Source0: %{name}-%{version}.tar.bz2
|
||||
# svn export http://svn.codehaus.org/qdox/tags/qdox-1.10.1/
|
||||
# tar cjf qdox-1.10.1.tar.bz2 qdox-1.10.1/
|
||||
|
||||
Source1: build.xml.tar.gz
|
||||
Source2: qdox-settings.xml
|
||||
Patch0: %{name}-disable-xsite.patch
|
||||
|
||||
BuildRequires: jpackage-utils >= 0:1.7.4
|
||||
BuildRequires: java-devel = 0:1.5.0
|
||||
BuildRequires: java-devel >= 1:1.6.0
|
||||
BuildRequires: ant >= 0:1.6
|
||||
BuildRequires: ant-junit >= 0:1.6
|
||||
BuildRequires: junit >= 0:3.8.1
|
||||
@ -62,23 +63,30 @@ BuildRequires: maven2 >= 2.0.7
|
||||
BuildRequires: maven2-plugin-ant
|
||||
BuildRequires: maven2-plugin-antrun
|
||||
BuildRequires: maven2-plugin-compiler
|
||||
BuildRequires: maven2-plugin-changes
|
||||
BuildRequires: maven2-plugin-clean
|
||||
BuildRequires: maven-plugin-cobertura
|
||||
BuildRequires: maven2-plugin-dependency
|
||||
BuildRequires: maven2-plugin-deploy
|
||||
BuildRequires: maven2-plugin-install
|
||||
BuildRequires: maven2-plugin-jar
|
||||
BuildRequires: maven2-plugin-javadoc
|
||||
BuildRequires: maven2-plugin-release
|
||||
BuildRequires: maven2-plugin-site
|
||||
BuildRequires: maven2-plugin-resources
|
||||
BuildRequires: maven2-plugin-surefire
|
||||
BuildRequires: jmock >= 0:1.0
|
||||
BuildRequires: maven-surefire-maven-plugin
|
||||
BuildRequires: maven-surefire-provider-junit
|
||||
BuildRequires: maven-jflex-plugin
|
||||
%endif
|
||||
|
||||
Requires: java >= 0:1.5.0
|
||||
Requires: java >= 1:1.6.0
|
||||
Requires(post): jpackage-utils >= 0:1.7.4
|
||||
Requires(postun): jpackage-utils >= 0:1.7.4
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
||||
|
||||
Obsoletes: qdox-manual <= 0:1.9.2
|
||||
|
||||
|
||||
%description
|
||||
QDox is a high speed, small footprint parser
|
||||
@ -92,19 +100,12 @@ Summary: Javadoc for %{name}
|
||||
Group: Documentation
|
||||
|
||||
%description javadoc
|
||||
%{summary}.
|
||||
API docs for %{name}.
|
||||
|
||||
%if %{with_maven}
|
||||
%package manual
|
||||
Summary: Documents for %{name}
|
||||
Group: Documentation
|
||||
|
||||
%description manual
|
||||
%{summary}.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%setup -q
|
||||
%patch0 -b .sav
|
||||
for j in $(find . -name "*.jar"); do
|
||||
mv $j $j.no
|
||||
done
|
||||
@ -131,6 +132,7 @@ mkdir -p $MAVEN_REPO_LOCAL
|
||||
mvn-jpp \
|
||||
-e \
|
||||
-s settings.xml \
|
||||
-Dmaven.test.skip=true \
|
||||
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
|
||||
ant:ant install javadoc:javadoc
|
||||
|
||||
@ -174,17 +176,9 @@ install -m 644 pom.xml \
|
||||
|
||||
# javadoc
|
||||
mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||
cp -pr target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||
cp -pr target/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||
ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||
|
||||
# manual
|
||||
mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
|
||||
cp LICENSE.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
|
||||
%if %{with_maven}
|
||||
rm -rf target/site/apidocs
|
||||
cp -pr target/site $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
|
||||
%endif
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
@ -196,7 +190,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files
|
||||
%defattr(0644,root,root,0755)
|
||||
%doc %{_docdir}/%{name}-%{version}/LICENSE.txt
|
||||
%doc LICENSE.txt README.txt
|
||||
%{_javadir}/%{name}.jar
|
||||
%{_javadir}/%{name}-%{version}.jar
|
||||
%{_datadir}/maven2/poms/*
|
||||
@ -207,13 +201,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc %{_javadocdir}/%{name}-%{version}
|
||||
%doc %{_javadocdir}/%{name}
|
||||
|
||||
%if %{with_maven}
|
||||
%files manual
|
||||
%defattr(0644,root,root,0755)
|
||||
%doc %{_docdir}/%{name}-%{version}/site
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Jan 14 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.10.1-1
|
||||
- Update to upstream 1.10.1.
|
||||
|
||||
* Sat Sep 19 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.9.2-2
|
||||
- Remove not needed sources.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user