auto-import qdox-1.5-2jpp.1 on branch devel from qdox-1.5-2jpp.1.src.rpm
This commit is contained in:
parent
dfdc4b8a0b
commit
e227c9df55
@ -0,0 +1 @@
|
|||||||
|
qdox-1.5-src.tar.gz
|
15
qdox-1.5-parser_y.patch
Normal file
15
qdox-1.5-parser_y.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
--- src/grammar/parser.y.sav 2004-06-20 02:12:18.000000000 +0200
|
||||||
|
+++ src/grammar/parser.y 2005-11-16 08:54:40.000000000 +0100
|
||||||
|
@@ -118,10 +118,9 @@
|
||||||
|
};
|
||||||
|
|
||||||
|
classdefinition:
|
||||||
|
- { line = lexer.getLine(); } modifiers classorinterface IDENTIFIER typeparams extends implements {
|
||||||
|
- cls.lineNumber = line;
|
||||||
|
+ modifiers classorinterface IDENTIFIER typeparams extends implements {
|
||||||
|
cls.modifiers.addAll(modifiers); modifiers.clear();
|
||||||
|
- cls.name = $4;
|
||||||
|
+ cls.name = $3;
|
||||||
|
builder.beginClass(cls);
|
||||||
|
cls = new ClassDef();
|
||||||
|
};
|
7
qdox-LocatedDef.java
Normal file
7
qdox-LocatedDef.java
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
package com.thoughtworks.qdox.parser.structs;
|
||||||
|
|
||||||
|
public class LocatedDef {
|
||||||
|
|
||||||
|
public int lineNumber;
|
||||||
|
|
||||||
|
}
|
135
qdox-build.xml
Normal file
135
qdox-build.xml
Normal file
@ -0,0 +1,135 @@
|
|||||||
|
<project name="qdox" default="main">
|
||||||
|
|
||||||
|
<!-- user customisation -->
|
||||||
|
<property file="config.properties"/>
|
||||||
|
|
||||||
|
<property name="name" value="qdox"/>
|
||||||
|
<property name="yacc.exe" value="/usr/bin/byaccj"/>
|
||||||
|
|
||||||
|
<!-- <taskdef name="mockmaker" classname="mockmaker.AntTask">
|
||||||
|
|
||||||
|
<classpath>
|
||||||
|
<fileset dir="bootstrap"/>
|
||||||
|
</classpath>
|
||||||
|
</taskdef> -->
|
||||||
|
|
||||||
|
<target name="generate-check">
|
||||||
|
<uptodate property="generate.skip"
|
||||||
|
targetfile="build/java/com/thoughtworks/qdox/parser/impl/Parser.java" >
|
||||||
|
<srcfiles dir="src/grammar"/>
|
||||||
|
</uptodate>
|
||||||
|
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<target name="generate" description="Perform code generation"
|
||||||
|
depends="generate-check" unless="generate.skip">
|
||||||
|
<!-- Generate Lexer -->
|
||||||
|
<echo>**** Generating Lexer ****</echo>
|
||||||
|
<mkdir dir="build/java/com/thoughtworks/qdox/parser/impl"/>
|
||||||
|
<!-- <java classpath="bootstrap/jflex.jar" classname="JFlex.Main" fork="yes"> -->
|
||||||
|
<java classpath="/usr/share/java/jflex.jar" classname="JFlex.Main" fork="yes">
|
||||||
|
<arg value="-d"/>
|
||||||
|
<arg value="build/java/com/thoughtworks/qdox/parser/impl"/>
|
||||||
|
|
||||||
|
<arg value="src/grammar/lexer.flex"/>
|
||||||
|
</java>
|
||||||
|
|
||||||
|
<!-- Generate Parser -->
|
||||||
|
<echo>**** Generating Parser ****</echo>
|
||||||
|
<exec executable="${yacc.exe}" dir="build">
|
||||||
|
<arg value="-Jnorun"/>
|
||||||
|
<arg value="-Jnoconstruct"/>
|
||||||
|
<arg value="-Jclass=Parser"/>
|
||||||
|
|
||||||
|
<arg value="-Jsemantic=Value"/>
|
||||||
|
<arg value="-Jpackage=com.thoughtworks.qdox.parser.impl"/>
|
||||||
|
<arg value="../src/grammar/parser.y"/>
|
||||||
|
</exec>
|
||||||
|
<move todir="build/java/com/thoughtworks/qdox/parser/impl" file="build/Parser.java"/>
|
||||||
|
|
||||||
|
<!-- Generate Mock Objects -->
|
||||||
|
<echo>**** Generating Mock Objects ****</echo>
|
||||||
|
<mkdir dir="build/test"/>
|
||||||
|
|
||||||
|
<!-- <mockmaker srcdir="src/java" destdir="build/test"/> -->
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<target name="compile" depends="generate" description="Compile Java">
|
||||||
|
<mkdir dir="build/classes"/>
|
||||||
|
<depend srcdir="src/java;build/java"
|
||||||
|
destdir="build/classes" />
|
||||||
|
<javac srcdir="src/java;build/java"
|
||||||
|
destdir="build/classes"
|
||||||
|
debug="true"/>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<target name="test" depends="compile" description="Compile and run tests">
|
||||||
|
|
||||||
|
<mkdir dir="build/test-classes"/>
|
||||||
|
<mkdir dir="lib"/>
|
||||||
|
<depend srcdir="src/test;build/test"
|
||||||
|
destdir="build/test-classes">
|
||||||
|
<classpath id="test.build.classpath">
|
||||||
|
<fileset dir="lib"/>
|
||||||
|
<pathelement path="build/classes"/>
|
||||||
|
</classpath>
|
||||||
|
</depend>
|
||||||
|
<javac srcdir="src/test;build/test"
|
||||||
|
destdir="build/test-classes"
|
||||||
|
debug="true">
|
||||||
|
<classpath refid="test.build.classpath" />
|
||||||
|
|
||||||
|
</javac>
|
||||||
|
<java classname="junit.textui.TestRunner" fork="yes">
|
||||||
|
<classpath>
|
||||||
|
<fileset dir="lib"/>
|
||||||
|
<pathelement location="/usr/share/java/junit.jar"/>
|
||||||
|
<pathelement path="build/classes"/>
|
||||||
|
<pathelement path="build/test-classes"/>
|
||||||
|
</classpath>
|
||||||
|
<arg value="com.thoughtworks.qdox.FullTestSuite"/>
|
||||||
|
</java>
|
||||||
|
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<target name="jar" depends="compile" description="Generate redistributable jar">
|
||||||
|
<mkdir dir="build/classes-dist"/>
|
||||||
|
<javac srcdir="src/java;build/java" destdir="build/classes-dist" debug="false" optimize="true" />
|
||||||
|
<jar jarfile="build/${name}.jar">
|
||||||
|
<fileset dir="build/classes-dist"/>
|
||||||
|
</jar>
|
||||||
|
<echo>Generated build/${name}.jar</echo>
|
||||||
|
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<target name="javadoc" description="o Generate javadoc">
|
||||||
|
<mkdir dir="build/javadocdir">
|
||||||
|
</mkdir>
|
||||||
|
<tstamp>
|
||||||
|
<format pattern="2002-yyyy" property="year">
|
||||||
|
</format>
|
||||||
|
</tstamp>
|
||||||
|
<property name="copyright" value="Copyright &copy; ThoughtWorks, Inc. All Rights Reserved.">
|
||||||
|
</property>
|
||||||
|
<property name="title" value="QDox 1.5 API">
|
||||||
|
</property>
|
||||||
|
<javadoc use="true" private="true" destdir="build/javadocdir" author="true" version="true" sourcepath="src/java" packagenames="com.thoughtworks.qdox.*">
|
||||||
|
<classpath>
|
||||||
|
<fileset dir="build">
|
||||||
|
<include name="*.jar">
|
||||||
|
</include>
|
||||||
|
</fileset>
|
||||||
|
<pathelement location="${defaulttargetdir}/${final.name}.jar">
|
||||||
|
</pathelement>
|
||||||
|
</classpath>
|
||||||
|
</javadoc>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<target name="main" depends="jar,test" description="Build jar and run unit tests."/>
|
||||||
|
|
||||||
|
|
||||||
|
<target name="clean" description="Clean up built files">
|
||||||
|
<delete dir="build"/>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
</project>
|
141
qdox.spec
Normal file
141
qdox.spec
Normal file
@ -0,0 +1,141 @@
|
|||||||
|
# Copyright (c) 2000-2005, JPackage Project
|
||||||
|
# All rights reserved.
|
||||||
|
#
|
||||||
|
# Redistribution and use in source and binary forms, with or without
|
||||||
|
# modification, are permitted provided that the following conditions
|
||||||
|
# are met:
|
||||||
|
#
|
||||||
|
# 1. Redistributions of source code must retain the above copyright
|
||||||
|
# notice, this list of conditions and the following disclaimer.
|
||||||
|
# 2. Redistributions in binary form must reproduce the above copyright
|
||||||
|
# notice, this list of conditions and the following disclaimer in the
|
||||||
|
# documentation and/or other materials provided with the
|
||||||
|
# distribution.
|
||||||
|
# 3. Neither the name of the JPackage Project nor the names of its
|
||||||
|
# contributors may be used to endorse or promote products derived
|
||||||
|
# from this software without specific prior written permission.
|
||||||
|
#
|
||||||
|
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||||
|
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||||
|
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
||||||
|
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
||||||
|
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||||
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||||
|
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
||||||
|
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
||||||
|
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
||||||
|
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
||||||
|
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
#
|
||||||
|
|
||||||
|
Summary: Extract class/interface/method definitions from sources
|
||||||
|
Name: qdox
|
||||||
|
Version: 1.5
|
||||||
|
Release: 2jpp.1%{?dist}
|
||||||
|
Epoch: 0
|
||||||
|
License: Apache Software License style
|
||||||
|
URL: http://qdox.codehaus.org/
|
||||||
|
Group: Development/Libraries/Java
|
||||||
|
Source0: qdox-1.5-src.tar.gz
|
||||||
|
#svn export http://svn.codehaus.org/qdox/tags/QDOX_1_5/qdox/
|
||||||
|
#tar czvf qdox-1.5-src.tar.gz qdox
|
||||||
|
Source1: qdox-build.xml
|
||||||
|
Source2: qdox-LocatedDef.java
|
||||||
|
Patch0: qdox-1.5-parser_y.patch
|
||||||
|
BuildRequires: jpackage-utils >= 0:1.6
|
||||||
|
BuildRequires: ant >= 0:1.6
|
||||||
|
BuildRequires: ant-junit >= 0:1.6
|
||||||
|
BuildRequires: ant-nodeps >= 0:1.6
|
||||||
|
BuildRequires: junit >= 0:3.8.1
|
||||||
|
BuildRequires: jflex
|
||||||
|
BuildRequires: byaccj
|
||||||
|
Requires: jpackage-utils
|
||||||
|
Requires: java
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
%description
|
||||||
|
QDox is a high speed, small footprint parser
|
||||||
|
for extracting class/interface/method definitions
|
||||||
|
from source files complete with JavaDoc @tags.
|
||||||
|
It is designed to be used by active code
|
||||||
|
generators or documentation tools.
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Summary: Javadoc for %{name}
|
||||||
|
Group: Development/Documentation
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}
|
||||||
|
cp %{SOURCE2} src/java/com/thoughtworks/qdox/parser/structs/LocatedDef.java
|
||||||
|
cp %{SOURCE1} build.xml
|
||||||
|
|
||||||
|
%patch0 -b .sav
|
||||||
|
#Remove files which needed jmock
|
||||||
|
rm src/test/com/thoughtworks/qdox/parser/MockBuilder.java
|
||||||
|
rm src/test/com/thoughtworks/qdox/parser/MockLexer.java
|
||||||
|
rm src/test/com/thoughtworks/qdox/parser/ParserTest.java
|
||||||
|
rm src/test/com/thoughtworks/qdox/directorywalker/DirectoryScannerTest.java
|
||||||
|
|
||||||
|
%build
|
||||||
|
export CLASSPATH=$(build-classpath \
|
||||||
|
ant \
|
||||||
|
ant-launcher \
|
||||||
|
junit)
|
||||||
|
CLASSPATH=target/classes:target/test-classes:$CLASSPATH
|
||||||
|
ant jar javadoc
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
# jars
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_javadir}
|
||||||
|
cp -p build/%{name}.jar \
|
||||||
|
$RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
|
||||||
|
(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; \
|
||||||
|
do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
|
||||||
|
|
||||||
|
# javadoc
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||||
|
cp -pr build/javadocdir/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||||
|
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(0644,root,root,0755)
|
||||||
|
%doc LICENSE.txt README.txt
|
||||||
|
%{_javadir}/%{name}.jar
|
||||||
|
%{_javadir}/%{name}-%{version}.jar
|
||||||
|
|
||||||
|
%files javadoc
|
||||||
|
%defattr(0644,root,root,0755)
|
||||||
|
%doc %{_javadocdir}/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Feb 15 2007 Permaine Cheung <pcheung@redhat.com> - 0:1.5-2jpp.1
|
||||||
|
- Use ant for building, and fixes as per fedora guidelines.
|
||||||
|
|
||||||
|
* Mon Feb 20 2006 Ralph Apel <r.apel at r-apel.de> - 0:1.5-2jpp
|
||||||
|
- Rebuild for JPP-1.7, adapting to maven-1.1
|
||||||
|
|
||||||
|
* Wed Nov 16 2005 Ralph Apel <r.apel at r-apel.de> - 0:1.5-1jpp
|
||||||
|
- Upgrade to 1.5
|
||||||
|
- Build is now done with maven and requires jflex and byaccj
|
||||||
|
|
||||||
|
* Wed Aug 25 2004 Fernando Nasser <fnasser@redhat.com> - 0:1.4-3jpp
|
||||||
|
- Rebuild with Ant 1.6.2
|
||||||
|
|
||||||
|
* Fri Aug 06 2004 Ralph Apel <r.apel at r-apel.de> - 0:1.4-2jpp
|
||||||
|
- Upgrade to ant-1.6.X
|
||||||
|
|
||||||
|
* Mon Jun 07 2004 Ralph Apel <r.apel at r-apel.de> - 0:1.4-1jpp
|
||||||
|
- Upgrade to 1.4
|
||||||
|
- Drop Requires: mockobjects (Build/Test only)
|
||||||
|
|
||||||
|
* Tue Feb 24 2004 Ralph Apel <r.apel at r-apel.de> - 0:1.3-1jpp
|
||||||
|
- First JPackage release
|
Loading…
Reference in New Issue
Block a user