Run jflex manually before Maven build is started
- Resolves: rhbz#879653
This commit is contained in:
parent
bbaf8229e5
commit
ccadbd6e7f
@ -1,60 +0,0 @@
|
|||||||
--- pom.xml.sav 2010-06-11 19:17:14.000000000 +0300
|
|
||||||
+++ pom.xml 2010-10-05 22:53:09.146608222 +0300
|
|
||||||
@@ -282,8 +282,8 @@
|
|
||||||
<templateFile>${basedir}/src/site/templates/site-template.vm</templateFile>
|
|
||||||
</configuration>
|
|
||||||
</plugin>
|
|
||||||
- <plugin>
|
|
||||||
- <groupId>org.codehaus.xsite</groupId>
|
|
||||||
+ <!--plugin>
|
|
||||||
+ <groupId>org.codehaus.site</groupId>
|
|
||||||
<artifactId>xsite-maven-plugin</artifactId>
|
|
||||||
<version>1.0</version>
|
|
||||||
<configuration>
|
|
||||||
@@ -301,11 +301,11 @@
|
|
||||||
</goals>
|
|
||||||
</execution>
|
|
||||||
</executions>
|
|
||||||
- </plugin>
|
|
||||||
+ </plugin-->
|
|
||||||
<plugin>
|
|
||||||
<artifactId>maven-resources-plugin</artifactId>
|
|
||||||
<version>2.3</version>
|
|
||||||
- <executions>
|
|
||||||
+ <!--executions>
|
|
||||||
<execution>
|
|
||||||
<id>pre-copy-resources</id>
|
|
||||||
<phase>pre-site</phase>
|
|
||||||
@@ -352,7 +352,7 @@
|
|
||||||
</resources>
|
|
||||||
</configuration>
|
|
||||||
</execution>
|
|
||||||
- </executions>
|
|
||||||
+ </executions-->
|
|
||||||
</plugin>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.apache.maven.plugins</groupId>
|
|
||||||
@@ -371,7 +371,7 @@
|
|
||||||
|
|
||||||
<dependencies>
|
|
||||||
<dependency>
|
|
||||||
- <groupId>ant</groupId>
|
|
||||||
+ <groupId>org.apache.ant</groupId>
|
|
||||||
<artifactId>ant</artifactId>
|
|
||||||
<version>1.5.1</version>
|
|
||||||
<scope>compile</scope>
|
|
||||||
@@ -384,12 +384,12 @@
|
|
||||||
<scope>compile</scope>
|
|
||||||
<optional>true</optional>
|
|
||||||
</dependency>
|
|
||||||
- <dependency>
|
|
||||||
+ <!--dependency>
|
|
||||||
<groupId>jmock</groupId>
|
|
||||||
<artifactId>jmock</artifactId>
|
|
||||||
<version>1.0.0</version>
|
|
||||||
<scope>test</scope>
|
|
||||||
- </dependency>
|
|
||||||
+ </dependency-->
|
|
||||||
</dependencies>
|
|
||||||
|
|
||||||
<distributionManagement>
|
|
57
qdox.spec
57
qdox.spec
@ -31,14 +31,13 @@
|
|||||||
Summary: Extract class/interface/method definitions from sources
|
Summary: Extract class/interface/method definitions from sources
|
||||||
Name: qdox
|
Name: qdox
|
||||||
Version: 1.12.1
|
Version: 1.12.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Epoch: 0
|
Epoch: 0
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: http://qdox.codehaus.org/
|
URL: http://qdox.codehaus.org/
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Source0: http://repo2.maven.org/maven2/com/thoughtworks/qdox/qdox/%{version}/%{name}-%{version}-project.tar.bz2
|
Source0: http://repo2.maven.org/maven2/com/thoughtworks/qdox/qdox/%{version}/%{name}-%{version}-project.tar.bz2
|
||||||
Source1: qdox-MANIFEST.MF
|
Source1: qdox-MANIFEST.MF
|
||||||
Patch0: %{name}-disable-xsite.patch
|
|
||||||
|
|
||||||
BuildRequires: jpackage-utils >= 0:1.7.4
|
BuildRequires: jpackage-utils >= 0:1.7.4
|
||||||
BuildRequires: java-devel >= 1:1.6.0
|
BuildRequires: java-devel >= 1:1.6.0
|
||||||
@ -48,8 +47,6 @@ BuildRequires: junit >= 0:3.8.1
|
|||||||
BuildRequires: byaccj
|
BuildRequires: byaccj
|
||||||
BuildRequires: jflex
|
BuildRequires: jflex
|
||||||
BuildRequires: maven
|
BuildRequires: maven
|
||||||
BuildRequires: maven-ant-plugin
|
|
||||||
BuildRequires: maven-antrun-plugin
|
|
||||||
BuildRequires: maven-assembly-plugin
|
BuildRequires: maven-assembly-plugin
|
||||||
BuildRequires: maven-compiler-plugin
|
BuildRequires: maven-compiler-plugin
|
||||||
BuildRequires: maven-changes-plugin
|
BuildRequires: maven-changes-plugin
|
||||||
@ -61,10 +58,8 @@ BuildRequires: maven-install-plugin
|
|||||||
BuildRequires: maven-jar-plugin
|
BuildRequires: maven-jar-plugin
|
||||||
BuildRequires: maven-javadoc-plugin
|
BuildRequires: maven-javadoc-plugin
|
||||||
BuildRequires: maven-site-plugin
|
BuildRequires: maven-site-plugin
|
||||||
BuildRequires: maven-resources-plugin
|
|
||||||
BuildRequires: maven-surefire-plugin
|
BuildRequires: maven-surefire-plugin
|
||||||
BuildRequires: maven-surefire-provider-junit
|
BuildRequires: maven-surefire-provider-junit
|
||||||
BuildRequires: maven-jflex-plugin
|
|
||||||
BuildRequires: maven-release-plugin
|
BuildRequires: maven-release-plugin
|
||||||
BuildRequires: zip
|
BuildRequires: zip
|
||||||
|
|
||||||
@ -92,22 +87,46 @@ API docs for %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -b .sav
|
find -name *.jar -delete
|
||||||
for j in $(find . -name "*.jar"); do
|
rm -rf bootstrap
|
||||||
mv $j $j.no
|
|
||||||
done
|
# Ant changed groupId
|
||||||
rm bootstrap/yacc.*
|
%pom_remove_dep ant:ant
|
||||||
ln -s /usr/bin/byaccj bootstrap/yacc.linux
|
%pom_add_dep org.apache.ant:ant
|
||||||
ln -s /usr/bin/byaccj bootstrap/yacc.linux.x86_64
|
|
||||||
ln -s $(build-classpath jflex) bootstrap
|
# We don't need these plugins
|
||||||
#ln -s $(build-classpath java-cup) bootstrap
|
%pom_remove_plugin :maven-antrun-plugin
|
||||||
|
%pom_remove_plugin :maven-jflex-plugin
|
||||||
|
%pom_remove_plugin :maven-resources-plugin
|
||||||
|
%pom_remove_plugin :xsite-maven-plugin
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
# Generate scanner (upstream does this with maven-jflex-plugin)
|
||||||
|
jflex \
|
||||||
|
-d src/java \
|
||||||
|
--skel src/grammar/skeleton.inner \
|
||||||
|
src/grammar/lexer.flex
|
||||||
|
|
||||||
|
# Generate parser (upstream does this with maven-antrun-plugin)
|
||||||
|
dir=src/java/com/thoughtworks/qdox/parser/impl
|
||||||
|
mkdir -p $dir
|
||||||
|
(cd ./$dir
|
||||||
|
byaccj \
|
||||||
|
-v \
|
||||||
|
-Jnorun \
|
||||||
|
-Jnoconstruct \
|
||||||
|
-Jclass=Parser \
|
||||||
|
-Jsemantic=Value \
|
||||||
|
-Jpackage=com.thoughtworks.qdox.parser.impl \
|
||||||
|
../../../../../../grammar/parser.y)
|
||||||
|
|
||||||
|
# Build artifact
|
||||||
mvn-rpmbuild \
|
mvn-rpmbuild \
|
||||||
-Dmaven.test.skip=true \
|
-Dmaven.test.skip=true \
|
||||||
ant:ant install javadoc:javadoc
|
install \
|
||||||
|
javadoc:aggregate
|
||||||
|
|
||||||
# inject OSGi manifests
|
# Inject OSGi manifests
|
||||||
mkdir -p META-INF
|
mkdir -p META-INF
|
||||||
cp -p %{SOURCE1} META-INF/MANIFEST.MF
|
cp -p %{SOURCE1} META-INF/MANIFEST.MF
|
||||||
touch META-INF/MANIFEST.MF
|
touch META-INF/MANIFEST.MF
|
||||||
@ -139,6 +158,10 @@ cp -pr target/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
|||||||
%doc %{_javadocdir}/%{name}
|
%doc %{_javadocdir}/%{name}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 9 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.12.1-2
|
||||||
|
- Run jflex manually before Maven build is started
|
||||||
|
- Resolves: rhbz#879653
|
||||||
|
|
||||||
* Tue Dec 11 2012 Alexander Kurtakov <akurtako@redhat.com> 0:1.12.1-1
|
* Tue Dec 11 2012 Alexander Kurtakov <akurtako@redhat.com> 0:1.12.1-1
|
||||||
- Update to latest upstream release.
|
- Update to latest upstream release.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user