Rebuild and add support for newer jflex
This commit is contained in:
parent
e227c9df55
commit
73c84ba175
11
qdox-jflex.patch
Normal file
11
qdox-jflex.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/grammar/lexer.flex.orig 2008-02-22 13:10:40.000000000 -0500
|
||||
+++ src/grammar/lexer.flex 2008-02-22 13:10:55.000000000 -0500
|
||||
@@ -38,7 +38,7 @@
|
||||
}
|
||||
|
||||
private void pushState(int newState) {
|
||||
- stateStack[stateDepth++] = yy_lexical_state;
|
||||
+ stateStack[stateDepth++] = zzLexicalState;
|
||||
yybegin(newState);
|
||||
}
|
||||
|
13
qdox.spec
13
qdox.spec
@ -31,7 +31,7 @@
|
||||
Summary: Extract class/interface/method definitions from sources
|
||||
Name: qdox
|
||||
Version: 1.5
|
||||
Release: 2jpp.1%{?dist}
|
||||
Release: 2jpp.2%{?dist}
|
||||
Epoch: 0
|
||||
License: Apache Software License style
|
||||
URL: http://qdox.codehaus.org/
|
||||
@ -42,12 +42,13 @@ Source0: qdox-1.5-src.tar.gz
|
||||
Source1: qdox-build.xml
|
||||
Source2: qdox-LocatedDef.java
|
||||
Patch0: qdox-1.5-parser_y.patch
|
||||
Patch1: qdox-jflex.patch
|
||||
BuildRequires: jpackage-utils >= 0:1.6
|
||||
BuildRequires: ant >= 0:1.6
|
||||
BuildRequires: ant-junit >= 0:1.6
|
||||
BuildRequires: ant-nodeps >= 0:1.6
|
||||
BuildRequires: junit >= 0:3.8.1
|
||||
BuildRequires: jflex
|
||||
BuildRequires: jflex >= 1.4.1
|
||||
BuildRequires: byaccj
|
||||
Requires: jpackage-utils
|
||||
Requires: java
|
||||
@ -70,10 +71,14 @@ Group: Development/Documentation
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
for j in $(find . -name "*.jar"); do mv $j $j.no; done
|
||||
find . -name "*.class" -exec rm {} \;
|
||||
|
||||
cp %{SOURCE2} src/java/com/thoughtworks/qdox/parser/structs/LocatedDef.java
|
||||
cp %{SOURCE1} build.xml
|
||||
|
||||
%patch0 -b .sav
|
||||
%patch1 -b .sav
|
||||
#Remove files which needed jmock
|
||||
rm src/test/com/thoughtworks/qdox/parser/MockBuilder.java
|
||||
rm src/test/com/thoughtworks/qdox/parser/MockLexer.java
|
||||
@ -117,6 +122,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc %{_javadocdir}/*
|
||||
|
||||
%changelog
|
||||
* Fri Feb 22 2008 Matt Wringe <mwringe@redhat.com> - 0:1.5-2jpp.2
|
||||
- add a patch (qdox-flex.patch) so that qdox will build with
|
||||
the new jflex.
|
||||
|
||||
* Thu Feb 15 2007 Permaine Cheung <pcheung@redhat.com> - 0:1.5-2jpp.1
|
||||
- Use ant for building, and fixes as per fedora guidelines.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user