Update to upstream version 2.0-M7
This commit is contained in:
parent
647efb5b77
commit
5a494e9fad
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ qdox-1.12-project.tar.bz2
|
|||||||
/qdox-2.0-M2-project.tar.gz
|
/qdox-2.0-M2-project.tar.gz
|
||||||
/qdox-2.0-M3-project.tar.gz
|
/qdox-2.0-M3-project.tar.gz
|
||||||
/qdox-2.0-M5-project.tar.gz
|
/qdox-2.0-M5-project.tar.gz
|
||||||
|
/qdox-2.0-M7-project.tar.gz
|
||||||
|
@ -1,69 +0,0 @@
|
|||||||
From ca5a50fc69b4b1bb0f640edb8dbaa13c5e90112e Mon Sep 17 00:00:00 2001
|
|
||||||
From: rfscholte <rfscholte@apache.org>
|
|
||||||
Date: Thu, 19 Jan 2017 18:44:38 +0100
|
|
||||||
Subject: [PATCH] #16 Single comment line not recognized
|
|
||||||
|
|
||||||
---
|
|
||||||
src/grammar/lexer.flex | 2 +-
|
|
||||||
.../thoughtworks/qdox/JavaProjectBuilderTest.java | 32 ++++++++++++++++++++++
|
|
||||||
2 files changed, 33 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/grammar/lexer.flex b/src/grammar/lexer.flex
|
|
||||||
index 681f2b8..bd3462c 100644
|
|
||||||
--- a/src/grammar/lexer.flex
|
|
||||||
+++ b/src/grammar/lexer.flex
|
|
||||||
@@ -608,7 +608,7 @@ JavadocEnd = "*"+ "/"
|
|
||||||
\' { if (appendingToCodeBody) { codeBody.append('\''); } pushState(CHAR); }
|
|
||||||
}
|
|
||||||
|
|
||||||
-<ASSIGNMENT, YYINITIAL, CODEBLOCK, PARENBLOCK, ENUM, ANNOTATIONTYPE, ANNOTATION, ARGUMENTS, TYPE> {
|
|
||||||
+<ASSIGNMENT, YYINITIAL, CODEBLOCK, PARENBLOCK, ENUM, ANNOTATIONTYPE, ANNOTATION, ARGUMENTS, TYPE, NAME> {
|
|
||||||
"//" { if (appendingToCodeBody) { codeBody.append("//"); } pushState(SINGLELINECOMMENT); }
|
|
||||||
"/*" { if (appendingToCodeBody) { codeBody.append("/*"); } pushState(MULTILINECOMMENT); }
|
|
||||||
"/**/" { if (appendingToCodeBody) { codeBody.append("/**/"); } }
|
|
||||||
diff --git a/src/test/java/com/thoughtworks/qdox/JavaProjectBuilderTest.java b/src/test/java/com/thoughtworks/qdox/JavaProjectBuilderTest.java
|
|
||||||
index 204a23a..edc6352 100644
|
|
||||||
--- a/src/test/java/com/thoughtworks/qdox/JavaProjectBuilderTest.java
|
|
||||||
+++ b/src/test/java/com/thoughtworks/qdox/JavaProjectBuilderTest.java
|
|
||||||
@@ -1582,6 +1582,38 @@ public class JavaProjectBuilderTest extends TestCase
|
|
||||||
|
|
||||||
assertEquals( "com.fg.rtdoc.test.Iface", clz.getInterfaces().get(0).getFullyQualifiedName() );
|
|
||||||
}
|
|
||||||
+
|
|
||||||
+ // Github #16
|
|
||||||
+ public void testBeanProperties()
|
|
||||||
+ {
|
|
||||||
+ String zothParent = "public class ZothParent {\n" +
|
|
||||||
+ " private String name;\n" +
|
|
||||||
+ " public String getName() {\n" +
|
|
||||||
+ " return name;\n" +
|
|
||||||
+ " }\n" +
|
|
||||||
+ " public void setName(String name) {\n" +
|
|
||||||
+ " this.name = name;\n" +
|
|
||||||
+ " }\n" +
|
|
||||||
+ "}";
|
|
||||||
+
|
|
||||||
+ String zothChild = "public class ZothChild // extends ZothParent\n" +
|
|
||||||
+ "{\n" +
|
|
||||||
+ " private int age;\n" +
|
|
||||||
+ " public int getAge() {\n" +
|
|
||||||
+ " return age;\n" +
|
|
||||||
+ " }\n" +
|
|
||||||
+ " public void setAge(int age) {\n" +
|
|
||||||
+ " this.age = age;\n" +
|
|
||||||
+ " }\n" +
|
|
||||||
+ "}";
|
|
||||||
+
|
|
||||||
+ JavaProjectBuilder builder = new JavaProjectBuilder();
|
|
||||||
+ builder.addSource(new StringReader( zothParent ));
|
|
||||||
+ JavaClass zothClass = builder.addSource(new StringReader( zothChild )).getClassByName( "ZothChild" );
|
|
||||||
+ assertEquals( "java.lang.Object", zothClass.getSuperClass().getBinaryName());
|
|
||||||
+ assertEquals( 2, zothClass.getBeanProperties( true ).size() );
|
|
||||||
+
|
|
||||||
+ }
|
|
||||||
|
|
||||||
public void testDeclarationSignatureWithGenerics() {
|
|
||||||
String source = "import java.util.List;"
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
12
qdox.spec
12
qdox.spec
@ -1,9 +1,9 @@
|
|||||||
%global vertag M5
|
%global vertag M7
|
||||||
|
|
||||||
Summary: Extract class/interface/method definitions from sources
|
Summary: Extract class/interface/method definitions from sources
|
||||||
Name: qdox
|
Name: qdox
|
||||||
Version: 2.0
|
Version: 2.0
|
||||||
Release: 0.9.%{vertag}%{?dist}
|
Release: 0.10.%{vertag}%{?dist}
|
||||||
Epoch: 0
|
Epoch: 0
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: https://github.com/paul-hammant/qdox
|
URL: https://github.com/paul-hammant/qdox
|
||||||
@ -12,9 +12,6 @@ BuildArch: noarch
|
|||||||
Source0: http://repo2.maven.org/maven2/com/thoughtworks/qdox/qdox/%{version}-%{vertag}/%{name}-%{version}-%{vertag}-project.tar.gz
|
Source0: http://repo2.maven.org/maven2/com/thoughtworks/qdox/qdox/%{version}-%{vertag}/%{name}-%{version}-%{vertag}-project.tar.gz
|
||||||
Source1: qdox-MANIFEST.MF
|
Source1: qdox-MANIFEST.MF
|
||||||
|
|
||||||
# https://github.com/paul-hammant/qdox/issues/16
|
|
||||||
Patch1: 0001-16-Single-comment-line-not-recognized.patch
|
|
||||||
|
|
||||||
BuildRequires: byaccj
|
BuildRequires: byaccj
|
||||||
BuildRequires: jflex
|
BuildRequires: jflex
|
||||||
BuildRequires: maven-local
|
BuildRequires: maven-local
|
||||||
@ -44,8 +41,6 @@ API docs for %{name}.
|
|||||||
find -name *.jar -delete
|
find -name *.jar -delete
|
||||||
rm -rf bootstrap
|
rm -rf bootstrap
|
||||||
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
# We don't need these plugins
|
# We don't need these plugins
|
||||||
%pom_remove_plugin :animal-sniffer-maven-plugin
|
%pom_remove_plugin :animal-sniffer-maven-plugin
|
||||||
%pom_remove_plugin :maven-failsafe-plugin
|
%pom_remove_plugin :maven-failsafe-plugin
|
||||||
@ -80,6 +75,9 @@ zip -u target/%{name}-%{version}.jar META-INF/MANIFEST.MF
|
|||||||
%doc LICENSE.txt
|
%doc LICENSE.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 12 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:2.0-0.10.M7
|
||||||
|
- Update to upstream version 2.0-M7
|
||||||
|
|
||||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.0-0.9.M5
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.0-0.9.M5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (qdox-2.0-M5-project.tar.gz) = 0f1e6a0452744130b6f670d572c6da1b4fcbf9479ed44ce8cf19957329a025e7c0d4443e1e3bd367878667ef38d87de1d6c507a3ca215e671e02962032375e6e
|
SHA512 (qdox-2.0-M7-project.tar.gz) = 7fddaf0cc4962c0e94ebf2a470391bf9d05d0f8556de7c1f881c63f130b53e57a024aa8fb920bd0d856ee71d0414c0ab00cb6c6af3dfe0d346479bb108f3fe66
|
||||||
|
Loading…
Reference in New Issue
Block a user