Update to upstream version 2.0.3
This commit is contained in:
parent
41579b6f5a
commit
0c8a788563
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@
|
|||||||
/qdox-2.0-M9.tar.gz
|
/qdox-2.0-M9.tar.gz
|
||||||
/qdox-2.0~M10.tar.gz
|
/qdox-2.0~M10.tar.gz
|
||||||
/qdox-2.0.0.tar.gz
|
/qdox-2.0.0.tar.gz
|
||||||
|
/qdox-2.0.3.tar.gz
|
||||||
|
@ -1,39 +0,0 @@
|
|||||||
From 31f530b26bd4625ffe41aa16c48836455ef81c23 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
|
||||||
Date: Fri, 7 Jun 2019 10:39:34 +0200
|
|
||||||
Subject: [PATCH] Port to JFlex 1.7.0
|
|
||||||
|
|
||||||
---
|
|
||||||
src/grammar/lexer.flex | 2 +-
|
|
||||||
.../java/com/thoughtworks/qdox/library/ClassLoaderLibrary.java | 2 +-
|
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/grammar/lexer.flex b/src/grammar/lexer.flex
|
|
||||||
index 9b567ff..cd9d5b6 100644
|
|
||||||
--- a/src/grammar/lexer.flex
|
|
||||||
+++ b/src/grammar/lexer.flex
|
|
||||||
@@ -168,7 +168,7 @@ import java.util.*;
|
|
||||||
}
|
|
||||||
|
|
||||||
public JFlexLexer( java.io.InputStream stream, java.io.Writer writer ) {
|
|
||||||
- this( stream );
|
|
||||||
+ this( new java.io.InputStreamReader( stream, java.nio.charset.Charset.forName( "UTF-8" ) ) );
|
|
||||||
this.writer = writer;
|
|
||||||
}
|
|
||||||
|
|
||||||
diff --git a/src/main/java/com/thoughtworks/qdox/library/ClassLoaderLibrary.java b/src/main/java/com/thoughtworks/qdox/library/ClassLoaderLibrary.java
|
|
||||||
index c947f9b..5b415c0 100644
|
|
||||||
--- a/src/main/java/com/thoughtworks/qdox/library/ClassLoaderLibrary.java
|
|
||||||
+++ b/src/main/java/com/thoughtworks/qdox/library/ClassLoaderLibrary.java
|
|
||||||
@@ -112,7 +112,7 @@ public class ClassLoaderLibrary
|
|
||||||
if ( sourceStream != null )
|
|
||||||
{
|
|
||||||
Builder builder = getModelBuilder();
|
|
||||||
- JavaLexer lexer = new JFlexLexer( sourceStream );
|
|
||||||
+ JavaLexer lexer = new JFlexLexer( new java.io.InputStreamReader( sourceStream, java.nio.charset.Charset.forName( "UTF-8" ) ) );
|
|
||||||
Parser parser = new Parser( lexer, builder );
|
|
||||||
parser.setDebugLexer( debugLexer );
|
|
||||||
parser.setDebugParser( debugParser );
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
12
qdox.spec
12
qdox.spec
@ -3,8 +3,8 @@
|
|||||||
%global upstream_version %(echo %{version} | tr '~' '-')
|
%global upstream_version %(echo %{version} | tr '~' '-')
|
||||||
|
|
||||||
Name: qdox
|
Name: qdox
|
||||||
Version: 2.0.0
|
Version: 2.0.3
|
||||||
Release: 12%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Extract class/interface/method definitions from sources
|
Summary: Extract class/interface/method definitions from sources
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: https://github.com/paul-hammant/qdox
|
URL: https://github.com/paul-hammant/qdox
|
||||||
@ -17,8 +17,6 @@ Source1: qdox-MANIFEST.MF
|
|||||||
# Remove bundled binaries which are possibly proprietary
|
# Remove bundled binaries which are possibly proprietary
|
||||||
Source2: generate-tarball.sh
|
Source2: generate-tarball.sh
|
||||||
|
|
||||||
Patch0: 0001-Port-to-JFlex-1.7.0.patch
|
|
||||||
|
|
||||||
BuildRequires: byaccj
|
BuildRequires: byaccj
|
||||||
%if %{with bootstrap}
|
%if %{with bootstrap}
|
||||||
BuildRequires: javapackages-bootstrap
|
BuildRequires: javapackages-bootstrap
|
||||||
@ -42,7 +40,6 @@ API docs for %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{upstream_version}
|
%setup -q -n %{name}-%{upstream_version}
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
# remove unnecessary dependency on parent POM
|
# remove unnecessary dependency on parent POM
|
||||||
%pom_remove_parent
|
%pom_remove_parent
|
||||||
@ -52,7 +49,7 @@ API docs for %{name}.
|
|||||||
%pom_remove_plugin :maven-assembly-plugin
|
%pom_remove_plugin :maven-assembly-plugin
|
||||||
%pom_remove_plugin :maven-failsafe-plugin
|
%pom_remove_plugin :maven-failsafe-plugin
|
||||||
%pom_remove_plugin :maven-invoker-plugin
|
%pom_remove_plugin :maven-invoker-plugin
|
||||||
%pom_remove_plugin :maven-jflex-plugin
|
%pom_remove_plugin :jflex-maven-plugin
|
||||||
%pom_remove_plugin :maven-enforcer-plugin
|
%pom_remove_plugin :maven-enforcer-plugin
|
||||||
%pom_remove_plugin :exec-maven-plugin
|
%pom_remove_plugin :exec-maven-plugin
|
||||||
|
|
||||||
@ -89,6 +86,9 @@ jar ufm target/%{name}-%{upstream_version}.jar %{SOURCE1}
|
|||||||
%license LICENSE.txt
|
%license LICENSE.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 17 2023 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.0.3-1
|
||||||
|
- Update to upstream version 2.0.3
|
||||||
|
|
||||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-12
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-12
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (qdox-2.0.0.tar.gz) = 2ea7bd97ca720856a3f61aa12d4ec681708b599fe87c8942ac19e41b59cb56d3583f0953dc280d6244334d19762b7fe0c5693ee7acbaff2a4b421a3c959139b6
|
SHA512 (qdox-2.0.3.tar.gz) = 507365056da084a93531f178461c367f426e3997c3fe7e8010d0e50528c99c5b8045d2fba84653889fdb3e42bff30a8dfb3ca5f22a239fcf095ebaeb6343d64b
|
||||||
|
Loading…
Reference in New Issue
Block a user