- updated to 2.2.1

This commit is contained in:
Dan Horák 2020-10-16 04:59:29 -04:00
parent f9b4669ccb
commit a7f4387128
6 changed files with 9 additions and 97 deletions

1
.gitignore vendored
View File

@ -7,3 +7,4 @@
/qclib-2.0.1.tgz
/qclib-2.1.0.tgz
/qclib-2.2.0.tgz
/qclib-2.2.1.tar.gz

View File

@ -1,25 +0,0 @@
From 881a8f56fb185c5de6e5fe2e60bb68bb4a771939 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 23 Sep 2020 11:58:17 +0200
Subject: [PATCH] add missing check in Makefile
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 39eaf14..0e8bf31 100644
--- a/Makefile
+++ b/Makefile
@@ -73,7 +73,7 @@ html: $(CFILES) query_capacity.h query_capacity_int.h query_capacity_data.h hcpi
else \
echo "Error: 'doxygen' not installed"; \
fi
-
+ -@if which cppcheck >/dev/null 2>&1; then \
cppcheck query_capacity*.[ch] 2>&1 | sed 's/^/ /'; \
else \
echo "cppcheck not available"; \
--
2.26.2

View File

@ -1,35 +0,0 @@
From 88747097f3f6d2512811a7f9045f935e60b3cd44 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 23 Sep 2020 12:14:22 +0200
Subject: [PATCH 2/2] introduce MANDIR in Makefile
---
Makefile | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index 0e8bf31..a3ca5bd 100644
--- a/Makefile
+++ b/Makefile
@@ -13,6 +13,7 @@ CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c \
OBJECTS = $(patsubst %.c,%.o,$(CFILES))
.SUFFIXES: .o .c
DOCDIR ?= /usr/share/doc/packages/
+MANDIR ?= /usr/share/
ifneq ("${V}","1")
MAKEFLAGS += --quiet
@@ -126,8 +127,8 @@ install: libqc.a libqc.so.$(VERSION)
ln -sr $(DESTDIR)/usr/lib64/libqc.so.$(VERSION) $(DESTDIR)/usr/lib64/libqc.so
install -Dm 755 zname $(DESTDIR)/usr/bin/zname
install -Dm 755 zhypinfo $(DESTDIR)/usr/bin/zhypinfo
- install -Dm 644 zname.8 $(DESTDIR)/usr/share/man8/zname.8
- install -Dm 644 zhypinfo.8 $(DESTDIR)/usr/share/man8/zhypinfo.8
+ install -Dm 644 zname.8 $(DESTDIR)/$(MANDIR)/man8/zname.8
+ install -Dm 644 zhypinfo.8 $(DESTDIR)/$(MANDIR)/man8/zhypinfo.8
install -Dm 644 query_capacity.h $(DESTDIR)/usr/include/query_capacity.h
install -Dm 644 README $(DESTDIR)/$(DOCDIR)/qclib/README
install -Dm 644 LICENSE $(DESTDIR)/$(DOCDIR)/qclib/LICENSE
--
2.26.2

View File

@ -1,29 +0,0 @@
From 57c32ddf4435155bd4f3965f4e526e39e858e2bf Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Thu, 24 Sep 2020 14:03:07 +0200
Subject: [PATCH 3/3] use LDFLAGS when linking the tools
---
Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index a3ca5bd..1a26dcd 100644
--- a/Makefile
+++ b/Makefile
@@ -49,10 +49,10 @@ libqc.so.$(VERSION): $(OBJECTS)
ln -s libqc.so.$(VERSION) libqc.so.$(VERM)
zname: zname.c zhypinfo.h libqc.so.$(VERSION)
- $(CC) $(CFLAGS) -L. $< -o $@ libqc.so.$(VERSION)
+ $(CC) $(CFLAGS) $(LDFLAGS) -L. $< -o $@ libqc.so.$(VERSION)
zhypinfo: zhypinfo.c zhypinfo.h libqc.so.$(VERSION)
- $(CC) $(CFLAGS) -L. $< -o $@ libqc.so.$(VERSION)
+ $(CC) $(CFLAGS) $(LDFLAGS) -L. $< -o $@ libqc.so.$(VERSION)
qc_test: qc_test.c libqc.a
$(CC) $(CFLAGS) -static $< -L. -lqc -o $@
--
2.26.2

View File

@ -1,13 +1,10 @@
Name: qclib
Version: 2.2.0
Release: 2%{?dist}
Version: 2.2.1
Release: 1%{?dist}
Summary: Library for extraction of system information for Linux on z Systems
License: BSD
URL: http://www.ibm.com/developerworks/linux/linux390/qclib.html
Source0: http://public.dhe.ibm.com/software/dw/linux390/ht_src/%{name}-%{version}.tgz
Patch0: 0001-add-missing-check-in-Makefile.patch
Patch1: 0002-introduce-MANDIR-in-Makefile.patch
Patch2: 0003-use-LDFLAGS-when-linking-the-tools.patch
Source0: http://public.dhe.ibm.com/software/dw/linux390/ht_src/%{name}-%{version}.tar.gz
ExclusiveArch: s390 s390x
BuildRequires: gcc
BuildRequires: glibc-static
@ -55,7 +52,7 @@ make V=1 CFLAGS="%{build_cflags}" LDFLAGS="%{build_ldflags}" %{?_smp_mflags} all
%install
%make_install DOCDIR=%{_docdir} MANDIR=%{_mandir}
%make_install DOCDIR=%{_docdir}
make DESTDIR=%{buildroot} DOCDIR=%{_docdir} installdoc
@ -83,6 +80,9 @@ make test-sh test
%changelog
* Fri Oct 16 2020 Dan Horák <dan[at]danny.cz> - 2.2.1-1
- updated to 2.2.1
* Thu Sep 24 2020 Dan Horák <dan[at]danny.cz> - 2.2.0-2
- fix linking

View File

@ -1 +1 @@
SHA512 (qclib-2.2.0.tgz) = f364f9583545e362ab4ad9385b8d579143fd26414a742ed980e2fccefb1400875bcf281292d1968736af37d0aba773256c55a428f4e14d4629f6278bdd09c76b
SHA512 (qclib-2.2.1.tar.gz) = b92418089feb7c97c7822b58df444c8bed20ff0ddf30d4fde10c2c22e347c9a0f77c24f8d8c921a862d2e548a8b2e3080b83285e04f2b13f52ac315c438afad4