- updated to 2.2.0

This commit is contained in:
Dan Horák 2020-09-23 12:27:40 +02:00
parent 80505ed892
commit a1a986938d
7 changed files with 74 additions and 97 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@
/qclib-2.0.0.tgz
/qclib-2.0.1.tgz
/qclib-2.1.0.tgz
/qclib-2.2.0.tgz

View File

@ -0,0 +1,25 @@
From 881a8f56fb185c5de6e5fe2e60bb68bb4a771939 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 23 Sep 2020 11:58:17 +0200
Subject: [PATCH] add missing check in Makefile
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 39eaf14..0e8bf31 100644
--- a/Makefile
+++ b/Makefile
@@ -73,7 +73,7 @@ html: $(CFILES) query_capacity.h query_capacity_int.h query_capacity_data.h hcpi
else \
echo "Error: 'doxygen' not installed"; \
fi
-
+ -@if which cppcheck >/dev/null 2>&1; then \
cppcheck query_capacity*.[ch] 2>&1 | sed 's/^/ /'; \
else \
echo "cppcheck not available"; \
--
2.26.2

View File

@ -1,52 +0,0 @@
From f9f4404f0ee2f788d7ff195a50322a5480d72fed Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 22 Apr 2020 09:51:22 +0200
Subject: [PATCH 1/2] introduce DOCDIR
With a DOCDIR variable in the Makefile the distributions can set the docs
location to their preferred place.
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1306280
---
Makefile | 15 ++++++++-------
1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/Makefile b/Makefile
index 9f48fcb..700783a 100644
--- a/Makefile
+++ b/Makefile
@@ -6,6 +6,7 @@
# bugfix: Bugfixes only
VERSION = 2.1.0
VERM = $(shell echo $(VERSION) | cut -d '.' -f 1)
+DOCDIR ?= /usr/share/doc/packages/
CFLAGS ?= -g -Wall -O2
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c \
query_capacity_sysfs.c query_capacity_hypfs.c query_capacity_sthyi.c
@@ -72,16 +73,16 @@ install: libqc.a libqc.so.$(VERSION)
ln -sr $(DESTDIR)/usr/lib64/libqc.so.$(VERSION) $(DESTDIR)/usr/lib64/libqc.so.$(VERM)
ln -sr $(DESTDIR)/usr/lib64/libqc.so.$(VERSION) $(DESTDIR)/usr/lib64/libqc.so
install -Dm 644 query_capacity.h $(DESTDIR)/usr/include/query_capacity.h
- install -Dm 644 README $(DESTDIR)/usr/share/doc/packages/qclib/README
- install -Dm 644 LICENSE $(DESTDIR)/usr/share/doc/packages/qclib/LICENSE
+ install -Dm 644 README $(DESTDIR)/$(DOCDIR)/qclib/README
+ install -Dm 644 LICENSE $(DESTDIR)/$(DOCDIR)/qclib/LICENSE
installdoc: doc
echo " INSTALLDOC"
- install -dm 755 $(DESTDIR)/usr/share/doc/packages/qclib/html
- cp -r html/* $(DESTDIR)/usr/share/doc/packages/qclib/html
- chmod 644 $(DESTDIR)/usr/share/doc/packages/qclib/html/search/*
- chmod 644 $(DESTDIR)/usr/share/doc/packages/qclib/html/*
- chmod 755 $(DESTDIR)/usr/share/doc/packages/qclib/html/search
+ install -dm 755 $(DESTDIR)/$(DOCDIR)/qclib/html
+ cp -r html/* $(DESTDIR)/$(DOCDIR)/qclib/html
+ chmod 644 $(DESTDIR)/$(DOCDIR)/qclib/html/search/*
+ chmod 644 $(DESTDIR)/$(DOCDIR)/qclib/html/*
+ chmod 755 $(DESTDIR)/$(DOCDIR)/qclib/html/search
clean:
echo " CLEAN"
--
2.21.1

View File

@ -1,37 +0,0 @@
From 58e01a3e2f0c7f84a9942e34ef31ef17182e243f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 22 Apr 2020 09:53:52 +0200
Subject: [PATCH 2/2] introduce LDFLAGS
With an LDFLAGS variable distributions can pass their system-wide linker
options to the build.
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1552658
---
Makefile | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 700783a..4495356 100644
--- a/Makefile
+++ b/Makefile
@@ -8,6 +8,7 @@ VERSION = 2.1.0
VERM = $(shell echo $(VERSION) | cut -d '.' -f 1)
DOCDIR ?= /usr/share/doc/packages/
CFLAGS ?= -g -Wall -O2
+LDFLAGS ?=
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c \
query_capacity_sysfs.c query_capacity_hypfs.c query_capacity_sthyi.c
OBJECTS = $(patsubst %.c,%.o,$(CFILES))
@@ -41,7 +42,7 @@ libqc.a: $(OBJECTS)
$(AR) rcs $@ $^
libqc.so.$(VERSION): $(OBJECTS)
- $(LINK) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
+ $(LINK) $(LDFLAGS) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
-rm libqc.so.$(VERM) 2>/dev/null
ln -s libqc.so.$(VERSION) libqc.so.$(VERM)
--
2.21.1

View File

@ -0,0 +1,35 @@
From 88747097f3f6d2512811a7f9045f935e60b3cd44 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 23 Sep 2020 12:14:22 +0200
Subject: [PATCH 2/2] introduce MANDIR in Makefile
---
Makefile | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index 0e8bf31..a3ca5bd 100644
--- a/Makefile
+++ b/Makefile
@@ -13,6 +13,7 @@ CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c \
OBJECTS = $(patsubst %.c,%.o,$(CFILES))
.SUFFIXES: .o .c
DOCDIR ?= /usr/share/doc/packages/
+MANDIR ?= /usr/share/
ifneq ("${V}","1")
MAKEFLAGS += --quiet
@@ -126,8 +127,8 @@ install: libqc.a libqc.so.$(VERSION)
ln -sr $(DESTDIR)/usr/lib64/libqc.so.$(VERSION) $(DESTDIR)/usr/lib64/libqc.so
install -Dm 755 zname $(DESTDIR)/usr/bin/zname
install -Dm 755 zhypinfo $(DESTDIR)/usr/bin/zhypinfo
- install -Dm 644 zname.8 $(DESTDIR)/usr/share/man8/zname.8
- install -Dm 644 zhypinfo.8 $(DESTDIR)/usr/share/man8/zhypinfo.8
+ install -Dm 644 zname.8 $(DESTDIR)/$(MANDIR)/man8/zname.8
+ install -Dm 644 zhypinfo.8 $(DESTDIR)/$(MANDIR)/man8/zhypinfo.8
install -Dm 644 query_capacity.h $(DESTDIR)/usr/include/query_capacity.h
install -Dm 644 README $(DESTDIR)/$(DOCDIR)/qclib/README
install -Dm 644 LICENSE $(DESTDIR)/$(DOCDIR)/qclib/LICENSE
--
2.26.2

View File

@ -1,14 +1,12 @@
Name: qclib
Version: 2.1.0
Release: 2%{?dist}
Version: 2.2.0
Release: 1%{?dist}
Summary: Library for extraction of system information for Linux on z Systems
License: BSD
URL: http://www.ibm.com/developerworks/linux/linux390/qclib.html
Source0: http://public.dhe.ibm.com/software/dw/linux390/ht_src/%{name}-%{version}.tgz
# https://bugzilla.redhat.com/show_bug.cgi?id=1306280
Patch0: 0001-introduce-DOCDIR.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1552658
Patch1: 0002-introduce-LDFLAGS.patch
Patch0: 0001-add-missing-check-in-Makefile.patch
Patch1: 0002-introduce-MANDIR-in-Makefile.patch
ExclusiveArch: s390 s390x
BuildRequires: gcc
BuildRequires: glibc-static
@ -56,7 +54,7 @@ make V=1 CFLAGS="%{build_cflags}" LDFLAGS="%{build_ldflags}" %{?_smp_mflags} all
%install
%make_install DOCDIR=%{_docdir}
%make_install DOCDIR=%{_docdir} MANDIR=%{_mandir}
make DESTDIR=%{buildroot} DOCDIR=%{_docdir} installdoc
@ -68,7 +66,11 @@ make test-sh test
%dir %{_docdir}/%{name}
%license %{_docdir}/%{name}/LICENSE
%doc %{_docdir}/%{name}/README
%{_bindir}/zhypinfo
%{_bindir}/zname
%{_libdir}/libqc.so.*
%{_mandir}/man8/zhypinfo.8*
%{_mandir}/man8/zname.8*
%files devel
%doc %{_docdir}/%{name}/html/
@ -80,6 +82,9 @@ make test-sh test
%changelog
* Wed Sep 23 2020 Dan Horák <dan[at]danny.cz> - 2.2.0-1
- updated to 2.2.0
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (qclib-2.1.0.tgz) = acd21c63fe9d63fd290323dfcf4dd34e051ed565fd03c4b0e92a29478a13747e656e3341401c23deda7d31591c41d7a644a9b3cbecc110871dadbca8b0ee657e
SHA512 (qclib-2.2.0.tgz) = f364f9583545e362ab4ad9385b8d579143fd26414a742ed980e2fccefb1400875bcf281292d1968736af37d0aba773256c55a428f4e14d4629f6278bdd09c76b