- updated to 2.1.0
This commit is contained in:
parent
d688f0dbaf
commit
4c64cd2567
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
||||
/qclib-1.4.1.tgz
|
||||
/qclib-2.0.0.tgz
|
||||
/qclib-2.0.1.tgz
|
||||
/qclib-2.1.0.tgz
|
||||
|
@ -1,15 +1,29 @@
|
||||
diff -up qclib-1.3.1/Makefile.docdir qclib-1.3.1/Makefile
|
||||
--- qclib-1.3.1/Makefile.docdir 2017-10-24 07:02:42.000000000 +0200
|
||||
+++ qclib-1.3.1/Makefile 2017-12-04 14:15:08.000000000 +0100
|
||||
From f9f4404f0ee2f788d7ff195a50322a5480d72fed Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Wed, 22 Apr 2020 09:51:22 +0200
|
||||
Subject: [PATCH 1/2] introduce DOCDIR
|
||||
|
||||
With a DOCDIR variable in the Makefile the distributions can set the docs
|
||||
location to their preferred place.
|
||||
|
||||
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1306280
|
||||
---
|
||||
Makefile | 15 ++++++++-------
|
||||
1 file changed, 8 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 9f48fcb..700783a 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -6,6 +6,7 @@
|
||||
# bugfix: Bugfixes only
|
||||
VERSION = 2.0.1
|
||||
VERSION = 2.1.0
|
||||
VERM = $(shell echo $(VERSION) | cut -d '.' -f 1)
|
||||
+DOCDIR ?= /usr/share/doc/packages/
|
||||
CFLAGS ?= -g -Wall -O2
|
||||
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c query_capacity_ocf.c \
|
||||
query_capacity_hypfs.c query_capacity_sthyi.c
|
||||
@@ -69,16 +70,16 @@ install: libqc.a libqc.so.$(VERSION)
|
||||
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c \
|
||||
query_capacity_sysfs.c query_capacity_hypfs.c query_capacity_sthyi.c
|
||||
@@ -72,16 +73,16 @@ install: libqc.a libqc.so.$(VERSION)
|
||||
ln -sr $(DESTDIR)/usr/lib64/libqc.so.$(VERSION) $(DESTDIR)/usr/lib64/libqc.so.$(VERM)
|
||||
ln -sr $(DESTDIR)/usr/lib64/libqc.so.$(VERSION) $(DESTDIR)/usr/lib64/libqc.so
|
||||
install -Dm 644 query_capacity.h $(DESTDIR)/usr/include/query_capacity.h
|
||||
@ -33,3 +47,6 @@ diff -up qclib-1.3.1/Makefile.docdir qclib-1.3.1/Makefile
|
||||
|
||||
clean:
|
||||
echo " CLEAN"
|
||||
--
|
||||
2.21.1
|
||||
|
37
0002-introduce-LDFLAGS.patch
Normal file
37
0002-introduce-LDFLAGS.patch
Normal file
@ -0,0 +1,37 @@
|
||||
From 58e01a3e2f0c7f84a9942e34ef31ef17182e243f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Wed, 22 Apr 2020 09:53:52 +0200
|
||||
Subject: [PATCH 2/2] introduce LDFLAGS
|
||||
|
||||
With an LDFLAGS variable distributions can pass their system-wide linker
|
||||
options to the build.
|
||||
|
||||
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1552658
|
||||
---
|
||||
Makefile | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 700783a..4495356 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -8,6 +8,7 @@ VERSION = 2.1.0
|
||||
VERM = $(shell echo $(VERSION) | cut -d '.' -f 1)
|
||||
DOCDIR ?= /usr/share/doc/packages/
|
||||
CFLAGS ?= -g -Wall -O2
|
||||
+LDFLAGS ?=
|
||||
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c \
|
||||
query_capacity_sysfs.c query_capacity_hypfs.c query_capacity_sthyi.c
|
||||
OBJECTS = $(patsubst %.c,%.o,$(CFILES))
|
||||
@@ -41,7 +42,7 @@ libqc.a: $(OBJECTS)
|
||||
$(AR) rcs $@ $^
|
||||
|
||||
libqc.so.$(VERSION): $(OBJECTS)
|
||||
- $(LINK) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
|
||||
+ $(LINK) $(LDFLAGS) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
|
||||
-rm libqc.so.$(VERM) 2>/dev/null
|
||||
ln -s libqc.so.$(VERSION) libqc.so.$(VERM)
|
||||
|
||||
--
|
||||
2.21.1
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -up qclib-1.3.1/Makefile.ldflags qclib-1.3.1/Makefile
|
||||
--- qclib-1.3.1/Makefile.ldflags 2018-03-12 10:36:52.428425169 +0100
|
||||
+++ qclib-1.3.1/Makefile 2018-03-12 10:37:27.328425169 +0100
|
||||
@@ -8,6 +8,7 @@ VERSION = 1.3.1
|
||||
VERM = $(shell echo $(VERSION) | cut -d '.' -f 1)
|
||||
DOCDIR ?= /usr/share/doc/packages/
|
||||
CFLAGS ?= -g -Wall -O2
|
||||
+LDFLAGS ?=
|
||||
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c query_capacity_ocf.c \
|
||||
query_capacity_hypfs.c query_capacity_sthyi.c
|
||||
OBJECTS = $(patsubst %.c,%.o,$(CFILES))
|
||||
@@ -38,7 +39,7 @@ libqc.a: $(OBJECTS)
|
||||
$(AR) rcs $@ $^
|
||||
|
||||
libqc.so.$(VERSION): $(OBJECTS)
|
||||
- $(LINK) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
|
||||
+ $(LINK) $(LDFLAGS) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
|
||||
-rm libqc.so.$(VERM) 2>/dev/null
|
||||
ln -s libqc.so.$(VERSION) libqc.so.$(VERM)
|
||||
|
11
qclib.spec
11
qclib.spec
@ -1,14 +1,14 @@
|
||||
Name: qclib
|
||||
Version: 2.0.1
|
||||
Release: 2%{?dist}
|
||||
Version: 2.1.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Library for extraction of system information for Linux on z Systems
|
||||
License: BSD
|
||||
URL: http://www.ibm.com/developerworks/linux/linux390/qclib.html
|
||||
Source0: http://public.dhe.ibm.com/software/dw/linux390/ht_src/%{name}-%{version}.tgz
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1306280
|
||||
Patch0: %{name}-2.0.0-docdir.patch
|
||||
Patch0: 0001-introduce-DOCDIR.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1552658
|
||||
Patch1: %{name}-1.3.1-ldflags.patch
|
||||
Patch1: 0002-introduce-LDFLAGS.patch
|
||||
ExclusiveArch: s390 s390x
|
||||
BuildRequires: gcc
|
||||
BuildRequires: glibc-static
|
||||
@ -80,6 +80,9 @@ make test-sh test
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 22 2020 Dan Horák <dan[at]danny.cz> - 2.1.0-1
|
||||
- updated to 2.1.0
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (qclib-2.0.1.tgz) = 17b23cc2ab312846acbba791620e1622cbbca17931884bf7b7857096c50147510de602bb34f3c12db64d3040617daa5e607d7c8955c22cfff2295c489b0f04ee
|
||||
SHA512 (qclib-2.1.0.tgz) = acd21c63fe9d63fd290323dfcf4dd34e051ed565fd03c4b0e92a29478a13747e656e3341401c23deda7d31591c41d7a644a9b3cbecc110871dadbca8b0ee657e
|
||||
|
Loading…
Reference in New Issue
Block a user